aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-15 10:40:27 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-18 10:30:32 +0200
commit60fd1623f8cf55042d6c242e4f27893456817718 (patch)
tree401e83d30b12093cbdbd63535c93f6b23604fb41
parent9b774251418fe62b302c4a7a6e5481c7e7deac32 (diff)
downloadalpine_aports-60fd1623f8cf55042d6c242e4f27893456817718.tar.bz2
alpine_aports-60fd1623f8cf55042d6c242e4f27893456817718.tar.xz
alpine_aports-60fd1623f8cf55042d6c242e4f27893456817718.zip
testing/radare2: upgrade to 2.6.0
-rw-r--r--testing/radare2/0001-fix-for-build-with-syscapstone.patch37
-rw-r--r--testing/radare2/0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch38
-rw-r--r--testing/radare2/0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch30
-rw-r--r--testing/radare2/APKBUILD14
4 files changed, 115 insertions, 4 deletions
diff --git a/testing/radare2/0001-fix-for-build-with-syscapstone.patch b/testing/radare2/0001-fix-for-build-with-syscapstone.patch
new file mode 100644
index 0000000000..04bbaed49d
--- /dev/null
+++ b/testing/radare2/0001-fix-for-build-with-syscapstone.patch
@@ -0,0 +1,37 @@
1From 032a5cacd98d86414dffee61265a567df10c48e2 Mon Sep 17 00:00:00 2001
2From: cc <longlene@gmail.com>
3Date: Tue, 22 May 2018 12:52:12 +0800
4Subject: [PATCH 1/3] fix for build with syscapstone
5
6---
7 libr/Makefile | 9 +++++++--
8 1 file changed, 7 insertions(+), 2 deletions(-)
9
10diff --git a/libr/Makefile b/libr/Makefile
11index 05cb40fec..0b39b48c0 100644
12--- a/libr/Makefile
13+++ b/libr/Makefile
14@@ -84,13 +84,18 @@ E+=../shlr/bochs/lib/libbochs.${EXT_AR}
15 #E+=../shlr/sdb/src/libsdb.${EXT_AR}
16 #endif
17
18+ifeq ($(USE_CAPSTONE),1)
19+E+=$(CAPSTONE_LDFLAGS)
20+else
21+E+=../shlr/capstone/libcapstone.${EXT_AR}
22+endif
23+
24 libr.${EXT_SO}: .libr
25 $(CC) -fvisibility=hidden $(MLFLAGS) -shared -dynamiclib -o libr.${EXT_SO} \
26 .libr/*.o \
27 ../shlr/gdb/lib/libgdbr.${EXT_AR} ../shlr/java/libr_java.${EXT_AR} \
28 ../shlr/zip/librz.${EXT_AR} \
29- ../shlr/libr_shlr.${EXT_AR} $(E)\
30- ../shlr/capstone/libcapstone.${EXT_AR}
31+ ../shlr/libr_shlr.${EXT_AR} $(E)
32
33 else
34
35--
362.17.1
37
diff --git a/testing/radare2/0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch b/testing/radare2/0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
new file mode 100644
index 0000000000..63c2e4ddde
--- /dev/null
+++ b/testing/radare2/0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
@@ -0,0 +1,38 @@
1From dcb863e18f619137c3fe040f632adccb13d07a09 Mon Sep 17 00:00:00 2001
2From: Levente Polyak <levente@leventepolyak.net>
3Date: Wed, 23 May 2018 11:13:26 +0200
4Subject: [PATCH 2/3] libc: respect zip/deps.mk for zlib/libzip (#10163)
5
6Additionally respect standard caller {C,CPP,LD}FLAGS plus the
7deps.mk relaed LINK
8---
9 libr/Makefile | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/libr/Makefile b/libr/Makefile
13index 0b39b48c0..0d0257708 100644
14--- a/libr/Makefile
15+++ b/libr/Makefile
16@@ -3,6 +3,7 @@ include config.mk
17 include ../config-user.mk
18 include ../mk/platform.mk
19 include ../mk/${COMPILER}.mk
20+include ${SHLR}/zip/deps.mk
21
22 DESTDIR:=$(DESTDIR)
23 PREFIX?=${PWD}/../prefix
24@@ -91,10 +92,9 @@ E+=../shlr/capstone/libcapstone.${EXT_AR}
25 endif
26
27 libr.${EXT_SO}: .libr
28- $(CC) -fvisibility=hidden $(MLFLAGS) -shared -dynamiclib -o libr.${EXT_SO} \
29+ $(CC) -fvisibility=hidden $(MLFLAGS) ${LINK} ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -shared -dynamiclib -o libr.${EXT_SO} \
30 .libr/*.o \
31 ../shlr/gdb/lib/libgdbr.${EXT_AR} ../shlr/java/libr_java.${EXT_AR} \
32- ../shlr/zip/librz.${EXT_AR} \
33 ../shlr/libr_shlr.${EXT_AR} $(E)
34
35 else
36--
372.17.1
38
diff --git a/testing/radare2/0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch b/testing/radare2/0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch
new file mode 100644
index 0000000000..a4d5562d19
--- /dev/null
+++ b/testing/radare2/0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch
@@ -0,0 +1,30 @@
1From ff045066c141efc56697ea0ca0a29f8960267bd3 Mon Sep 17 00:00:00 2001
2From: Levente Polyak <levente@leventepolyak.net>
3Date: Wed, 30 May 2018 16:57:45 +0200
4Subject: [PATCH 3/3] make: don't dist .${LIBVERSION} into /usr/lib (#10164)
5
6Not exlucidng ^libr.{so,dynlin}$ doesn't do any good and will purely
7result in distributing a .${LIBVERSION} into $DESTDIR
8f.e. /usr/lib/.2.6.0
9
10Introduced by: 8bab02
11---
12 libr/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/libr/Makefile b/libr/Makefile
16index 0d0257708..7e75a3a1e 100644
17--- a/libr/Makefile
18+++ b/libr/Makefile
19@@ -171,7 +171,7 @@ install: install-includes install-pkgconfig
20 # TODO :Use INSTALL_DATA_DIR instead of mkdir
21 # libraries
22 @${INSTALL_DIR} "${DESTDIR}${LIBDIR}"
23- @$(foreach lib,$(shell find * -type f -iname "*.${EXT_SO}" | grep -v '(lib|parse)/t/' | grep lib | grep -v /bin/ | grep -v /p/), \
24+ @$(foreach lib,$(shell find * -type f -iname "*.${EXT_SO}" | grep -vE '^libr\.${EXT_SO}$$' | grep -v '(lib|parse)/t/' | grep lib | grep -v /bin/ | grep -v /p/), \
25 echo " ${DESTDIR}${LIBDIR}/$(call libpath-to-name-version,$(lib),${LIBVERSION})"; \
26 rm -f "${DESTDIR}${LIBDIR}/$(call libpath-to-name-version,$(lib),${LIBVERSION})"; \
27 ${INSTALL_LIB} "$(lib)" "${DESTDIR}${LIBDIR}/$(call libpath-to-name-version,$(lib),${LIBVERSION})"; \
28--
292.17.1
30
diff --git a/testing/radare2/APKBUILD b/testing/radare2/APKBUILD
index 756a7b4e10..738d583085 100644
--- a/testing/radare2/APKBUILD
+++ b/testing/radare2/APKBUILD
@@ -4,8 +4,8 @@
4# Contributor: Jose-Luis Rivas <ghostbar@riseup.net> 4# Contributor: Jose-Luis Rivas <ghostbar@riseup.net>
5# Maintainer: Valery Kartel <valery.kartel@gmail.com> 5# Maintainer: Valery Kartel <valery.kartel@gmail.com>
6pkgname=radare2 6pkgname=radare2
7pkgver=2.3.0 7pkgver=2.6.0
8pkgrel=1 8pkgrel=0
9pkgdesc="An opensource, crossplatform reverse engineering framework" 9pkgdesc="An opensource, crossplatform reverse engineering framework"
10url="http://www.radare.org" 10url="http://www.radare.org"
11arch="all !aarch64" 11arch="all !aarch64"
@@ -16,7 +16,10 @@ depends_dev=""
16makedepends="$depends_dev libzip-dev libressl-dev capstone-dev linux-headers" 16makedepends="$depends_dev libzip-dev libressl-dev capstone-dev linux-headers"
17install="" 17install=""
18subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-libs" 18subpackages="$pkgname-dev $pkgname-doc $pkgname-dbg $pkgname-libs"
19source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pkgver}.tar.gz" 19source="$pkgname-$pkgver.tar.gz::https://github.com/radare/$pkgname/archive/${pkgver}.tar.gz
20 0001-fix-for-build-with-syscapstone.patch
21 0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
22 0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch"
20builddir="$srcdir"/$pkgname-$pkgver 23builddir="$srcdir"/$pkgname-$pkgver
21 24
22build() { 25build() {
@@ -41,4 +44,7 @@ package() {
41 make DESTDIR="$pkgdir" install 44 make DESTDIR="$pkgdir" install
42} 45}
43 46
44sha512sums="4b52ae3678c5bbba1d173f95715807469e88603067faf4f1058606a4235050ec07aebdb6408e24c0c031b9554b4ca095bf77fc2791a9efa498dfff49200b3b1d radare2-2.3.0.tar.gz" 47sha512sums="44e7d0c10e17b40d4d71af851cf462c159b03b3242dfccd786bd54d3cf9f92441084f26694166dd1385e84c00626f45dbe09d1fe713595721723c468ac47b01b radare2-2.6.0.tar.gz
483d7500e805d14cbe12b856a57c2d6efb37c968210f1bfc6bfea4517a9234b02fc0e924c6c9fd9475d05b18a998abaed642cc5714b996f9d02c07d74e81f17c10 0001-fix-for-build-with-syscapstone.patch
492f91f1718784ad77449596e828847d215556b2409a4c83f2d8d895c6b1d41f8b94f25d9450d15b595d008e8587c1eb687a0a8d8b4777a4a9b64411a0f6549c9d 0002-libc-respect-zip-deps.mk-for-zlib-libzip-10163.patch
50d7ee63b301a6191eb0504b50ee19e3aaadd3fdd08389c9d043dcade8c0115bc862464899c1e0607f860f21e5e890cdd416362cbc4b098e149ecdba765e8f4548 0003-make-don-t-dist-.-LIBVERSION-into-usr-lib-10164.patch"