aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-18 09:50:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-18 09:51:24 +0000
commit988c3763e7f52ca6f399513e7c893d4e2340b957 (patch)
treec54682142f372e6c591acf1ac044aae7bcaea929
parent02c5be0411e10660cb62e374e692fa8ac7d4fa7c (diff)
downloadalpine_aports-988c3763e7f52ca6f399513e7c893d4e2340b957.tar.bz2
alpine_aports-988c3763e7f52ca6f399513e7c893d4e2340b957.tar.xz
alpine_aports-988c3763e7f52ca6f399513e7c893d4e2340b957.zip
main/graphite2: build fix for x86
we need -lssp_nonshared on alpine x86
-rw-r--r--main/graphite2/APKBUILD6
-rw-r--r--main/graphite2/cmake.patch29
2 files changed, 20 insertions, 15 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 512ce732b4..cb8c41e763 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -3,7 +3,7 @@
3pkgname=graphite2 3pkgname=graphite2
4_realname=${pkgname/2/} 4_realname=${pkgname/2/}
5pkgver=1.3.11 5pkgver=1.3.11
6pkgrel=0 6pkgrel=1
7pkgdesc="reimplementation of the SIL Graphite text processing engine" 7pkgdesc="reimplementation of the SIL Graphite text processing engine"
8url="http://graphite.sil.org/" 8url="http://graphite.sil.org/"
9arch="all" 9arch="all"
@@ -16,6 +16,7 @@ install=""
16subpackages="$pkgname-static $pkgname-dev" 16subpackages="$pkgname-static $pkgname-dev"
17source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz 17source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
18 graphite2-1.2.0-cmakepath.patch 18 graphite2-1.2.0-cmakepath.patch
19 cmake.patch
19 " 20 "
20 21
21builddir="$srcdir"/$_realname-$pkgver 22builddir="$srcdir"/$_realname-$pkgver
@@ -69,4 +70,5 @@ package() {
69} 70}
70 71
71sha512sums="53c5e9442900bc4d8a1b45be5198c25a82e34b077d62ff11036f5f4bfc69906891a16dbc17d521fafe8738ef9363cbacd201e1848221cdd70c5c40a59c4ab03f graphite2-1.3.11.tar.gz 72sha512sums="53c5e9442900bc4d8a1b45be5198c25a82e34b077d62ff11036f5f4bfc69906891a16dbc17d521fafe8738ef9363cbacd201e1848221cdd70c5c40a59c4ab03f graphite2-1.3.11.tar.gz
724ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch" 734ef5414e6d554bb8d6ead435e38d061a073f350c313b7141158bb68332f5f57ca5250385875a387b828bb657964588e974143b96b5e11c2cd314871e7baddb88 graphite2-1.2.0-cmakepath.patch
74f6630138d67764b8240819125810544cf5ad89554b298de9762e5e05e85f9df719d957ac3f2e7a2c4e201cc6d58544f196d742b93fc2c5754db3c3ffe663492d cmake.patch"
diff --git a/main/graphite2/cmake.patch b/main/graphite2/cmake.patch
index 41f1e51876..ffafa17d4a 100644
--- a/main/graphite2/cmake.patch
+++ b/main/graphite2/cmake.patch
@@ -1,13 +1,16 @@
1--- ./tests/CMakeLists.txt.orig 1--- graphite2-1.2.0/src/CMakeLists.txt.orig 2012-11-09 17:48:04.908391335 +0800
2+++ ./tests/CMakeLists.txt 2+++ graphite2-1.2.0/src/CMakeLists.txt 2012-11-09 17:48:48.647102280 +0800
3@@ -58,7 +58,9 @@ 3@@ -118,11 +118,7 @@
4 LINKER_LANGUAGE C) 4 if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
5 endif (${CMAKE_SYSTEM_NAME} STREQUAL "Windows") 5 target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
6 6 else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
7-add_subdirectory(comparerenderer) 7- if (GRAPHITE2_ASAN)
8+if (GRAPHITE2_COMPARE_RENDERER) 8- target_link_libraries(graphite2 c gcc_s)
9+ add_subdirectory(comparerenderer) 9- else (GRAPHITE2_ASAN)
10+endif (GRAPHITE2_COMPARE_RENDERER) 10- target_link_libraries(graphite2 c gcc)
11 add_subdirectory(endian) 11- endif (GRAPHITE2_ASAN)
12 add_subdirectory(bittwiddling) 12+ target_link_libraries(graphite2 c gcc_s -lssp_nonshared)
13 if (NOT GRAPHITE2_NFILEFACE) 13 include(Graphite)
14 nolib_test(stdc++ $<TARGET_SONAME_FILE:graphite2>)
15 endif (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
16