aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-17 14:28:13 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-17 14:23:18 +0200
commitf49ce14f0bbc45d0913d83b7015e13f880146f92 (patch)
treee355cec03155f0c2092644afc6058e05286495bb
parent824bb08c5d3e74eb9d15b2585db76b6ad6d157f1 (diff)
downloadalpine_aports-f49ce14f0bbc45d0913d83b7015e13f880146f92.tar.bz2
alpine_aports-f49ce14f0bbc45d0913d83b7015e13f880146f92.tar.xz
alpine_aports-f49ce14f0bbc45d0913d83b7015e13f880146f92.zip
community/ruby-nokogiri: fix tests and enable check
-rw-r--r--community/ruby-nokogiri/APKBUILD8
-rw-r--r--community/ruby-nokogiri/skip-tests-broken-on-musl.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/community/ruby-nokogiri/APKBUILD b/community/ruby-nokogiri/APKBUILD
index 65ac7c920c..92df53a1e8 100644
--- a/community/ruby-nokogiri/APKBUILD
+++ b/community/ruby-nokogiri/APKBUILD
@@ -12,9 +12,10 @@ depends="ruby ruby-mini_portile2"
12makedepends="ruby-dev libxml2-dev libxslt-dev" 12makedepends="ruby-dev libxml2-dev libxslt-dev"
13checkdepends="ruby-minitest" 13checkdepends="ruby-minitest"
14source="https://rubygems.org/downloads/$_gemname-$pkgver.gem 14source="https://rubygems.org/downloads/$_gemname-$pkgver.gem
15 fix-extconf.patch" 15 fix-extconf.patch
16 skip-tests-broken-on-musl.patch
17 "
16builddir="$srcdir/$_gemname-$pkgver" 18builddir="$srcdir/$_gemname-$pkgver"
17options="!check" # FIXME: some tests fails due to encoding issues
18 19
19unpack() { 20unpack() {
20 default_unpack 21 default_unpack
@@ -80,4 +81,5 @@ package() {
80} 81}
81 82
82sha512sums="4825cc19667393c41a0c5a662474556991da3955fb17e67a363f979da8fadf0680eb4f89a7c87b71f6deba9db64e67bd463d5562d58604ea71a168abb8215eed nokogiri-1.8.3.gem 83sha512sums="4825cc19667393c41a0c5a662474556991da3955fb17e67a363f979da8fadf0680eb4f89a7c87b71f6deba9db64e67bd463d5562d58604ea71a168abb8215eed nokogiri-1.8.3.gem
83514cc33109357457dfd7739991f3d270fe62a26313a5dfed0f539e89e4ed8de7dd08744540c7becc93ad12e6d096f2c4b4c3fb15f47b827a65352b895ab62a89 fix-extconf.patch" 84514cc33109357457dfd7739991f3d270fe62a26313a5dfed0f539e89e4ed8de7dd08744540c7becc93ad12e6d096f2c4b4c3fb15f47b827a65352b895ab62a89 fix-extconf.patch
855f92d4cf87751c404a33dfbdc035dd5b54163eccdc46b4f515e6d6367a9573cf3fc4ef3c12c5b9e099b20f6c563d5a573acb1c2716890e492bfb26aa91f2cb5d skip-tests-broken-on-musl.patch"
diff --git a/community/ruby-nokogiri/skip-tests-broken-on-musl.patch b/community/ruby-nokogiri/skip-tests-broken-on-musl.patch
new file mode 100644
index 0000000000..f07717a98a
--- /dev/null
+++ b/community/ruby-nokogiri/skip-tests-broken-on-musl.patch
@@ -0,0 +1,10 @@
1--- a/test/html/test_document_encoding.rb
2+++ b/test/html/test_document_encoding.rb
3@@ -19,6 +19,7 @@
4 end
5
6 def test_encoding_without_charset
7+ skip 'Not supported on musl'
8 doc = Nokogiri::HTML File.open(SHIFT_JIS_NO_CHARSET, 'r:cp932:cp932').read
9
10 hello = "こんにちは"