aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMick Tarsel <mtarsel@gmail.com>2018-06-20 02:18:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-21 07:44:55 +0000
commitbec7d16f8e9f5e9adf961a65a5a1f4b10bb5c9d2 (patch)
tree0776ca65ed012f6dd8bd8cf0980ef5b4b5448d4f
parent13c8df96b709df7ae190b537f6caab4cae1c62b0 (diff)
downloadalpine_aports-bec7d16f8e9f5e9adf961a65a5a1f4b10bb5c9d2.tar.bz2
alpine_aports-bec7d16f8e9f5e9adf961a65a5a1f4b10bb5c9d2.tar.xz
alpine_aports-bec7d16f8e9f5e9adf961a65a5a1f4b10bb5c9d2.zip
main/openrc: Allow http:// for ssh_key
A slight revert of commit 4ef156921798938 which removed http://* Since the kernel argument is downloading the public key, we are not required to use an encrypted protocol. This will also be easier for a local development environment.
-rw-r--r--main/openrc/APKBUILD4
-rw-r--r--main/openrc/firstboot.initd2
2 files changed, 3 insertions, 3 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index 7d2da953b2..0c3016fd82 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
2pkgname=openrc 2pkgname=openrc
3pkgver=0.35.5 3pkgver=0.35.5
4_ver=${pkgver/_git*/} 4_ver=${pkgver/_git*/}
5pkgrel=3 5pkgrel=4
6pkgdesc="OpenRC manages the services, startup and shutdown of a host" 6pkgdesc="OpenRC manages the services, startup and shutdown of a host"
7url="https://gitweb.gentoo.org/proj/openrc.git" 7url="https://gitweb.gentoo.org/proj/openrc.git"
8arch="all" 8arch="all"
@@ -96,4 +96,4 @@ b04058ec630e19de0bafefe06198dc1bff8c8d5d2c89e4660dd83dda8bb82a76cdb1d8661cce88e4
9655df0ac13dac1f215f0c573ac07b150d31232a5204eccfc8941d5af73f91b4535a85d79b7f6514217038ecbe6bffa28cb83fd8d46fd4c596e07103deb8bc8a57 networking.initd 9655df0ac13dac1f215f0c573ac07b150d31232a5204eccfc8941d5af73f91b4535a85d79b7f6514217038ecbe6bffa28cb83fd8d46fd4c596e07103deb8bc8a57 networking.initd
9780e43ded522e2d48b876131c7c9997debd43f3790e0985801a8c1dd60bc6e09f625b35a127bf225eb45a65eec7808a50d1c08a5e8abceafc61726211e061e0a2 modloop.confd 9780e43ded522e2d48b876131c7c9997debd43f3790e0985801a8c1dd60bc6e09f625b35a127bf225eb45a65eec7808a50d1c08a5e8abceafc61726211e061e0a2 modloop.confd
98d76c75c58e6f4b0801edac4e081b725ef3d50a9a8c9bbb5692bf4d0f804af7d383bf71a73d5d03ed348a89741ef0b2427eb6a7cbf5a9b9ff60a240639fa6ec88 sysfsconf.initd 98d76c75c58e6f4b0801edac4e081b725ef3d50a9a8c9bbb5692bf4d0f804af7d383bf71a73d5d03ed348a89741ef0b2427eb6a7cbf5a9b9ff60a240639fa6ec88 sysfsconf.initd
99be0b1c7a73287bd958a3ddf56fee12adc9343adcfe6b6c851d38c4851a6260b28d0e9e4da2edf2c1ac9a1d42e0c7f2e4f2c343aa45539ba469da49ba13b95521 firstboot.initd" 99f65b061b4272463071022e88a7392d5573f2d95f91e42c8b4f3ef69171604460ddd3d426dfbab382f73a3fac68d4b4ff3a923fdc49fb6fd9f27ebd3ab24e0d0e firstboot.initd"
diff --git a/main/openrc/firstboot.initd b/main/openrc/firstboot.initd
index 4c26a815c8..27f2c1f374 100644
--- a/main/openrc/firstboot.initd
+++ b/main/openrc/firstboot.initd
@@ -21,7 +21,7 @@ start() {
21 einfo "Fetching ssh keys" 21 einfo "Fetching ssh keys"
22 mkdir -pm 700 /root/.ssh 22 mkdir -pm 700 /root/.ssh
23 case "$KOPT_ssh_key" in 23 case "$KOPT_ssh_key" in
24 https://*|ftps://*) 24 https://*|ftps://*|http://*)
25 wget -q "$KOPT_ssh_key" -O /root/.ssh/authorized_keys 25 wget -q "$KOPT_ssh_key" -O /root/.ssh/authorized_keys
26 rc=$?;; 26 rc=$?;;
27 *) echo "$KOPT_ssh_key" > /root/.ssh/authorized_keys;; 27 *) echo "$KOPT_ssh_key" > /root/.ssh/authorized_keys;;