aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-06-21 06:55:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-21 07:44:55 +0000
commiteee35447587632660770b5debf34cb762295740a (patch)
tree95d7cff14ff4e8bf6465f09c17a2c2ebb3431eaa
parentbec7d16f8e9f5e9adf961a65a5a1f4b10bb5c9d2 (diff)
downloadalpine_aports-eee35447587632660770b5debf34cb762295740a.tar.bz2
alpine_aports-eee35447587632660770b5debf34cb762295740a.tar.xz
alpine_aports-eee35447587632660770b5debf34cb762295740a.zip
main/alpine-conf: fix firmware install in update-kernel
-rw-r--r--main/alpine-conf/0001-update-kernel-fix-install-of-firware.patch30
-rw-r--r--main/alpine-conf/APKBUILD6
2 files changed, 34 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-update-kernel-fix-install-of-firware.patch b/main/alpine-conf/0001-update-kernel-fix-install-of-firware.patch
new file mode 100644
index 0000000000..ba842d7714
--- /dev/null
+++ b/main/alpine-conf/0001-update-kernel-fix-install-of-firware.patch
@@ -0,0 +1,30 @@
1From 3342db32fa783c69188057ac182538fd4277979b Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Thu, 21 Jun 2018 06:11:28 +0000
4Subject: [PATCH] update-kernel: fix install of firware
5
6prevent to exit with error due to set -e, if last firmware does not have
7a *.txt file.
8---
9 update-kernel.in | 5 +++--
10 1 file changed, 3 insertions(+), 2 deletions(-)
11
12diff --git a/update-kernel.in b/update-kernel.in
13index aaf1cff..4267042 100644
14--- a/update-kernel.in
15+++ b/update-kernel.in
16@@ -252,8 +252,9 @@ find $ROOT/lib/modules -type f -name "*.ko" | xargs modinfo -F firmware | sort -
17 if [ -e "$ROOT/lib/firmware/$FW" ]; then
18 install -pD $ROOT/lib/firmware/$FW $MODLOOP/modules/firmware/$FW
19 # include nvram files if firmware is needed.
20- [ -e "$ROOT/lib/firmware/${FW%.*}.txt" ] && install -pD \
21- $ROOT/lib/firmware/${FW%.*}.txt $MODLOOP/modules/firmware/${FW%.*}.txt
22+ if [ -e "$ROOT/lib/firmware/${FW%.*}.txt" ]; then
23+ install -pD $ROOT/lib/firmware/${FW%.*}.txt $MODLOOP/modules/firmware/${FW%.*}.txt
24+ fi
25 fi
26 done
27
28--
292.17.1
30
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 45ec59f46f..762144ae7e 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-conf 2pkgname=alpine-conf
3pkgver=3.8.0_rc2 3pkgver=3.8.0_rc2
4pkgrel=1 4pkgrel=2
5pkgdesc="Alpine configuration management scripts" 5pkgdesc="Alpine configuration management scripts"
6url=http://git.alpinelinux.org/cgit/$pkgname 6url=http://git.alpinelinux.org/cgit/$pkgname
7arch="all" 7arch="all"
@@ -9,6 +9,7 @@ license="MIT"
9depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3" 9depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3"
10source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz 10source="http://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.xz
11 0001-update-kernel-add-additional-firmware-files.patch 11 0001-update-kernel-add-additional-firmware-files.patch
12 0001-update-kernel-fix-install-of-firware.patch
12 " 13 "
13 14
14builddir="$srcdir"/$pkgname-$pkgver 15builddir="$srcdir"/$pkgname-$pkgver
@@ -26,4 +27,5 @@ package() {
26} 27}
27 28
28sha512sums="3b5224c2484b47c858fcea9fca0d2a1a73db7151ae8ed02480ae05dea35eb6f5ed4c2ffd887686cd43ac701948319c74e2cb8ccb1ada4f64ab9c8c350a241208 alpine-conf-3.8.0_rc2.tar.xz 29sha512sums="3b5224c2484b47c858fcea9fca0d2a1a73db7151ae8ed02480ae05dea35eb6f5ed4c2ffd887686cd43ac701948319c74e2cb8ccb1ada4f64ab9c8c350a241208 alpine-conf-3.8.0_rc2.tar.xz
29faffb4d2e6da15f631211e36fdd8cdaedae91e8c00e09055f17130fef7ce073fadfa78deebedb1877768c1707fc1e0a2741496dea5b0831b2f2b12cef23555de 0001-update-kernel-add-additional-firmware-files.patch" 30faffb4d2e6da15f631211e36fdd8cdaedae91e8c00e09055f17130fef7ce073fadfa78deebedb1877768c1707fc1e0a2741496dea5b0831b2f2b12cef23555de 0001-update-kernel-add-additional-firmware-files.patch
31d6e9ce6935dbde887f8feaabe8f97ff05a823cc7d8c3f72d27fb67dbfdb2d2c39e7c6adea4d3c0a9c0d1497be4921c98a0c7be28734e034d5bb58ffbe6ab03ad 0001-update-kernel-fix-install-of-firware.patch"