aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-25 13:49:14 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-12-07 17:18:48 +0100
commit381c6cd1afe00ba6028bd899220e0d229dc35d92 (patch)
tree7773df2fa2ac5e0114e59778408182c92507e101
parent7a2897f5fb53f23d6d00a7b63c4a7a2771887bb7 (diff)
downloadalpine_aports-381c6cd1afe00ba6028bd899220e0d229dc35d92.tar.bz2
alpine_aports-381c6cd1afe00ba6028bd899220e0d229dc35d92.tar.xz
alpine_aports-381c6cd1afe00ba6028bd899220e0d229dc35d92.zip
community/php5: backport dependency fixes from edge
-rw-r--r--community/php5/APKBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/php5/APKBUILD b/community/php5/APKBUILD
index dcde76a631..fad85a675b 100644
--- a/community/php5/APKBUILD
+++ b/community/php5/APKBUILD
@@ -4,7 +4,7 @@
4# Maintainer: Matt Smith <mcs@darkregion.net> 4# Maintainer: Matt Smith <mcs@darkregion.net>
5pkgname=php5 5pkgname=php5
6pkgver=5.6.38 6pkgver=5.6.38
7pkgrel=0 7pkgrel=1
8pkgdesc="The PHP language runtime engine" 8pkgdesc="The PHP language runtime engine"
9url="http://www.php.net/" 9url="http://www.php.net/"
10arch="all" 10arch="all"
@@ -12,7 +12,7 @@ license="PHP-3.0"
12depends="$pkgname-cli" 12depends="$pkgname-cli"
13depends_dev="$pkgname-cli pcre-dev" 13depends_dev="$pkgname-cli pcre-dev"
14install="$pkgname.post-upgrade" 14install="$pkgname.post-upgrade"
15provides="$pkgname-cli php-cli php" 15provides="php"
16makedepends=" 16makedepends="
17 $depends_dev 17 $depends_dev
18 apache2-dev 18 apache2-dev
@@ -108,7 +108,7 @@ subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-common::noarch $pkg
108 $pkgname-opcache 108 $pkgname-opcache
109 " 109 "
110 110
111source="http://php.net/distributions/php-$pkgver.tar.bz2 111source="https://php.net/distributions/php-$pkgver.tar.bz2
112 php-fpm.initd 112 php-fpm.initd
113 php5-module.conf 113 php5-module.conf
114 php-install-pear-xml.patch 114 php-install-pear-xml.patch
@@ -169,6 +169,10 @@ _do_build() {
169 cd "$_builddir" 169 cd "$_builddir"
170 export EXTENSION_DIR=$_extdir 170 export EXTENSION_DIR=$_extdir
171 export PEAR_INSTALLDIR="$_peardir" 171 export PEAR_INSTALLDIR="$_peardir"
172
173 #http://source.icu-project.org/repos/icu/trunk/icu4c/readme.html#RecBuild
174 export CPPFLAGS="$CPPFLAGS -DU_USING_ICU_NAMESPACE=1"
175
172 "$_srcdir"/configure $@ || return 1 176 "$_srcdir"/configure $@ || return 1
173 sed -ri "s/^(EXTRA_LDFLAGS[ ]*\=.*)/\1 -lpthread/" Makefile # see #183 177 sed -ri "s/^(EXTRA_LDFLAGS[ ]*\=.*)/\1 -lpthread/" Makefile # see #183
174 make || return 1 178 make || return 1
@@ -371,6 +375,7 @@ cgi() {
371cli() { 375cli() {
372 pkgdesc="PHP Command Line Interface (CLI)" 376 pkgdesc="PHP Command Line Interface (CLI)"
373 depends="$pkgname-common" 377 depends="$pkgname-common"
378 provides="php-cli"
374 mkdir -p "$subpkgdir"/usr/bin 379 mkdir -p "$subpkgdir"/usr/bin
375 mv "$pkgdir"/usr/bin/php5 "$subpkgdir"/usr/bin/ || return 1 380 mv "$pkgdir"/usr/bin/php5 "$subpkgdir"/usr/bin/ || return 1
376 # provide phpize here instead of -dev due to pecl command 381 # provide phpize here instead of -dev due to pecl command
@@ -432,6 +437,7 @@ pear() {
432 437
433phpdbg() { 438phpdbg() {
434 pkgdesc="Interactive PHP debugger" 439 pkgdesc="Interactive PHP debugger"
440 depends="$pkgname-common"
435 provides="php-phpdbg" 441 provides="php-phpdbg"
436 mkdir -p "$subpkgdir"/usr/bin 442 mkdir -p "$subpkgdir"/usr/bin
437 mv "$pkgdir"/usr/bin/phpdbg* "$subpkgdir"/usr/bin/ 443 mv "$pkgdir"/usr/bin/phpdbg* "$subpkgdir"/usr/bin/
@@ -442,12 +448,12 @@ _mv_ext() {
442 local ini=$ext.ini 448 local ini=$ext.ini
443 pkgdesc="${ext} extension for PHP" 449 pkgdesc="${ext} extension for PHP"
444 provides="php-$extname" 450 provides="php-$extname"
451 depends="${pkgname}-common"
445 452
446 # extension dependencies 453 # extension dependencies
447 if [ -n "${2-}" ]; then 454 if [ -n "${2-}" ]; then
448 depends="${2-}" 455 depends="${depends} ${2-}"
449 fi 456 fi
450 depends="${pkgname} ${depends}"
451 457
452 # work around dependency issue 458 # work around dependency issue
453 # https://bugs.alpinelinux.org/issues/1848 459 # https://bugs.alpinelinux.org/issues/1848