aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-23 16:03:52 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-23 16:15:07 +0100
commit0c628c7969dcc2faaef3088c105ae9bb70a10bef (patch)
tree97b3848fd8d257b82bdf67acac42e5f4f3406419
parentbfbdee4e0db115f9008cf75c5904d1d0224f518c (diff)
downloadalpine_aports-0c628c7969dcc2faaef3088c105ae9bb70a10bef.tar.bz2
alpine_aports-0c628c7969dcc2faaef3088c105ae9bb70a10bef.tar.xz
alpine_aports-0c628c7969dcc2faaef3088c105ae9bb70a10bef.zip
community/elasticsearch: add logrotate config
-rw-r--r--community/elasticsearch/APKBUILD5
-rw-r--r--community/elasticsearch/elasticsearch.logrotated5
2 files changed, 10 insertions, 0 deletions
diff --git a/community/elasticsearch/APKBUILD b/community/elasticsearch/APKBUILD
index ad74cdd4da..5b68c2cc24 100644
--- a/community/elasticsearch/APKBUILD
+++ b/community/elasticsearch/APKBUILD
@@ -17,6 +17,7 @@ pkggroups="elastico"
17source="https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-$pkgver.tar.gz 17source="https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-$pkgver.tar.gz
18 $pkgname.initd 18 $pkgname.initd
19 $pkgname.confd 19 $pkgname.confd
20 $pkgname.logrotated
20 README.alpine 21 README.alpine
21 busybox-mktemp.patch 22 busybox-mktemp.patch
22 " 23 "
@@ -83,6 +84,9 @@ package() {
83 install -m644 -D "$srcdir"/$pkgname.confd \ 84 install -m644 -D "$srcdir"/$pkgname.confd \
84 "$pkgdir"/etc/conf.d/$pkgname 85 "$pkgdir"/etc/conf.d/$pkgname
85 86
87 install -m644 -D "$srcdir"/$pkgname.logrotated \
88 "$pkgdir"/etc/logrotate.d/$pkgname
89
86 install -m644 -D "$srcdir"/README.alpine \ 90 install -m644 -D "$srcdir"/README.alpine \
87 "$docdir" 91 "$docdir"
88 92
@@ -113,5 +117,6 @@ _x_pack() {
113sha512sums="a023a6db5554dee6f10718dfa297aa06a735c7857542c2db80fa5c2b86ff4bf405bb8167578c5b60741ad05ed96a64b54bc71d128a0ff955468b0449588b053c elasticsearch-6.4.1.tar.gz 117sha512sums="a023a6db5554dee6f10718dfa297aa06a735c7857542c2db80fa5c2b86ff4bf405bb8167578c5b60741ad05ed96a64b54bc71d128a0ff955468b0449588b053c elasticsearch-6.4.1.tar.gz
1142477cb748ea08de0b0a4c931e68d875b1a363c029820dcc2144f0da9a5adb3ad2c17d8f2f7cc7bea85a16b61951a782e6eb48e3d5890505638e3245ec04e21d7 elasticsearch.initd 1182477cb748ea08de0b0a4c931e68d875b1a363c029820dcc2144f0da9a5adb3ad2c17d8f2f7cc7bea85a16b61951a782e6eb48e3d5890505638e3245ec04e21d7 elasticsearch.initd
1152ab1baf1b5c8782f3f371ba221aadd3e841abc62175f0b1ddcfc68d711e2370465124e076f8cc2e549c25a1da9db8c90172b2f410bd6bbe4153f0e831620b6ba elasticsearch.confd 1192ab1baf1b5c8782f3f371ba221aadd3e841abc62175f0b1ddcfc68d711e2370465124e076f8cc2e549c25a1da9db8c90172b2f410bd6bbe4153f0e831620b6ba elasticsearch.confd
120450879a8ab49c4debac3f8ed484918d48428cabf300b8196db785930a9bc56ce8a153b8d4c91655cfbe9ff50bb978b3c0f87eef99ed36213463f206b68d06590 elasticsearch.logrotated
1166de81485cdc059afef58382862e4155482463fde0b604aaa8dbe904c778b841467c4a383a5e54acd09e3436f1fb7be9923e001fb77bd3d7894e113a5e0f4036b README.alpine 1216de81485cdc059afef58382862e4155482463fde0b604aaa8dbe904c778b841467c4a383a5e54acd09e3436f1fb7be9923e001fb77bd3d7894e113a5e0f4036b README.alpine
1171f9d13bbc42c04c523ef4e9ce734f919ec3d79748d78f288ed3dd725cf7c74e83d66d8b48fbc782b27b1a760096a647cb33773578071710542b19fda18ea0b84 busybox-mktemp.patch" 1221f9d13bbc42c04c523ef4e9ce734f919ec3d79748d78f288ed3dd725cf7c74e83d66d8b48fbc782b27b1a760096a647cb33773578071710542b19fda18ea0b84 busybox-mktemp.patch"
diff --git a/community/elasticsearch/elasticsearch.logrotated b/community/elasticsearch/elasticsearch.logrotated
new file mode 100644
index 0000000000..39eb6c15af
--- /dev/null
+++ b/community/elasticsearch/elasticsearch.logrotated
@@ -0,0 +1,5 @@
1/var/log/elasticsearch/*.log {
2 compress
3 copytruncate
4 missingok
5}