aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Romanenko <Dmitry@Romanenko.in>2019-01-18 23:09:44 -0500
committerAndy Postnikov <apostnikov@gmail.com>2019-01-27 04:13:27 +0200
commit74344dfdf72fa4774326810a004b4f811e8983e0 (patch)
tree81df027d81c6c84f64007f9a7727567e1d489de7
parentd4158842d97c4c05ceb81a2aee4f96d55d9b4bc9 (diff)
downloadalpine_aports-74344dfdf72fa4774326810a004b4f811e8983e0.tar.bz2
alpine_aports-74344dfdf72fa4774326810a004b4f811e8983e0.tar.xz
alpine_aports-74344dfdf72fa4774326810a004b4f811e8983e0.zip
testing/pytest-xdist: new aport
-rw-r--r--testing/pytest-xdist/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/pytest-xdist/APKBUILD b/testing/pytest-xdist/APKBUILD
new file mode 100644
index 0000000000..507235756a
--- /dev/null
+++ b/testing/pytest-xdist/APKBUILD
@@ -0,0 +1,59 @@
1# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
2# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
3pkgname=pytest-xdist
4_pkgname=pytest-xdist
5pkgver=1.26.0
6pkgrel=0
7pkgdesc="pytest xdist plugin for distributed testing and loop-on-failing modes"
8url="https://github.com/pytest-dev/pytest-xdist"
9arch="noarch"
10license="MIT"
11depends="py-execnet pytest pytest-forked py-six"
12checkdepends="pytest py-filelock py-py"
13makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm"
14subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
15source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
16builddir="$srcdir"/$_pkgname-$pkgver
17
18build() {
19 cd "$builddir"
20 python2 setup.py build
21 python3 setup.py build
22}
23
24check() {
25 cd "$builddir"
26
27 mkdir -p tmp_py2
28 python2 setup.py install --root="$builddir/tmp_py2" --optimize=1
29 PYTHONPATH="$builddir/tmp_py2/usr/lib/python2.7/site-packages:$PYTHONPATH" python2 -m pytest
30
31 mkdir -p tmp_py3
32 python3 setup.py install --root="$builddir/tmp_py3" --optimize=1
33 PYTHONPATH="$builddir/tmp_py3/usr/lib/python3.6/site-packages:$PYTHONPATH" python3 -m pytest
34}
35
36package() {
37 mkdir -p "$pkgdir"
38}
39
40_py2() {
41 replaces="$pkgname"
42 _py python2
43}
44
45_py3() {
46 _py python3
47}
48
49_py() {
50 local python="$1"
51 pkgdesc="$pkgdesc (for $python)"
52 depends="$depends $python"
53 install_if="$pkgname=$pkgver-r$pkgrel $python"
54
55 cd "$builddir"
56 $python setup.py install --prefix=/usr --root="$subpkgdir"
57}
58
59sha512sums="e364f51d2ff67b3b52808471374aeb237b2eef1bfe22acf5b99fb1e9411b7b6dbc489e98173e338915d9f2e311363401c58d5758b01356636adbac9a75919522 pytest-xdist-1.26.0.tar.gz"