aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-01-27 19:55:23 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-01-28 01:51:37 +0100
commit8190aae00739bc46d5ee8a804d3c96cb24e9e540 (patch)
tree3a54bc00138a58c748de7d308c86610360090ffc
parentc24314f73b7bb44a6d16b359ecb62050703c917d (diff)
downloadalpine_aports-8190aae00739bc46d5ee8a804d3c96cb24e9e540.tar.bz2
alpine_aports-8190aae00739bc46d5ee8a804d3c96cb24e9e540.tar.xz
alpine_aports-8190aae00739bc46d5ee8a804d3c96cb24e9e540.zip
main/librelp: new aport (needed for main/rsyslog)
The Reliable Event Logging Protocol library https://www.rsyslog.org
-rw-r--r--main/librelp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/main/librelp/APKBUILD b/main/librelp/APKBUILD
new file mode 100644
index 0000000000..de86652fa8
--- /dev/null
+++ b/main/librelp/APKBUILD
@@ -0,0 +1,31 @@
1# Contributor: Jakub Jirutka <jakub@jirutka.cz>
2# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
3pkgname=librelp
4pkgver=1.3.0
5pkgrel=0
6pkgdesc="The Reliable Event Logging Protocol library"
7url="https://www.rsyslog.com"
8arch="all"
9license="GPL-3.0-or-later"
10makedepends="gnutls-dev"
11subpackages="$pkgname-dev"
12source="http://download.rsyslog.com/librelp/$pkgname-$pkgver.tar.gz"
13options="!check" # XXX: all tests fail, don't know why
14builddir="$srcdir/$pkgname-$pkgver"
15
16build() {
17 cd "$builddir"
18 ./configure \
19 --build=$CBUILD \
20 --host=$CHOST \
21 --prefix=/usr \
22 --mandir=/usr/share/man
23 make
24}
25
26package() {
27 cd "$builddir"
28 make DESTDIR="$pkgdir" install
29}
30
31sha512sums="6e60398c68a78f4b4202a697e144f1516ff3bbb32192f745b52c77d107954febf8cb31d2e166efa96c00122f6807860ecd01084f1d3d4005336f2cb75e6461c9 librelp-1.3.0.tar.gz"