aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-01-28 11:41:08 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-01-28 12:02:37 +0000
commite57890e734b9727cbd98241b46832dbeb2535b1e (patch)
tree0c7807ca5c0b2c59214a4e5e8f927cbb12dd096b
parent6327c4b8f67b993d5ca5d79924fe0e2c6551c798 (diff)
downloadalpine_aports-e57890e734b9727cbd98241b46832dbeb2535b1e.tar.bz2
alpine_aports-e57890e734b9727cbd98241b46832dbeb2535b1e.tar.xz
alpine_aports-e57890e734b9727cbd98241b46832dbeb2535b1e.zip
testing/redo: fix check failing due to missing /dev/tty
On the builders, the checks failed because they tried to open /dev/tty, which does not exists. Add a patch that continues when /dev/tty is missing. Re-enable redo
-rw-r--r--testing/redo/APKBUILD11
-rw-r--r--testing/redo/skip-when-tty-missing.patch20
2 files changed, 26 insertions, 5 deletions
diff --git a/testing/redo/APKBUILD b/testing/redo/APKBUILD
index 14848fb2eb..1041ac0f87 100644
--- a/testing/redo/APKBUILD
+++ b/testing/redo/APKBUILD
@@ -2,16 +2,16 @@
2# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org> 2# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
3pkgname=redo 3pkgname=redo
4pkgver=0.41 4pkgver=0.41
5pkgrel=1 5pkgrel=2
6pkgdesc="Smaller, easier, more powerful, and more reliable than make" 6pkgdesc="Smaller, easier, more powerful, and more reliable than make"
7url="https://redo.readthedocs.io/en/latest/" 7url="https://redo.readthedocs.io/en/latest/"
8# arch="noarch" 8arch="noarch"
9license="Apache-2.0" 9license="Apache-2.0"
10depends="python2" 10depends="python2"
11makedepends="python2 perl" 11makedepends="python2 perl"
12subpackages="$pkgname-doc" 12subpackages="$pkgname-doc"
13options="!check" # FIXME fails 13source="https://github.com/apenwarr/redo/archive/redo-${pkgver}.tar.gz
14source="https://github.com/apenwarr/redo/archive/redo-${pkgver}.tar.gz" 14 skip-when-tty-missing.patch"
15builddir="$srcdir/redo-redo-${pkgver}" 15builddir="$srcdir/redo-redo-${pkgver}"
16 16
17build() { 17build() {
@@ -36,4 +36,5 @@ package() {
36 DESTDIR="$pkgdir" PREFIX="/usr" ./do install 36 DESTDIR="$pkgdir" PREFIX="/usr" ./do install
37} 37}
38 38
39sha512sums="94e4414a2f8120e5d4a949461734ed69dc2f39edfb7929d2efff83041ac0b941e037359ccfafcb4eff760608274e32c579df56d58fdb67b13b8a26eb1945b0d0 redo-0.41.tar.gz" 39sha512sums="94e4414a2f8120e5d4a949461734ed69dc2f39edfb7929d2efff83041ac0b941e037359ccfafcb4eff760608274e32c579df56d58fdb67b13b8a26eb1945b0d0 redo-0.41.tar.gz
40bc622d6a4b2c270f4f7791bb545d9f0a34a3c993f4a03dd901c4419c4f82ffeb43d210972f29abada14ba9eae812040c2c5a76ffdcfc744bb01fd5c32fa0ca89 skip-when-tty-missing.patch"
diff --git a/testing/redo/skip-when-tty-missing.patch b/testing/redo/skip-when-tty-missing.patch
new file mode 100644
index 0000000000..8acefbacd9
--- /dev/null
+++ b/testing/redo/skip-when-tty-missing.patch
@@ -0,0 +1,20 @@
1diff --git a/redo/builder.py b/redo/builder.py.new
2index e55955f7f9..160cba8dfe 100644
3--- a/redo/builder.py
4+++ b/redo/builder.py.new
5@@ -1,5 +1,5 @@
6 """Code for parallel-building a set of targets, if needed."""
7-import errno, os, stat, signal, sys, tempfile, time
8+import errno, os, os.path, stat, signal, sys, tempfile, time
9 from . import cycles, env, jobserver, logs, state, paths
10 from .helpers import unlink, close_on_exec
11 from .logs import debug2, err, warn, meta
12@@ -99,6 +99,8 @@ def await_log_reader():
13 if not env.v.LOG:
14 return
15 if log_reader_pid > 0:
16+ if not os.path.exists('/dev/tty'):
17+ return
18 # never actually close fd#1 or fd#2; insanity awaits.
19 # replace it with something else instead.
20 # Since our stdout/stderr are attached to redo-log's stdin,