aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-02-11 22:48:42 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-02-26 19:17:57 +0100
commit957dc8a8ec5f4102c9258938655a3e9cf3736a72 (patch)
tree4b534fa04f865aa283d5c992140ba416e59936e5
parent203cb413da1ecf416412c7b7d53213b1c2b22a09 (diff)
downloadalpine_aports-957dc8a8ec5f4102c9258938655a3e9cf3736a72.tar.bz2
alpine_aports-957dc8a8ec5f4102c9258938655a3e9cf3736a72.tar.xz
alpine_aports-957dc8a8ec5f4102c9258938655a3e9cf3736a72.zip
main/curl: fix segfault when running cargo
Patch is taken from upstream at https://github.com/curl/curls The http2 code for connection checking needs a transfer to use. Make sure a working one is set before handler->connection_check() is called. (cherry picked from commit 4a7cbd15d80c1cda6e5221612f846b6b4c91104e)
-rw-r--r--main/curl/APKBUILD8
-rw-r--r--main/curl/url-fix-7.64.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index b737e59121..93e15c6d54 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -4,7 +4,7 @@
4# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 4# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
5pkgname=curl 5pkgname=curl
6pkgver=7.64.0 6pkgver=7.64.0
7pkgrel=0 7pkgrel=1
8pkgdesc="URL retrival utility and library" 8pkgdesc="URL retrival utility and library"
9url="https://curl.haxx.se" 9url="https://curl.haxx.se"
10arch="all" 10arch="all"
@@ -14,7 +14,8 @@ depends_dev="openssl-dev libssh2-dev nghttp2-dev zlib-dev"
14checkdepends="python2" 14checkdepends="python2"
15makedepends="$depends_dev autoconf automake groff libtool perl" 15makedepends="$depends_dev autoconf automake groff libtool perl"
16subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl" 16subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
17source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz" 17source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
18 url-fix-7.64.patch"
18options="!check" # sftp tests failing 19options="!check" # sftp tests failing
19builddir="$srcdir/$pkgname-$pkgver" 20builddir="$srcdir/$pkgname-$pkgver"
20 21
@@ -115,4 +116,5 @@ libcurl() {
115 mv "$pkgdir"/usr/lib "$subpkgdir"/usr 116 mv "$pkgdir"/usr/lib "$subpkgdir"/usr
116} 117}
117 118
118sha512sums="953f1f5336ce5dfd1b9f933624432d401552d91ee02d39ecde6f023c956f99ec6aae8d7746d7c34b6eb2d6452f114e67da4e64d9c8dd90b7644b7844e7b9b423 curl-7.64.0.tar.xz" 119sha512sums="953f1f5336ce5dfd1b9f933624432d401552d91ee02d39ecde6f023c956f99ec6aae8d7746d7c34b6eb2d6452f114e67da4e64d9c8dd90b7644b7844e7b9b423 curl-7.64.0.tar.xz
1209b0cd3bfb705e804f21b3c87929ec5c3bbd6f17748e82cda75c3edbca5ea66cbcb0260c666635a2cbdaa6d4081008a9c445b4f266e9b970d3deaed21f9b352a1 url-fix-7.64.patch"
diff --git a/main/curl/url-fix-7.64.patch b/main/curl/url-fix-7.64.patch
new file mode 100644
index 0000000000..ed63f90092
--- /dev/null
+++ b/main/curl/url-fix-7.64.patch
@@ -0,0 +1,10 @@
1--- a/lib/url.c
2+++ b/lib/url.c
3@@ -965,6 +965,7 @@
4 /* The protocol has a special method for checking the state of the
5 connection. Use it to check if the connection is dead. */
6 unsigned int state;
7+ conn->data = data; /* use this transfer for now */
8 state = conn->handler->connection_check(conn, CONNCHECK_ISDEAD);
9 dead = (state & CONNRESULT_DEAD);
10 }