aboutsummaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-31 12:18:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-06-04 13:45:40 -0300
commit6e38efeea34e8cae0acb6f91e86e1652c0bf65bd (patch)
tree86c0432de69390010d93e81a57c1093046490ffa /community
parentd54ec732f536701d32f637c227eb69cf310b5860 (diff)
downloadalpine_aports-6e38efeea34e8cae0acb6f91e86e1652c0bf65bd.tar.bz2
alpine_aports-6e38efeea34e8cae0acb6f91e86e1652c0bf65bd.tar.xz
alpine_aports-6e38efeea34e8cae0acb6f91e86e1652c0bf65bd.zip
community/ion-shell: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/ion-shell/APKBUILD28
-rw-r--r--community/ion-shell/ion-shell.post-install3
l---------community/ion-shell/ion-shell.post-upgrade1
-rw-r--r--community/ion-shell/ion-shell.pre-deinstall3
4 files changed, 35 insertions, 0 deletions
diff --git a/community/ion-shell/APKBUILD b/community/ion-shell/APKBUILD
new file mode 100644
index 0000000000..b4444595ef
--- /dev/null
+++ b/community/ion-shell/APKBUILD
@@ -0,0 +1,28 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Maintainer: Leo <thinkabit.ukim@gmail.com>
3pkgname=ion-shell
4pkgver=1.0.5_git20200522
5pkgrel=0
6_commit=ca069ed1c113d8d07d6535c24939389065ce761f
7pkgdesc="The Ion Shell"
8url="https://gitlab.redox-os.org/redox-os/ion"
9arch="all !s390x !mips !mips64"
10license="MIT"
11makedepends="cargo"
12install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
13source="$pkgname-$_commit.tar.gz::https://gitlab.redox-os.org/redox-os/ion/-/archive/$_commit.tar.gz"
14builddir="$srcdir/ion-$_commit"
15
16build() {
17 cargo build --release --locked
18}
19
20check() {
21 cargo test --release --locked
22}
23
24package() {
25 install -Dm0755 target/release/ion -t "$pkgdir"/usr/bin
26}
27
28sha512sums="9c83c3ae6bc3253a93496448b6137a686f52edcf28036fe6bc237ed6bc8e64f184a1cc8753c0b870d20d122080306a1cfc9e7c610bb188e56fcad595585dcf66 ion-shell-ca069ed1c113d8d07d6535c24939389065ce761f.tar.gz"
diff --git a/community/ion-shell/ion-shell.post-install b/community/ion-shell/ion-shell.post-install
new file mode 100644
index 0000000000..a40b915462
--- /dev/null
+++ b/community/ion-shell/ion-shell.post-install
@@ -0,0 +1,3 @@
1#!/bin/sh
2add-shell '/usr/bin/ion'
3exit 0
diff --git a/community/ion-shell/ion-shell.post-upgrade b/community/ion-shell/ion-shell.post-upgrade
new file mode 120000
index 0000000000..90eba30cc4
--- /dev/null
+++ b/community/ion-shell/ion-shell.post-upgrade
@@ -0,0 +1 @@
ion-shell.post-install \ No newline at end of file
diff --git a/community/ion-shell/ion-shell.pre-deinstall b/community/ion-shell/ion-shell.pre-deinstall
new file mode 100644
index 0000000000..e344456932
--- /dev/null
+++ b/community/ion-shell/ion-shell.pre-deinstall
@@ -0,0 +1,3 @@
1#!/bin/sh
2remove-shell '/usr/bin/ion'
3exit 0