aboutsummaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-05-26 07:51:17 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-05-26 07:58:02 +0000
commit55b841110f77efabb511e802ae9d626447fcc663 (patch)
treebc3798091a0ba46d9a612f61d26891bb301d0fe5 /community
parent1086feea674efd75f74c0f332fcc89d50e85a71f (diff)
downloadalpine_aports-55b841110f77efabb511e802ae9d626447fcc663.tar.bz2
alpine_aports-55b841110f77efabb511e802ae9d626447fcc663.tar.xz
alpine_aports-55b841110f77efabb511e802ae9d626447fcc663.zip
community/py3-pyzabbix: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-pyzabbix/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-pyzabbix/APKBUILD b/community/py3-pyzabbix/APKBUILD
new file mode 100644
index 0000000000..bce1502398
--- /dev/null
+++ b/community/py3-pyzabbix/APKBUILD
@@ -0,0 +1,27 @@
1# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
2# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
3pkgname=py3-pyzabbix
4pkgver=0.8.2
5pkgrel=0
6pkgdesc="Library to interact with the Zabbix API"
7url="https://github.com/lukecyca/pyzabbix"
8arch="noarch"
9license="LGPL-2.1-or-later"
10depends="python3 py3-requests"
11makedepends="python3-dev py3-setuptools"
12source="$pkgname-$pkgver.tar.gz::https://github.com/lukecyca/pyzabbix/archive/$pkgver.tar.gz"
13builddir="$srcdir/${pkgname#py3-}-$pkgver"
14
15build() {
16 python3 setup.py build
17}
18
19check() {
20 python3 setup.py test
21}
22
23package() {
24 python3 setup.py install --prefix=/usr --root="$pkgdir"
25}
26
27sha512sums="e191c449b36ec13b66ed52889cdcdd8318b2613eb657f5fbb27cf6d7c2554c472ea051933fb6ff8168535c281e7cc94764c8229a7772ead49d00e0fe9c139793 py3-pyzabbix-0.8.2.tar.gz"