aboutsummaryrefslogtreecommitdiff
path: root/non-free
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-26 20:38:35 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-26 21:49:22 +0100
commitc2f08f65b89e1c358a8650b6d1eab96a87877a54 (patch)
treefd192b6d53bb5f7e569bb99b843404f8a638b7e1 /non-free
parent5bd8435b3318741b81dc83e853ffbb637b5940ad (diff)
downloadalpine_aports-c2f08f65b89e1c358a8650b6d1eab96a87877a54.tar.bz2
alpine_aports-c2f08f65b89e1c358a8650b6d1eab96a87877a54.tar.xz
alpine_aports-c2f08f65b89e1c358a8650b6d1eab96a87877a54.zip
community/mongodb-tools: move from non-free
Turns out it is actually Apache-2.0 and doesn't depend on mongodb itself. fixes #10994
Diffstat (limited to 'non-free')
-rw-r--r--non-free/mongodb-tools/APKBUILD40
-rw-r--r--non-free/mongodb-tools/fix-build.patch13
-rw-r--r--non-free/mongodb-tools/fix-cstruct-decls.patch78
3 files changed, 0 insertions, 131 deletions
diff --git a/non-free/mongodb-tools/APKBUILD b/non-free/mongodb-tools/APKBUILD
deleted file mode 100644
index 8f96d606ca..0000000000
--- a/non-free/mongodb-tools/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
1# Contributor: Marc Vertes <mvertes@free.fr>
2# Maintainer: Marc Vertes <mvertes@free.fr>
3pkgname=mongodb-tools
4pkgver=4.0.6
5pkgrel=1
6pkgdesc="The MongoDB tools provide import, export, and diagnostic capabilities."
7url="https://github.com/mongodb/mongo-tools"
8arch="all !s390x"
9license="Apache"
10makedepends="$depends_dev go cyrus-sasl-dev openssl-dev libpcap-dev bash perl"
11options="!check"
12source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo-tools/archive/r$pkgver.tar.gz
13 fix-cstruct-decls.patch
14 fix-build.patch
15 "
16builddir="$srcdir/src/github.com/mongodb/mongo-tools"
17
18prepare() {
19 mkdir -p "${builddir%/*}"
20 mv "$srcdir"/mongo-tools-r$pkgver "$builddir"
21 default_prepare
22}
23
24build() {
25 cd "$builddir"
26 GOROOT=/usr/lib/go GOPATH="$srcdir" ./build.sh sasl ssl
27}
28
29package() {
30 cd "$builddir/bin"
31 local bindir="$pkgdir/usr/bin"
32 mkdir -p "$bindir"
33 cp bsondump mongostat mongofiles mongoexport mongoimport \
34 mongorestore mongodump mongotop mongoreplay \
35 "$bindir"
36}
37
38sha512sums="d6185d7442a593d29db78889c55aba53e070bedd522d78d8c0bf52bb27f26c5fee6d010457f65774ea36a2e6d5280f38c95433ff76ed53ed9d74b1c811198cb7 mongodb-tools-4.0.6.tar.gz
39e95ff1c3583ad8c3c4b8f14c6743fe8a5029c91e83b78bc33eae762d1d3aa48a6536c5b27183fca81b93034f4f3d91d23fef857a1f85f725d57f3a45a599fedf fix-cstruct-decls.patch
4074e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch"
diff --git a/non-free/mongodb-tools/fix-build.patch b/non-free/mongodb-tools/fix-build.patch
deleted file mode 100644
index 4913d8caa6..0000000000
--- a/non-free/mongodb-tools/fix-build.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1--- mongo-tools-r3.4.3/build.sh.orig
2+++ mongo-tools-r3.4.3/build.sh
3@@ -7,8 +7,8 @@
4 fi
5
6 # make sure we're in the directory where the script lives
7-SCRIPT_DIR="$(cd "$(dirname ${BASH_SOURCE[0]})" && pwd)"
8-cd $SCRIPT_DIR
9+#SCRIPT_DIR="$(cd "$(dirname ${BASH_SOURCE[0]})" && pwd)"
10+#cd $SCRIPT_DIR
11
12 sed -i.bak -e "s/built-without-version-string/$(git describe)/" \
13 -e "s/built-without-git-spec/$(git rev-parse HEAD)/" \
diff --git a/non-free/mongodb-tools/fix-cstruct-decls.patch b/non-free/mongodb-tools/fix-cstruct-decls.patch
deleted file mode 100644
index 87d332c5b5..0000000000
--- a/non-free/mongodb-tools/fix-cstruct-decls.patch
+++ /dev/null
@@ -1,78 +0,0 @@
1--- a/vendor/github.com/google/gopacket/pcap/pcap.go
2+++ b/vendor/github.com/google/gopacket/pcap/pcap.go
3@@ -170,7 +170,7 @@
4 // BPF is a compiled filter program, useful for offline packet matching.
5 type BPF struct {
6 orig string
7- bpf _Ctype_struct_bpf_program // takes a finalizer, not overriden by outsiders
8+ bpf C.struct_bpf_program // takes a finalizer, not overriden by outsiders
9 }
10
11 // BPFInstruction is a byte encoded structure holding a BPF instruction
12@@ -381,7 +381,7 @@
13
14 // Stats returns statistics on the underlying pcap handle.
15 func (p *Handle) Stats() (stat *Stats, err error) {
16- var cstats _Ctype_struct_pcap_stat
17+ var cstats C.struct_pcap_stat
18 if -1 == C.pcap_stats(p.cptr, &cstats) {
19 return nil, p.Error()
20 }
21@@ -418,7 +418,7 @@
22 return datalinks, nil
23 }
24
25-func (p *Handle) compileBPFFilter(expr string) (_Ctype_struct_bpf_program, error) {
26+func (p *Handle) compileBPFFilter(expr string) (C.struct_bpf_program, error) {
27 errorBuf := (*C.char)(C.calloc(errorBufferSize, 1))
28 defer C.free(unsafe.Pointer(errorBuf))
29
30@@ -441,7 +441,7 @@
31 }
32 }
33
34- var bpf _Ctype_struct_bpf_program
35+ var bpf C.struct_bpf_program
36 cexpr := C.CString(expr)
37 defer C.free(unsafe.Pointer(cexpr))
38
39@@ -459,7 +459,7 @@
40 return nil, err
41 }
42
43- bpfInsn := (*[bpfInstructionBufferSize]_Ctype_struct_bpf_insn)(unsafe.Pointer(bpf.bf_insns))[0:bpf.bf_len:bpf.bf_len]
44+ bpfInsn := (*[bpfInstructionBufferSize]C.struct_bpf_insn)(unsafe.Pointer(bpf.bf_insns))[0:bpf.bf_len:bpf.bf_len]
45 bpfInstruction := make([]BPFInstruction, len(bpfInsn), len(bpfInsn))
46
47 for i, v := range bpfInsn {
48@@ -535,7 +535,7 @@
49
50 return nil
51 }
52-func bpfInstructionFilter(bpfInstructions []BPFInstruction) (bpf _Ctype_struct_bpf_program, err error) {
53+func bpfInstructionFilter(bpfInstructions []BPFInstruction) (bpf C.struct_bpf_program, err error) {
54 if len(bpfInstructions) < 1 {
55 return bpf, errors.New("bpfInstructions must not be empty")
56 }
57@@ -548,7 +548,7 @@
58 cbpfInsns := C.calloc(C.size_t(len(bpfInstructions)), C.size_t(unsafe.Sizeof(bpfInstructions[0])))
59
60 copy((*[bpfInstructionBufferSize]BPFInstruction)(cbpfInsns)[0:len(bpfInstructions)], bpfInstructions)
61- bpf.bf_insns = (*_Ctype_struct_bpf_insn)(cbpfInsns)
62+ bpf.bf_insns = (*C.struct_bpf_insn)(cbpfInsns)
63
64 return
65 }
66@@ -656,10 +656,10 @@
67 return
68 }
69
70-func findalladdresses(addresses *_Ctype_struct_pcap_addr) (retval []InterfaceAddress) {
71+func findalladdresses(addresses *C.struct_pcap_addr) (retval []InterfaceAddress) {
72 // TODO - make it support more than IPv4 and IPv6?
73 retval = make([]InterfaceAddress, 0, 1)
74- for curaddr := addresses; curaddr != nil; curaddr = (*_Ctype_struct_pcap_addr)(curaddr.next) {
75+ for curaddr := addresses; curaddr != nil; curaddr = (*C.struct_pcap_addr)(curaddr.next) {
76 // Strangely, it appears that in some cases, we get a pcap address back from
77 // pcap_findalldevs with a nil .addr. It appears that we can skip over
78 // these.