aboutsummaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-06-04 10:41:24 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-06-04 10:41:24 +0200
commit258dba7bb9f2b96f62eceeedc330afdafc9d23c8 (patch)
treed88b78d6bad0457c6104888a93ae28075ad6c557 /testing
parent146e836211c8e8aec8522156cf05add7463568de (diff)
downloadalpine_aports-258dba7bb9f2b96f62eceeedc330afdafc9d23c8.tar.bz2
alpine_aports-258dba7bb9f2b96f62eceeedc330afdafc9d23c8.tar.xz
alpine_aports-258dba7bb9f2b96f62eceeedc330afdafc9d23c8.zip
testing/xfce4-timer-plugin: new aport
Timer plugin for Xfce https://docs.xfce.org/panel-plugins/xfce4-timer-plugin
Diffstat (limited to 'testing')
-rw-r--r--testing/xfce4-timer-plugin/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/xfce4-timer-plugin/APKBUILD b/testing/xfce4-timer-plugin/APKBUILD
new file mode 100644
index 0000000000..e724076a94
--- /dev/null
+++ b/testing/xfce4-timer-plugin/APKBUILD
@@ -0,0 +1,30 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname="xfce4-timer-plugin"
3pkgver=1.7.0
4pkgrel=0
5pkgdesc="Timer plugin for Xfce"
6url="https://docs.xfce.org/panel-plugins/xfce4-timer-plugin"
7arch="all"
8license="BSD"
9makedepends="xfce4-panel-dev libxfce4ui-dev gtk+3.0-dev"
10options="!check" # no testsuite
11subpackages="$pkgname-lang"
12source="http://archive.xfce.org/src/panel-plugins/xfce4-timer-plugin/${pkgver%.*}/xfce4-timer-plugin-$pkgver.tar.bz2"
13builddir="$srcdir/xfce4-timer-plugin-$pkgver"
14
15build() {
16 ./configure \
17 --build=$CBUILD \
18 --host=$CHOST \
19 --prefix=/usr \
20 --sysconfdir=/etc \
21 --mandir=/usr/share/man \
22 --localstatedir=/var
23 make
24}
25
26package() {
27 make DESTDIR="$pkgdir" install
28}
29
30sha512sums="b4d00396f5be37d009cdb50baea8804c4b06a6f0b821d66751fd07ca21e186c01bafeec5170209b5de69559803e0ac54d9b56266f193b65ac056cdd52bf5228e xfce4-timer-plugin-1.7.0.tar.bz2"