aboutsummaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-31 15:51:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-06-04 13:45:42 -0300
commit9742c4648caaf7a783c1e3735424c8608cf836fa (patch)
tree7a8cee060748cc82c473aecf2f69b15e1740828f /testing
parent450ac8b85e99d84f65bf6068214b9952dd99d9cc (diff)
downloadalpine_aports-9742c4648caaf7a783c1e3735424c8608cf836fa.tar.bz2
alpine_aports-9742c4648caaf7a783c1e3735424c8608cf836fa.tar.xz
alpine_aports-9742c4648caaf7a783c1e3735424c8608cf836fa.zip
community/py3-readchar: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-readchar/APKBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/testing/py3-readchar/APKBUILD b/testing/py3-readchar/APKBUILD
deleted file mode 100644
index a4ced0694e..0000000000
--- a/testing/py3-readchar/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
1# Contributor: Rasmus Thomsen <oss@cogitri.dev>
2# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
3pkgname=py3-readchar
4pkgver=2.0.0
5pkgrel=0
6pkgdesc=" Python library to read characters and key strokes"
7url="https://github.com/magmax/python-readchar"
8arch="noarch"
9license="MIT"
10depends="python3"
11makedepends="py3-setuptools"
12checkdepends="py3-pexpect py3-coverage py3-pytest py3-pytest-cov py3-wheel"
13source="https://github.com/magmax/python-readchar/archive/$pkgver/py3-readchar-$pkgver.tar.gz"
14builddir="$srcdir/python-readchar-$pkgver"
15
16build() {
17 python3 setup.py build
18}
19
20check() {
21 python3 setup.py test
22}
23
24package() {
25 python3 setup.py install --prefix=/usr --root="$pkgdir"
26 # Remove installed tests
27 rm -r "$pkgdir"/usr/lib/python*/site-packages/tests
28}
29
30sha512sums="92331e55080f5ebf55e313bd0e9562d55578df98ee116fa534a2ae47b43cbd9b19cf11263db821490a6b9ae5f62b78d378fd5b4c996d98a88c765af489b4d70f py3-readchar-2.0.0.tar.gz"