aboutsummaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-05-31 13:02:49 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-06-04 13:45:41 -0300
commitaaf3bbc11c75f45b8cac2e662333ac2ad24a115a (patch)
treec4453c4763817f0320598ba589da443efeda2b36 /testing
parentb074564646aa32b0b424c4cbe6dca6f51338968b (diff)
downloadalpine_aports-aaf3bbc11c75f45b8cac2e662333ac2ad24a115a.tar.bz2
alpine_aports-aaf3bbc11c75f45b8cac2e662333ac2ad24a115a.tar.xz
alpine_aports-aaf3bbc11c75f45b8cac2e662333ac2ad24a115a.zip
community/py3-gitpython: move from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-gitpython/APKBUILD29
1 files changed, 0 insertions, 29 deletions
diff --git a/testing/py3-gitpython/APKBUILD b/testing/py3-gitpython/APKBUILD
deleted file mode 100644
index 0f1c969700..0000000000
--- a/testing/py3-gitpython/APKBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
2# Maintainer: Bart Ribbers <bribbers@disroot.org>
3pkgname=py3-gitpython
4pkgver=3.1.3
5pkgrel=0
6pkgdesc="Python3 Git Library"
7url="https://github.com/gitpython-developers/GitPython"
8arch="noarch"
9license="BSD-3-Clause"
10depends="python3 py3-gitdb2"
11makedepends="py3-setuptools"
12checkdepends="py3-ddt py3-nose"
13source="https://pypi.python.org/packages/source/G/GitPython/GitPython-$pkgver.tar.gz"
14options="!check" # Tests require a specific git configuration
15builddir="$srcdir/GitPython-$pkgver"
16
17build() {
18 python3 setup.py build
19}
20
21check() {
22 nosetests
23}
24
25package() {
26 python3 setup.py install --prefix=/usr --root="$pkgdir"
27}
28
29sha512sums="ea4043c8be79cec7ffc9c6b6383be37dcf7b4a877cf02d6fc8c9e7d39a5005e088c8780dd6e0fcd72c0711c997228f417773c82572f569c5ca1128f5ebe56736 GitPython-3.1.3.tar.gz"