aboutsummaryrefslogtreecommitdiff
path: root/testing
diff options
context:
space:
mode:
authorJustin Berthault <justin.berthault@zaclys.net>2020-05-20 14:21:48 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-21 07:46:25 +0000
commit0e8fdba70e1e7eff7551600d76928a7f34788bf8 (patch)
tree1f17fa574e0ac97b2239e78e8e5043f711b899fe /testing
parentc86441ea255148a7452f5cb920e9167cef06b189 (diff)
downloadalpine_aports-0e8fdba70e1e7eff7551600d76928a7f34788bf8.tar.bz2
alpine_aports-0e8fdba70e1e7eff7551600d76928a7f34788bf8.tar.xz
alpine_aports-0e8fdba70e1e7eff7551600d76928a7f34788bf8.zip
testing/py3-pyserial: new aport
https://github.com/pyserial/pyserial Multiplatform Serial Port Module for Python
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-pyserial/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pyserial/APKBUILD b/testing/py3-pyserial/APKBUILD
new file mode 100644
index 0000000000..58a29a49b4
--- /dev/null
+++ b/testing/py3-pyserial/APKBUILD
@@ -0,0 +1,27 @@
1# Contributor: Justin Berthault <justin.berthault@zaclys.net>
2# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
3pkgname=py3-pyserial
4pkgver=3.4
5pkgrel=0
6pkgdesc="Multiplatform Serial Port Module for Python"
7url="https://github.com/pyserial/pyserial"
8arch="all"
9license="BSD-3-Clause"
10depends="python3"
11makedepends="python3-dev"
12source="https://files.pythonhosted.org/packages/source/p/pyserial/pyserial-3.4.tar.gz"
13builddir="$srcdir/"pyserial-$pkgver
14
15build() {
16 python3 setup.py build
17}
18
19check() {
20 python3 test/run_all_tests.py
21}
22
23package() {
24 python3 setup.py install --prefix=/usr --root="$pkgdir"
25}
26
27sha512sums="d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f pyserial-3.4.tar.gz"