aboutsummaryrefslogtreecommitdiff
path: root/unmaintained
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-03 11:46:25 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-04 04:14:51 -0300
commit1e7120d5de6dc1c21ca134cd0221c27c0e2f7252 (patch)
tree5bf374e1a37a968065285b229242c7f954047842 /unmaintained
parentf2b4df4df26dedad05a978110b5cf1707b0be8c1 (diff)
downloadalpine_aports-1e7120d5de6dc1c21ca134cd0221c27c0e2f7252.tar.bz2
alpine_aports-1e7120d5de6dc1c21ca134cd0221c27c0e2f7252.tar.xz
alpine_aports-1e7120d5de6dc1c21ca134cd0221c27c0e2f7252.zip
unmaintained/glade3: move from main
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/glade3/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/unmaintained/glade3/APKBUILD b/unmaintained/glade3/APKBUILD
new file mode 100644
index 0000000000..a6662e5ee6
--- /dev/null
+++ b/unmaintained/glade3/APKBUILD
@@ -0,0 +1,36 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=glade3
3pkgver=3.8.6
4pkgrel=0
5pkgdesc="A RAD tool for rapid development of GTK+2 user interfaces"
6url="https://glade.gnome.org/"
7arch="all"
8license="LGPL-2.1-or-later AND GPL-2.0-or-later"
9makedepends="gtk+2.0-dev itstool libxml2-dev paxmark python2"
10subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
11source="https://download.gnome.org/sources/glade3/${pkgver%.*}/glade3-$pkgver.tar.xz"
12
13build() {
14 ./configure \
15 --build=$CBUILD \
16 --host=$CHOST \
17 --prefix=/usr \
18 --sysconfdir=/etc \
19 --mandir=/usr/share/man \
20 --infodir=/usr/share/info \
21 --enable-compile-warnings=no \
22 --disable-scrollkeeper \
23 --disable-gnome
24 make
25}
26
27check() {
28 make check
29}
30
31package() {
32 make DESTDIR="$pkgdir" install
33 paxmark -r "$pkgdir"/usr/bin/glade-3
34}
35
36sha512sums="14ea975a62a2e032e0f39c38d13e0717119ef15b44e0c30bc0d9f19850ebd1535cb05eb0d240c1c8aeb88f38c276fea3a2880cb8aa684b976726ced729e7f8cf glade3-3.8.6.tar.xz"