aboutsummaryrefslogtreecommitdiff
path: root/unmaintained
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-01-31 21:52:51 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-31 22:04:03 +0100
commit8371587c8f5ad7e82c82a968a2a77483ee88c74e (patch)
treeef1705f84f6713066b287cfb808ea11341393b73 /unmaintained
parent4ddd06460994ab03441d1ad85a35894d57afb0d3 (diff)
downloadalpine_aports-8371587c8f5ad7e82c82a968a2a77483ee88c74e.tar.bz2
alpine_aports-8371587c8f5ad7e82c82a968a2a77483ee88c74e.tar.xz
alpine_aports-8371587c8f5ad7e82c82a968a2a77483ee88c74e.zip
unmaintained/libwnck: move from community
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/libwnck/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/unmaintained/libwnck/APKBUILD b/unmaintained/libwnck/APKBUILD
new file mode 100644
index 0000000000..67c3799a06
--- /dev/null
+++ b/unmaintained/libwnck/APKBUILD
@@ -0,0 +1,44 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=libwnck
3pkgver=2.31.0
4pkgrel=6
5pkgdesc="Window Navigator Construction Kit"
6url="https://git.gnome.org/browse/libwnck"
7arch="all"
8license="LGPL-2.0+"
9subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
10depends=
11makedepends="glib-dev gtk+2.0-dev libx11-dev pango-dev cairo-dev intltool
12 startup-notification-dev gobject-introspection-dev libxres-dev"
13source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
14
15prepare() {
16 cd "$builddir"
17 update_config_sub
18 default_prepare
19}
20
21build() {
22 cd "$builddir"
23 ./configure \
24 --build=$CBUILD \
25 --host=$CHOST \
26 --prefix=/usr \
27 --sysconfdir=/etc \
28 --localstatedir=/var \
29 --disable-static
30 make
31}
32
33check() {
34 cd "$builddir"
35 make check
36}
37
38package() {
39 cd "$builddir"
40 make DESTDIR="$pkgdir" install
41 rm "$pkgdir"/usr/bin/wnckprop \
42 "$pkgdir"/usr/bin/wnck-urgency-monitor
43}
44sha512sums="54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9 libwnck-2.31.0.tar.xz"