aboutsummaryrefslogtreecommitdiff
path: root/unmaintained
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-26 22:15:08 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-19 14:10:12 +0200
commite546983155a9a79f8a09bc9cf0d12a210b180ebc (patch)
tree20b411f59e628be2f4280f33e18b07ac95b585bd /unmaintained
parenta499d0b230ffa0c8d92c4e21e652d5e6e3a03acc (diff)
downloadalpine_aports-e546983155a9a79f8a09bc9cf0d12a210b180ebc.tar.bz2
alpine_aports-e546983155a9a79f8a09bc9cf0d12a210b180ebc.tar.xz
alpine_aports-e546983155a9a79f8a09bc9cf0d12a210b180ebc.zip
unmaintained/ponyc: move from testing
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/ponyc/APKBUILD80
-rw-r--r--unmaintained/ponyc/makefile-remove-march-mtune.patch39
-rw-r--r--unmaintained/ponyc/more-portable-ln.patch16
-rw-r--r--unmaintained/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch25
4 files changed, 160 insertions, 0 deletions
diff --git a/unmaintained/ponyc/APKBUILD b/unmaintained/ponyc/APKBUILD
new file mode 100644
index 0000000000..fad0ea11d2
--- /dev/null
+++ b/unmaintained/ponyc/APKBUILD
@@ -0,0 +1,80 @@
1# Contributor: Rasmus Thomsen <oss@cogitri.dev>
2# Contributor: Jakub Jirutka <jakub@jirutka.cz>
3# Maintainer:
4pkgname=ponyc
5pkgver=0.33.2
6pkgrel=0
7pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
8url="https://www.ponylang.org/"
9arch="all !s390x !ppc64le !mips !mips64"
10license="BSD-2-Clause"
11_llvmver=9
12depends="binutils-gold"
13checkdepends="openssl-dev pcre2-dev"
14makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark
15 zlib-dev linux-headers"
16options="!check"
17subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
18source="ponyc-$pkgver.tar.gz::https://github.com/ponylang/ponyc/archive/$pkgver.tar.gz
19 more-portable-ln.patch
20 makefile-remove-march-mtune.patch
21 rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
22 "
23
24export LLVM_CONFIG=/usr/lib/llvm$_llvmver/bin/llvm-config
25# Required to not crash gold: https://sourceware.org/bugzilla/show_bug.cgi?id=23856
26export CFLAGS="$CFLAGS -fPIE"
27
28build() {
29 make \
30 config=release \
31 default_pic=true \
32 link=llvm-dynamic \
33 verbose=true
34
35 paxmark m build/release/ponyc \
36 build/release/libponyc.tests
37
38 mkdir docs
39 build/release/ponyc packages/stdlib -rexpr -g -o docs
40}
41
42check() {
43 make test
44}
45
46package() {
47 make \
48 config=release \
49 default_pic=true \
50 link=llvm-dynamic \
51 ponydir="$pkgdir"/usr/lib/pony/$pkgver \
52 prefix="$pkgdir"/usr \
53 install
54
55 # links to $pkgdir
56 ln -sf /usr/lib/pony/$pkgver/lib/native/libponyrt.a "$pkgdir"/usr/lib/libponyrt.a
57 ln -sf /usr/lib/pony/$pkgver/lib/native/libponyrt-pic.a "$pkgdir"/usr/lib/libponyrt-pic.a
58 ln -sf /usr/lib/pony/$pkgver/lib/native/libponyc.a "$pkgdir"/usr/lib/libponyc.a
59 ln -sf /usr/lib/pony/$pkgver/bin/ponyc "$pkgdir"/usr/bin/ponyc
60
61 # We install these manually in dev()
62 rm -r "$pkgdir"/usr/include/
63
64 mkdir -p "$pkgdir"/usr/share/doc/$pkgname
65 cp -r docs/stdlib-docs/docs "$pkgdir"/usr/share/doc/$pkgname/stdlib
66}
67
68# Note: libponyrt*.a and libponyc.a are needed in runtime.
69dev() {
70 pkgdesc="$pkgdesc (development files)"
71 depends="$pkgname=$pkgver-r$pkgrel"
72
73 mkdir -p "$subpkgdir"/usr/
74 mv "$pkgdir"/usr/lib/pony/$pkgver/include "$subpkgdir"/usr
75}
76
77sha512sums="cc02bdac029325689fbe7a5c9e8c9f8a8adf9346e17a6c626c9eca8dcae110c3cf4fb9af348b603e9804dff97183e02687f092d76b62e4bb13e571cd1c7585e8 ponyc-0.33.2.tar.gz
7838aa40f6000dcb823be7b542cdad8d04b6ac4cd0a4fff1a472520a7cb71631fb34e5bee74914fe559674594dd901aede91390809e143dd96c5d68a16f8ac196c more-portable-ln.patch
79ce98aa2e33d057714703364509afd15e42ba53b5fefd42b66b9996a69036767595b868ddda592695bb109f09a7e1de118a53f262c2b23cbdf0b84063245f8b1b makefile-remove-march-mtune.patch
801c59f43f8aae369a0fc05c23082e86562d46f943a54e7490d5cb4f5087096213b44d7bda7fde9a1a536536c6f40fa29b9a88b3ac6c0e8e1d33c4a38f9201bc90 rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch"
diff --git a/unmaintained/ponyc/makefile-remove-march-mtune.patch b/unmaintained/ponyc/makefile-remove-march-mtune.patch
new file mode 100644
index 0000000000..2b81fb00a4
--- /dev/null
+++ b/unmaintained/ponyc/makefile-remove-march-mtune.patch
@@ -0,0 +1,39 @@
1Don't hassle with -march and -mtune, use gcc defaults.
2
3diff --git a/Makefile-ponyc b/Makefile-ponyc
4index 50f4936..8f28e1a 100644
5--- a/Makefile-ponyc
6+++ b/Makefile-ponyc
7@@ -108,9 +108,9 @@ else
8 endif
9
10 LIB_EXT ?= a
11-BUILD_FLAGS = -march=$(arch) -mtune=$(tune) -Werror -Wconversion \
12+BUILD_FLAGS = -Werror -Wconversion \
13 -Wno-sign-conversion -Wextra -Wall
14-LINKER_FLAGS = -march=$(arch) -mtune=$(tune) $(LDFLAGS)
15+LINKER_FLAGS = $(LDFLAGS)
16 AR_FLAGS ?= rcs
17 ALL_CFLAGS = -std=gnu11 -fexceptions \
18 -DPONY_VERSION=\"$(tag)\" -DLLVM_VERSION=\"$(llvm_version)\" \
19@@ -120,7 +120,7 @@ ALL_CFLAGS = -std=gnu11 -fexceptions \
20 -DPONY_VERSION_STR=\"$(version_str)\" \
21 -D_FILE_OFFSET_BITS=64
22 ALL_CXXFLAGS = -std=gnu++11 -fno-rtti
23-LL_FLAGS = -mcpu=$(cpu)
24+LL_FLAGS =
25
26 # Determine pointer size in bits.
27 BITS := $(bits)
28@@ -147,11 +147,6 @@
29 endif
30 endif
31
32-ifneq ($(fpu),)
33- BUILD_FLAGS += -mfpu=$(fpu)
34- LINKER_FLAGS += -mfpu=$(fpu)
35-endif
36-
37 ifdef link
38 ifeq (,$(filter $(link),static llvm-static llvm-dynamic))
39 $(error Unknown linking strategy "$(link)")
diff --git a/unmaintained/ponyc/more-portable-ln.patch b/unmaintained/ponyc/more-portable-ln.patch
new file mode 100644
index 0000000000..51235e95c8
--- /dev/null
+++ b/unmaintained/ponyc/more-portable-ln.patch
@@ -0,0 +1,16 @@
1https://github.com/ponylang/ponyc/issues/3169
2--- a/Makefile-ponyc
3+++ b/Makefile-ponyc
4@@ -95,11 +95,7 @@
5 endif
6 endif
7
8-ifneq (,$(filter $(OSTYPE), osx bsd))
9- symlink.flags = -sf
10-else
11- symlink.flags = -srf
12-endif
13+symlink.flags = -sf
14
15 ifneq (,$(filter $(OSTYPE), osx bsd))
16 SED_INPLACE = sed -i -e
diff --git a/unmaintained/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch b/unmaintained/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
new file mode 100644
index 0000000000..d8b4ece867
--- /dev/null
+++ b/unmaintained/ponyc/rename-SO_RCVTIMEO-SO_SNDTIMEO-with-OLD-suffix.patch
@@ -0,0 +1,25 @@
1https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=45bdc66159d49bfc7f75fe02d25bc74f5d2660cf
2--- a/src/libponyrt/lang/socket.c
3+++ b/src/libponyrt/lang/socket.c
4@@ -4470,8 +4470,8 @@
5 #ifdef SO_RCVLOWAT
6 case 886: return SO_RCVLOWAT;
7 #endif
8-#ifdef SO_RCVTIMEO
9- case 887: return SO_RCVTIMEO;
10+#ifdef SO_RCVTIMEO_OLD
11+ case 887: return SO_RCVTIMEO_OLD;
12 #endif
13 #ifdef SO_RDS_TRANSPORT
14 case 888: return SO_RDS_TRANSPORT;
15@@ -4527,8 +4527,8 @@
16 #ifdef SO_SNDLOWAT
17 case 905: return SO_SNDLOWAT;
18 #endif
19-#ifdef SO_SNDTIMEO
20- case 906: return SO_SNDTIMEO;
21+#ifdef SO_SNDTIMEO_OLD
22+ case 906: return SO_SNDTIMEO_OLD;
23 #endif
24 #ifdef SO_TIMESTAMP
25 case 907: return SO_TIMESTAMP;