aboutsummaryrefslogtreecommitdiff
path: root/community/duktape/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/duktape/APKBUILD')
-rw-r--r--community/duktape/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/duktape/APKBUILD b/community/duktape/APKBUILD
new file mode 100644
index 0000000000..c85dc51ab2
--- /dev/null
+++ b/community/duktape/APKBUILD
@@ -0,0 +1,31 @@
1# Contributor: Cory Sanin <corysanin@outlook.com>
2# Maintainer: Cory Sanin <corysanin@outlook.com>
3pkgname=duktape
4pkgver=2.5.0
5pkgrel=0
6pkgdesc="Embeddable Javascript engine with a focus on portability and compact footprint"
7url="https://duktape.org"
8arch="all"
9license="MIT"
10options="!check" # no tests in release archive
11subpackages="$pkgname-dev"
12source="https://duktape.org/duktape-$pkgver.tar.xz
13 $pkgname.pc
14 "
15
16build() {
17 make -f ./Makefile.sharedlibrary
18}
19
20check() {
21 make check # update if tests are added
22}
23
24package() {
25 make -f ./Makefile.sharedlibrary install INSTALL_PREFIX="$pkgdir/usr"
26 mkdir -p "$pkgdir/usr/lib/pkgconfig/"
27 sed "s/@VERSION@/$pkgver/" "$srcdir/$pkgname.pc" > "$pkgdir/usr/lib/pkgconfig/$pkgname.pc"
28}
29
30sha512sums="230e298a91cb48407d7c2a4b7c85cf9d53151d550e2fd7ba6cb8f9115682abce295fb78a3c3cd22b4812ce86944dd6d28c2b25c3845668a17232e3a08ea63837 duktape-2.5.0.tar.xz
31f7dc8853602233d67b69aff0ae32e9ed4c4a4888edfd27729174e240eca57a8f93a8b9db50e851091bed9cbed8d0028203a925c8424ea0c6f81a1dc046b9297d duktape.pc"