aboutsummaryrefslogtreecommitdiff
path: root/community/git-review/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-review/APKBUILD')
-rw-r--r--community/git-review/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/git-review/APKBUILD b/community/git-review/APKBUILD
new file mode 100644
index 0000000000..c2173a7fba
--- /dev/null
+++ b/community/git-review/APKBUILD
@@ -0,0 +1,31 @@
1# Contributor: Francesco Colista <fcolista@alpinelinux.org>
2# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
3pkgname=git-review
4pkgver=1.28.0
5pkgrel=3
6pkgdesc="A git command for submitting branches to Gerrit"
7url="https://github.com/openstack-infra/git-review"
8arch="noarch"
9license="Apache-2.0"
10depends="git python3 py3-requests py3-idna py3-urllib3 py3-chardet py3-certifi py3-setuptools"
11makedepends="python3-dev"
12subpackages="$pkgname-doc"
13source="$pkgname-$pkgver.tar.gz::https://github.com/openstack-infra/$pkgname/archive/$pkgver.tar.gz"
14builddir="$srcdir/$pkgname-$pkgver"
15
16build() {
17 cd "$builddir"
18 python3 setup.py build
19}
20
21check() {
22 cd "$builddir"
23 python3 setup.py check
24}
25
26package() {
27 cd "$builddir"
28 python3 setup.py install --prefix=/usr --root="$pkgdir"
29}
30
31sha512sums="21a71172b474ca0446f58d567e2c1b37059af3b680a3e441bcf94607d05f1fefa932ecef95328e1d77f0b71928477fd2878806ea26d2c4da030f281de15a210d git-review-1.28.0.tar.gz"