aboutsummaryrefslogtreecommitdiff
path: root/community/ladspa/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ladspa/APKBUILD')
-rw-r--r--community/ladspa/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/ladspa/APKBUILD b/community/ladspa/APKBUILD
new file mode 100644
index 0000000000..7d96045316
--- /dev/null
+++ b/community/ladspa/APKBUILD
@@ -0,0 +1,30 @@
1# Contributor: Carlo Landmeter <clandmeter@gmail.com>
2# Maintainer: David Demelier <markand@malikania.fr>
3pkgname=ladspa
4pkgver=1.15
5pkgrel=0
6pkgdesc="Linux Audio Developer's Simple Plug-in API, examples and tools"
7url="https://www.ladspa.org"
8arch="all"
9license="LGPL-2.0-or-later"
10subpackages="$pkgname-dev"
11source="https://www.ladspa.org/download/ladspa_sdk_$pkgver.tgz
12 fix-memleak-in-plugin-scanning.patch"
13builddir="$srcdir/ladspa_sdk_$pkgver/src"
14
15build() {
16 make targets
17}
18
19check() {
20 make test
21}
22
23package() {
24 make INSTALL_PLUGINS_DIR="$pkgdir/usr/lib/ladspa/" \
25 INSTALL_INCLUDE_DIR="$pkgdir/usr/include/" \
26 INSTALL_BINARY_DIR="$pkgdir/usr/bin/" install
27}
28
29sha512sums="a521622e23d988284244003e4ccfc3b42f6ddc7944cb00e7949b87e09d7f39a0cbb64b6d8b5a5af0a5ccf7179f88815416a88f02d3912957167e54b74accfc65 ladspa_sdk_1.15.tgz
301a96b24a47c2c82f7c2f66e2ee711f0ecbed9b03260562b72ced1bd4c8f0e518d15fc7c15951b95b1999e3dae1723b855fd3431a9795279f8a88ad68900e48e7 fix-memleak-in-plugin-scanning.patch"