aboutsummaryrefslogtreecommitdiff
path: root/community/libupnp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/libupnp/APKBUILD')
-rw-r--r--community/libupnp/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/libupnp/APKBUILD b/community/libupnp/APKBUILD
new file mode 100644
index 0000000000..b09a9280c6
--- /dev/null
+++ b/community/libupnp/APKBUILD
@@ -0,0 +1,37 @@
1# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
2# Contributor: Francesco Colista <fcolista@alpinelinux.org>
3# Contributor: Mike Crute <mike@crute.us>
4pkgname=libupnp
5pkgver=1.12.1
6pkgrel=0
7pkgdesc="Portable Open Source UPnP Development Kit"
8url="http://pupnp.sourceforge.net"
9arch="all"
10license="BSD-3-Clause"
11makedepends="automake autoconf libtool"
12subpackages="$pkgname-dev"
13source="https://github.com/pupnp/pupnp/releases/download/release-$pkgver/libupnp-$pkgver.tar.bz2"
14
15prepare() {
16 default_prepare
17 autoreconf
18}
19
20build() {
21 ./configure \
22 --prefix=/usr \
23 --enable-ipv6 \
24 --enable-static=no \
25 --enable-reuseaddr
26 make
27}
28
29check() {
30 make check
31}
32
33package() {
34 make DESTDIR="$pkgdir" install
35}
36
37sha512sums="f13833118d08fc05273dc65a12596854b937c505b20d82e58eb1c2e1fa35dba0cafd5799475e030f3c698069046cc5256e6ef5afe398680e7ea881df953b95e6 libupnp-1.12.1.tar.bz2"