aboutsummaryrefslogtreecommitdiff
path: root/community/ntpsec/python-to-python3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/ntpsec/python-to-python3.patch')
-rw-r--r--community/ntpsec/python-to-python3.patch404
1 files changed, 0 insertions, 404 deletions
diff --git a/community/ntpsec/python-to-python3.patch b/community/ntpsec/python-to-python3.patch
deleted file mode 100644
index 46c202cfa4..0000000000
--- a/community/ntpsec/python-to-python3.patch
+++ /dev/null
@@ -1,404 +0,0 @@
1diff --git a/attic/calc_tickadj/calc_tickadj b/attic/calc_tickadj/calc_tickadj
2index c8fda06..df316e0 100755
3--- a/attic/calc_tickadj/calc_tickadj
4+++ b/attic/calc_tickadj/calc_tickadj
5@@ -1,4 +1,4 @@
6-#!/usr/bin/env python
7+#!/usr/bin/env python3
8 #
9 # drift of 104.8576 -> +1 tick. Base of 10000 ticks.
10 #
11diff --git a/buildprep b/buildprep
12index 9de9cb8..60fae56 100755
13--- a/buildprep
14+++ b/buildprep
15@@ -54,7 +54,7 @@ done
16 # Python 3 equivalents with a python3 prefix. Compute the correct value for the
17 # infix based on system Python. This eill start to be significant after Python 2
18 # EOLs at the beginning of 2020.
19-PYVERS=`python --version 2>&1 | sed -n -e '/Python \([0-9]\).*/s//\1/p'`
20+PYVERS=`python3 --version 2>&1 | sed -n -e '/Python \([0-9]\).*/s//\1/p'`
21 if [ "$PYVERS" = "2" ]
22 then
23 PYVERS=""
24@@ -164,7 +164,7 @@ daemon () {
25 # Prerequisites to build the daemon: bison, pps-tools, service libraries
26 case $installer in
27 apk)
28- $install build-base python # basic tools
29+ $install build-base python${PYVERS} # basic tools
30 $install bison python${PYVERS}-dev linux-headers
31 $install openssl-dev libcap-dev libseccomp-dev
32 # probably needs more, but this builds
33diff --git a/contrib/cpu-temp-log b/contrib/cpu-temp-log
34index 340c4c8..be9896d 100755
35--- a/contrib/cpu-temp-log
36+++ b/contrib/cpu-temp-log
37@@ -1,4 +1,4 @@
38-#!/usr/bin/env python
39+#!/usr/bin/env python3
40 # coding: utf-8
41 """\
42 Usage: cpu-temper-log
43diff --git a/contrib/make-leap-seconds.py b/contrib/make-leap-seconds.py
44index 89fb475..a5b3837 100755
45--- a/contrib/make-leap-seconds.py
46+++ b/contrib/make-leap-seconds.py
47@@ -1,4 +1,4 @@
48-#!/usr/bin/env python
49+#!/usr/bin/env python3
50 """\
51 make-leap-seconds.py - make leap second file for testing
52
53diff --git a/contrib/ntpconfigtest b/contrib/ntpconfigtest
54index 6f76150..e494a78 100755
55--- a/contrib/ntpconfigtest
56+++ b/contrib/ntpconfigtest
57@@ -1,4 +1,4 @@
58-#!/usr/bin/env python
59+#!/usr/bin/env python3
60
61 # On Linux systems, read /proc/config.gz and check for the
62 # needed kernel options.
63diff --git a/contrib/ntpheat b/contrib/ntpheat
64index 36f5d06..285c5e4 100755
65--- a/contrib/ntpheat
66+++ b/contrib/ntpheat
67@@ -1,4 +1,4 @@
68-#!/usr/bin/env python
69+#!/usr/bin/env python3
70 #
71 # generate some heat!
72 #
73diff --git a/contrib/ntpheatusb b/contrib/ntpheatusb
74index 496047e..6011258 100755
75--- a/contrib/ntpheatusb
76+++ b/contrib/ntpheatusb
77@@ -1,4 +1,4 @@
78-#!/usr/bin/env python
79+#!/usr/bin/env python3
80 #
81 # generate some heat!
82 #
83diff --git a/contrib/smartctl-temp-log b/contrib/smartctl-temp-log
84index 9deaa9e..180b91e 100755
85--- a/contrib/smartctl-temp-log
86+++ b/contrib/smartctl-temp-log
87@@ -1,4 +1,4 @@
88-#!/usr/bin/env python
89+#!/usr/bin/env python3
90 # coding: utf-8
91 """\
92 Usage: smartctl-temp-log [device]
93diff --git a/contrib/temper-temp-log b/contrib/temper-temp-log
94index 441d4ff..6f69605 100755
95--- a/contrib/temper-temp-log
96+++ b/contrib/temper-temp-log
97@@ -1,4 +1,4 @@
98-#!/usr/bin/env python
99+#!/usr/bin/env python3
100 # coding: utf-8
101 """\
102 Usage: temper-temper-log
103diff --git a/contrib/zone-temp-log b/contrib/zone-temp-log
104index a3cbbce..5277a0f 100755
105--- a/contrib/zone-temp-log
106+++ b/contrib/zone-temp-log
107@@ -1,4 +1,4 @@
108-#!/usr/bin/env python
109+#!/usr/bin/env python3
110 # coding: utf-8
111 """\
112 Usage: zone-temper-log
113diff --git a/devel/linkcheck b/devel/linkcheck
114index 528de19..bf31e65 100755
115--- a/devel/linkcheck
116+++ b/devel/linkcheck
117@@ -1,4 +1,4 @@
118-#!/usr/bin/env python
119+#!/usr/bin/env python3
120 #
121 # linkcheck - check link integrity in an asciidoc document tree
122 #
123diff --git a/devel/python_paths.py b/devel/python_paths.py
124index d17e592..d4dc616 100755
125--- a/devel/python_paths.py
126+++ b/devel/python_paths.py
127@@ -1,4 +1,4 @@
128-#!/usr/bin/env python
129+#!/usr/bin/env python3
130
131 """Find all Pythons in the command path, and corresponding exe/lib locations.
132
133diff --git a/devel/release.nix b/devel/release.nix
134index 9bc7e32..db87d23 100644
135--- a/devel/release.nix
136+++ b/devel/release.nix
137@@ -29,7 +29,7 @@ in with derivationOptions; rec {
138 runHook preDist
139
140 echo "dist flags: $distFlags ''${distFlagsArray[@]}"
141- python waf dist $distFlags "''${distFlagsArray[@]}"
142+ python3 waf dist $distFlags "''${distFlagsArray[@]}"
143
144 if [ "$dontCopyDist" != 1 ]; then
145 mkdir -p "$out/tarballs"
146@@ -57,7 +57,7 @@ in with derivationOptions; rec {
147 fi
148
149 echo "configure flags: $configureFlags ''${configureFlagsArray[@]}"
150- python waf configure $configureFlags "''${configureFlagsArray[@]}"
151+ python3 waf configure $configureFlags "''${configureFlagsArray[@]}"
152
153 runHook postConfigure
154 '';
155@@ -66,7 +66,7 @@ in with derivationOptions; rec {
156 runHook preBuild
157
158 echo "build flags: $makeFlags ''${makeFlagsArray[@]} $buildFlags ''${buildFlagsArray[@]}"
159- python waf build \
160+ python3 waf build \
161 ''${enableParallelBuilding:+-j$NIX_BUILD_CORES} \
162 $makeFlags "''${makeFlagsArray[@]}" \
163 $buildFlags "''${buildFlagsArray[@]}"
164@@ -79,7 +79,7 @@ in with derivationOptions; rec {
165 runHook preCheck
166
167 echo "check flags: $makeFlags ''${makeFlagsArray[@]} ''${checkFlags:+-v} ''${checkFlagsArray[@]}"
168- python waf check \
169+ python3 waf check \
170 ''${enableParallelBuilding:+-j$NIX_BUILD_CORES} \
171 $makeFlags "''${makeFlagsArray[@]}" \
172 ''${checkFlags:+-v} "''${checkFlagsArray[@]}"
173@@ -94,7 +94,7 @@ in with derivationOptions; rec {
174 mkdir -p "$prefix"
175
176 echo "install flags: $makeFlags ''${makeFlagsArray[@]} ''${installFlags:+-v} ''${installFlagsArray[@]}"
177- python waf install \
178+ python3 waf install \
179 $makeFlags "''${makeFlagsArray[@]}" \
180 ''${installFlags:+-v} "''${installFlagsArray[@]}"
181
182diff --git a/ntpclients/ntpdig.py b/ntpclients/ntpdig.py
183index 9dc5aab..56dfc47 100644
184--- a/ntpclients/ntpdig.py
185+++ b/ntpclients/ntpdig.py
186@@ -1,4 +1,4 @@
187-#!/usr/bin/env python
188+#!/usr/bin/env python3
189 # -*- coding: utf-8 -*-
190 """
191 ntpdig - simple SNTP client
192diff --git a/ntpclients/ntpkeygen.py b/ntpclients/ntpkeygen.py
193index 8d3b37d..d9ab0ba 100644
194--- a/ntpclients/ntpkeygen.py
195+++ b/ntpclients/ntpkeygen.py
196@@ -1,4 +1,4 @@
197-#!/usr/bin/env python
198+#!/usr/bin/env python3
199 # -*- coding: utf-8 -*-
200 '''
201 ntpkeygen - generate cryptographic keys for NTP clients and servers
202diff --git a/ntpclients/ntploggps.py b/ntpclients/ntploggps.py
203index fe44914..8d498b9 100644
204--- a/ntpclients/ntploggps.py
205+++ b/ntpclients/ntploggps.py
206@@ -1,4 +1,4 @@
207-#!/usr/bin/env python
208+#!/usr/bin/env python3
209 # -*- coding: utf-8 -*-
210
211 """\
212diff --git a/ntpclients/ntplogtemp.py b/ntpclients/ntplogtemp.py
213index 3129822..3a4b00a 100644
214--- a/ntpclients/ntplogtemp.py
215+++ b/ntpclients/ntplogtemp.py
216@@ -1,4 +1,4 @@
217-#!/usr/bin/env python
218+#!/usr/bin/env python3
219 # -*- coding: utf-8 -*-
220
221 """\
222diff --git a/ntpclients/ntpmon.py b/ntpclients/ntpmon.py
223index d286f67..25083b2 100644
224--- a/ntpclients/ntpmon.py
225+++ b/ntpclients/ntpmon.py
226@@ -1,4 +1,4 @@
227-#!/usr/bin/env python
228+#!/usr/bin/env python3
229 # -*- coding: utf-8 -*-
230
231 # SPDX-License-Identifier: BSD-2-Clause
232diff --git a/ntpclients/ntpq.py b/ntpclients/ntpq.py
233index 5e17df0..7bba901 100644
234--- a/ntpclients/ntpq.py
235+++ b/ntpclients/ntpq.py
236@@ -1,4 +1,4 @@
237-#!/usr/bin/env python
238+#!/usr/bin/env python3
239 # -*- coding: utf-8 -*-
240 #
241 # ntpq - query an NTP server using mode 6 commands
242diff --git a/ntpclients/ntpsnmpd.py b/ntpclients/ntpsnmpd.py
243index 1382f19..34a9448 100644
244--- a/ntpclients/ntpsnmpd.py
245+++ b/ntpclients/ntpsnmpd.py
246@@ -1,4 +1,4 @@
247-#!/usr/bin/env python
248+#!/usr/bin/env python3
249 # -*- coding: utf-8 -*-
250
251 from __future__ import print_function, division
252diff --git a/ntpclients/ntpsweep.py b/ntpclients/ntpsweep.py
253index 22b2a45..732b2b1 100644
254--- a/ntpclients/ntpsweep.py
255+++ b/ntpclients/ntpsweep.py
256@@ -1,4 +1,4 @@
257-#!/usr/bin/env python
258+#!/usr/bin/env python3
259 # -*- coding: utf-8 -*-
260 """
261 ntpsweep - print various information about given NTP servers
262diff --git a/ntpclients/ntptrace.py b/ntpclients/ntptrace.py
263index 09c857e..1adea21 100644
264--- a/ntpclients/ntptrace.py
265+++ b/ntpclients/ntptrace.py
266@@ -1,4 +1,4 @@
267-#!/usr/bin/env python
268+#!/usr/bin/env python3
269 # -*- coding: utf-8 -*-
270 """
271 ntptrace - trace peers of an NTP server
272diff --git a/ntpclients/ntpviz.py b/ntpclients/ntpviz.py
273index 163f998..d501f0d 100644
274--- a/ntpclients/ntpviz.py
275+++ b/ntpclients/ntpviz.py
276@@ -1,4 +1,4 @@
277-#!/usr/bin/env python
278+#!/usr/bin/env python3
279 # -*- coding: utf-8 -*-
280 """\
281 ntpviz - visualizer for NTP log files
282diff --git a/ntpclients/ntpwait.py b/ntpclients/ntpwait.py
283index 972e83e..d879682 100644
284--- a/ntpclients/ntpwait.py
285+++ b/ntpclients/ntpwait.py
286@@ -1,4 +1,4 @@
287-#!/usr/bin/env python
288+#!/usr/bin/env python3
289 # -*- coding: utf-8 -*-
290 """\
291 ntpwait - Wait for ntpd to stabilize the system clock.
292diff --git a/pylib/agentx.py b/pylib/agentx.py
293index c018ac1..f1dd5f6 100644
294--- a/pylib/agentx.py
295+++ b/pylib/agentx.py
296@@ -1,4 +1,4 @@
297-#!/usr/bin/env python
298+#!/usr/bin/env python3
299 # -*- coding: utf-8 -*-
300
301 from __future__ import print_function, division
302diff --git a/pylib/poly.py b/pylib/poly.py
303index 8d29d67..d23606e 100644
304--- a/pylib/poly.py
305+++ b/pylib/poly.py
306@@ -1,4 +1,4 @@
307-#!/usr/bin/env python
308+#!/usr/bin/env python3
309 # -*- coding: utf-8 -*-
310 # SPDX-License-Identifier: BSD-2-Clause
311 """Handle bytes and strings in a polyglot fashion.
312diff --git a/tests/option-tester.sh b/tests/option-tester.sh
313index 0a513df..5dd9937 100755
314--- a/tests/option-tester.sh
315+++ b/tests/option-tester.sh
316@@ -77,7 +77,7 @@ grep "The configuration failed" test*/test.log
317 grep ^Trouble test*/test.log
318 echo
319
320-echo -n "## "; python --version
321+echo -n "## "; python3 --version
322 if test -n "$PYTHONPATH"
323 then
324 echo "## PYTHONPATH is" \"$PYTHONPATH\"
325diff --git a/tests/pylib/jigs.py b/tests/pylib/jigs.py
326index ca67c17..9cbc693 100644
327--- a/tests/pylib/jigs.py
328+++ b/tests/pylib/jigs.py
329@@ -1,4 +1,4 @@
330-#!/usr/bin/env python
331+#!/usr/bin/env python3
332 # -*- coding: utf-8 -*-
333
334 from __future__ import print_function, division
335diff --git a/tests/pylib/test_agentx.py b/tests/pylib/test_agentx.py
336index 211b3f9..cbf322a 100644
337--- a/tests/pylib/test_agentx.py
338+++ b/tests/pylib/test_agentx.py
339@@ -1,4 +1,4 @@
340-#!/usr/bin/env python
341+#!/usr/bin/env python3
342 # -*- coding: utf-8 -*-
343
344 import ntp.agentx as AX
345diff --git a/tests/pylib/test_agentx_packet.py b/tests/pylib/test_agentx_packet.py
346index 41ee384..ded4628 100644
347--- a/tests/pylib/test_agentx_packet.py
348+++ b/tests/pylib/test_agentx_packet.py
349@@ -1,4 +1,4 @@
350-#!/usr/bin/env python
351+#!/usr/bin/env python3
352 # -*- coding: utf-8 -*-
353
354 import unittest
355diff --git a/tests/pylib/test_packet.py b/tests/pylib/test_packet.py
356index 0ffb0d2..4825f54 100644
357--- a/tests/pylib/test_packet.py
358+++ b/tests/pylib/test_packet.py
359@@ -1,4 +1,4 @@
360-#!/usr/bin/env python
361+#!/usr/bin/env python3
362 # -*- coding: utf-8 -*-
363
364 from __future__ import print_function, division
365diff --git a/tests/pylib/test_statfiles.py b/tests/pylib/test_statfiles.py
366index 307ca87..d133727 100644
367--- a/tests/pylib/test_statfiles.py
368+++ b/tests/pylib/test_statfiles.py
369@@ -1,4 +1,4 @@
370-#!/usr/bin/env python
371+#!/usr/bin/env python3
372 # -*- coding: utf-8 -*-
373
374 import unittest
375diff --git a/tests/pylib/test_util.py b/tests/pylib/test_util.py
376index 3a3ce85..64f2955 100644
377--- a/tests/pylib/test_util.py
378+++ b/tests/pylib/test_util.py
379@@ -1,4 +1,4 @@
380-#!/usr/bin/env python
381+#!/usr/bin/env python3
382 # -*- coding: utf-8 -*-
383
384 from __future__ import print_function
385diff --git a/waf b/waf
386index 044af45..24eb3dd 100755
387--- a/waf
388+++ b/waf
389@@ -1,4 +1,4 @@
390-#!/usr/bin/env python
391+#!/usr/bin/env python3
392 # encoding: latin-1
393 # Thomas Nagy, 2005-2018
394 #
395diff --git a/wafhelpers/pythonize-header b/wafhelpers/pythonize-header
396index c58542a..f5ce2ad 100755
397--- a/wafhelpers/pythonize-header
398+++ b/wafhelpers/pythonize-header
399@@ -1,4 +1,4 @@
400-#!/usr/bin/env python
401+#!/usr/bin/env python3
402 # -*- coding: utf-8 -*-
403 """
404 Generate a Python module from a C file of macro definitions.