aboutsummaryrefslogtreecommitdiff
path: root/community/py3-inquirer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-inquirer/APKBUILD')
-rw-r--r--community/py3-inquirer/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/py3-inquirer/APKBUILD b/community/py3-inquirer/APKBUILD
new file mode 100644
index 0000000000..c2096ef7c8
--- /dev/null
+++ b/community/py3-inquirer/APKBUILD
@@ -0,0 +1,38 @@
1# Contributor: Rasmus Thomsen <oss@cogitri.dev>
2# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
3pkgname=py3-inquirer
4pkgver=2.6.3
5pkgrel=0
6pkgdesc="A collection of common interactive command line user interfaces"
7url="https://github.com/magmax/python-inquirer"
8arch="noarch"
9license="MIT"
10depends="python3 py3-blessings py3-readchar py3-python-editor"
11makedepends="py3-setuptools"
12checkdepends="py3-flake8 py3-pexpect py3-pytest py3-pytest-cov py3-pytest-xdist
13 py3-mock py3-nosexcover py3-coveralls py3-wheel ncurses-terminfo"
14# GH tarballs required for tests!
15source="$pkgname-$pkgver.tar.gz::https://github.com/magmax/python-inquirer/archive/$pkgver.tar.gz
16 loosen-deps.patch
17 use-py3-in-tests.patch
18 disable-failing-tests.patch"
19builddir="$srcdir/python-inquirer-$pkgver"
20
21build() {
22 python3 setup.py build
23}
24
25check() {
26 TERM=xterm-256color python3 setup.py test
27}
28
29package() {
30 python3 setup.py install --prefix=/usr --root="$pkgdir"
31 # Remove installed tests
32 rm -r "$pkgdir"/usr/lib/python*/site-packages/tests
33}
34
35sha512sums="8f1fd76a1e109040ef12ab519224f100f966515af7306dd61b8fa6579b9cbc6f835d741390ef1daa4a18f755a25599579d7bfd1b6f532b4cdba99a65058dcc12 py3-inquirer-2.6.3.tar.gz
36eea162938426f59d488422b956df611d5b074926c14ff024abffb905fb1af7a80ce705c981d4ad51c33890e00b64c935234bdaa65c2daa07b46a914526d11e8e loosen-deps.patch
3708cb9047bdbb04f27162eb58c3ad6dbf0905b7a320e02be07c117f351967aa0059b14923cbbd5e73192b5009e58b70555550d010e0a857dbb9c69277488111ba use-py3-in-tests.patch
38cbc376ae4f3200fbaa9b008a8c00ad264808421be2cccea08fb903f3dcf00a773a00ac0b928b71fc1e884b7341e73be38e79d32e4693fe263b635b0d4a6b6a7b disable-failing-tests.patch"