aboutsummaryrefslogtreecommitdiff
path: root/testing/phpspy/fix-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/phpspy/fix-install.patch')
-rw-r--r--testing/phpspy/fix-install.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/phpspy/fix-install.patch b/testing/phpspy/fix-install.patch
new file mode 100644
index 0000000000..f559b83958
--- /dev/null
+++ b/testing/phpspy/fix-install.patch
@@ -0,0 +1,14 @@
1We don't want a static binary, make sure the install target respects that.
2
3diff -upr phpspy-0.5.0.orig/Makefile phpspy-0.5.0/Makefile
4--- phpspy-0.5.0.orig/Makefile 2020-05-31 18:37:11.787907276 +0200
5+++ phpspy-0.5.0/Makefile 2020-05-31 18:37:18.961241194 +0200
6@@ -55,7 +55,7 @@ test: phpspy_static $(phpspy_tests)
7 printf "Passed %d out of %d tests\n" $$pass $$total ; \
8 [ $$pass -eq $$total ] || exit 1
9
10-install: phpspy_static
11+install: phpspy_dynamic
12 install -D -v -m 755 phpspy $(DESTDIR)$(prefix)/bin/phpspy
13
14 clean: