aboutsummaryrefslogtreecommitdiff
path: root/testing/phpspy/remove-termbox-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/phpspy/remove-termbox-check.patch')
-rw-r--r--testing/phpspy/remove-termbox-check.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/testing/phpspy/remove-termbox-check.patch b/testing/phpspy/remove-termbox-check.patch
new file mode 100644
index 0000000000..c94fb32dae
--- /dev/null
+++ b/testing/phpspy/remove-termbox-check.patch
@@ -0,0 +1,16 @@
1Check fails with:
2
3 ld: unrecognized option '-Wl,--as-needed'
4 ld: use the --help option for usage information
5
6diff -upr phpspy-0.5.0.orig/Makefile phpspy-0.5.0/Makefile
7--- phpspy-0.5.0.orig/Makefile 2020-05-31 18:34:19.931393581 +0200
8+++ phpspy-0.5.0/Makefile 2020-05-31 18:34:23.341389992 +0200
9@@ -33,7 +33,6 @@ phpspy_static: $(wildcard *.c *.h) vendo
10 $(CC) $(phpspy_cflags) $(phpspy_includes) $(termbox_inlcudes) $(phpspy_defines) $(phpspy_sources) -o phpspy $(phpspy_ldflags) $(phpspy_libs) $(termbox_libs)
11
12 phpspy_dynamic: $(wildcard *.c *.h)
13- @$(or $(has_termbox), $(error Need libtermbox. Hint: try `make phpspy_static`))
14 $(CC) $(phpspy_cflags) $(phpspy_includes) $(phpspy_defines) $(phpspy_sources) -o phpspy $(phpspy_ldflags) $(phpspy_libs) -ltermbox
15
16 vendor/termbox/build/src/libtermbox.a: vendor/termbox/waf