aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/openjfx12/disable-sse2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/openjfx12/disable-sse2.patch')
-rw-r--r--unmaintained/openjfx12/disable-sse2.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/unmaintained/openjfx12/disable-sse2.patch b/unmaintained/openjfx12/disable-sse2.patch
new file mode 100644
index 0000000000..ef60f825c2
--- /dev/null
+++ b/unmaintained/openjfx12/disable-sse2.patch
@@ -0,0 +1,60 @@
1Description: Enable SSE2 on i386 and amd64 CPUs only
2Author: Emmanuel Bourg <ebourg@apache.org>
3Forwarded: no
4Taken from: https://sources.debian.org/patches/openjfx/11.0.2+1-1/08-disable-sse2.patch
5--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
6+++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
7@@ -24,13 +24,16 @@
8 -fstack-protector \
9 -Werror=implicit-function-declaration \
10 -Werror=trampolines \
11- -msse2 \
12 -fbuiltin \
13 -DHAVE_STDINT_H \
14 -DLINUX \
15 -DGST_DISABLE_LOADSAVE \
16 -DGSTREAMER_LITE \
17 -ffunction-sections -fdata-sections
18+
19+ifneq (,$(filter $(CARCH), x86 x86_64))
20+ CFLAGS += -msse2
21+endif
22
23 ifeq ($(BUILD_TYPE), Release)
24 CFLAGS += -Os
25--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
26+++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
27@@ -21,7 +21,6 @@
28 -fstack-protector \
29 -Werror=implicit-function-declaration \
30 -Werror=trampolines \
31- -msse2 \
32 -fbuiltin \
33 -DHAVE_STDINT_H \
34 -DLINUX \
35@@ -32,6 +31,10 @@
36 -DGST_DISABLE_GST_DEBUG \
37 -DGSTREAMER_LITE \
38 -ffunction-sections -fdata-sections
39+
40+ifneq (,$(filter $(CARCH), x86 x86_64))
41+ CFLAGS += -msse2
42+endif
43
44 ifeq ($(BUILD_TYPE), Release)
45 CFLAGS += -Os
46--- old/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
47+++ new/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
48@@ -43,8 +43,11 @@
49 -fstack-protector \
50 -Werror=implicit-function-declaration \
51 -Werror=trampolines \
52- -msse2 \
53 -DGSTREAMER_LITE
54+
55+ifneq (,$(filter $(CARCH), x86 x86_64))
56+ CFLAGS += -msse2
57+endif
58
59 PACKAGES_INCLUDES := $(shell pkg-config --cflags glib-2.0)
60 PACKAGES_LIBS := $(shell pkg-config --libs glib-2.0 gobject-2.0 gmodule-2.0 gthread-2.0)