aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/openjfx12/fix-arm32-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/openjfx12/fix-arm32-build.patch')
-rw-r--r--unmaintained/openjfx12/fix-arm32-build.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/unmaintained/openjfx12/fix-arm32-build.patch b/unmaintained/openjfx12/fix-arm32-build.patch
new file mode 100644
index 0000000000..153ded3d65
--- /dev/null
+++ b/unmaintained/openjfx12/fix-arm32-build.patch
@@ -0,0 +1,69 @@
1--- old/buildSrc/linux.gradle
2+++ new/buildSrc/linux.gradle
3@@ -45,10 +45,6 @@
4 "-fstack-protector",
5 "-Wextra", "-Wall", "-Wformat-security", "-Wno-unused", "-Wno-parentheses", "-Werror=implicit-function-declaration", "-Werror=trampolines"] // warning flags
6
7-if (!IS_64) {
8- commonFlags += "-m32"
9-}
10-
11 // Specify the compilation parameters and link parameters
12 def ccFlags = [
13 commonFlags, "-I$JDK_HOME/include", "-I$JDK_HOME/include/linux", "-c",
14--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
15+++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/avplugin/Makefile
16@@ -64,11 +64,6 @@
17 LDFLAGS += $(shell pkg-config --libs libavcodec libavformat)
18 endif
19
20-ifeq ($(ARCH), x32)
21- CFLAGS += -m32
22- LDFLAGS += -m32
23-endif
24-
25 SOURCES = av/fxavcodecplugin.c \
26 av/avelement.c \
27 av/decoder.c \
28--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
29+++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/fxplugins/Makefile
30@@ -55,11 +55,6 @@
31 -z relro \
32 -static-libgcc -static-libstdc++ -Wl,--gc-sections
33
34-ifeq ($(ARCH), x32)
35- CFLAGS += -m32
36- LDFLAGS += -m32
37-endif
38-
39 SOURCES = fxplugins.c \
40 progressbuffer/progressbuffer.c \
41 progressbuffer/hlsprogressbuffer.c \
42--- old/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile
43+++ new/modules/javafx.media/src/main/native/gstreamer/projects/linux/gstreamer-lite/Makefile
44@@ -80,11 +80,6 @@
45 -z relro \
46 -static-libgcc -static-libstdc++ -Wl,--gc-sections
47
48-ifeq ($(ARCH), x32)
49- CFLAGS += -m32
50- LDFLAGS += -m32
51-endif
52-
53 SOURCES = \
54 gstreamer/gst/gst.c \
55 gstreamer/gst/gstallocator.c \
56--- old/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
57+++ new/modules/javafx.media/src/main/native/jfxmedia/projects/linux/Makefile
58@@ -75,11 +75,6 @@
59 CFLAGS += -g -Wall -D_DEBUG
60 endif
61
62-ifeq ($(ARCH), x32)
63- CFLAGS += -m32
64- LDFLAGS += -m32
65-endif
66-
67 CPP_SOURCES = \
68 jni/com_sun_media_jfxmedia_logging_Logger.cpp \
69 jni/JavaBandsHolder.cpp \