aboutsummaryrefslogtreecommitdiff
path: root/unmaintained/openjfx12/use-system-icu.patch
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/openjfx12/use-system-icu.patch')
-rw-r--r--unmaintained/openjfx12/use-system-icu.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/openjfx12/use-system-icu.patch b/unmaintained/openjfx12/use-system-icu.patch
new file mode 100644
index 0000000000..5717f0c971
--- /dev/null
+++ b/unmaintained/openjfx12/use-system-icu.patch
@@ -0,0 +1,39 @@
1This patch disables usage of the bundled icu library as alpine
2already has 63.1
3This saves about 30 MB on the final jfxwebkit.so
4--- old/modules/javafx.web/src/main/native/Source/PlatformJava.cmake
5+++ new/modules/javafx.web/src/main/native/Source/PlatformJava.cmake
6@@ -1,4 +1,3 @@
7 add_subdirectory(ThirdParty/sqlite)
8-add_subdirectory(ThirdParty/icu)
9 add_subdirectory(ThirdParty/libxml)
10 add_subdirectory(ThirdParty/libxslt)
11--- old/modules/javafx.web/src/main/native/Source/WTF/wtf/unicode/java/UnicodeJava.h
12+++ new/modules/javafx.web/src/main/native/Source/WTF/wtf/unicode/java/UnicodeJava.h
13@@ -18,7 +18,7 @@
14 #if PLATFORM(JAVA) && OS(WINDOWS)
15 typedef wchar_t UChar;
16 #else
17-typedef uint16_t UChar;
18+//typedef uint16_t UChar;
19 #endif
20
21 // #ifdef UChar32
22@@ -26,7 +26,7 @@
23 // #endif
24
25 #ifndef __UMACHINE_H__ //XXX: recheck
26-typedef uint32_t UChar32;
27+//typedef uint32_t UChar32;
28 #endif
29
30 #define U_MASK(x) ((uint32_t)1<<(x))
31--- old/modules/javafx.web/src/main/native/Tools/CMakeLists.txt
32+++ new/modules/javafx.web/src/main/native/Tools/CMakeLists.txt
33@@ -48,6 +48,3 @@
34 add_subdirectory(TestWebKitAPI)
35 endif ()
36
37-if (PORT STREQUAL "Java")
38- add_subdirectory(DumpRenderTree/java)
39-endif ()