aboutsummaryrefslogtreecommitdiff
path: root/.travis
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-01-08 13:19:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-08 13:19:15 +0100
commitfa3ee36b6cb845e1e0f59a0073f658e59e6a9f3c (patch)
treeb133ac82e037f16195b3fdd4b03bedcba01af020 /.travis
parent34ca052cd7f9e3c8a040026f1c765dae1a1a7a62 (diff)
downloadalpine_aports-fa3ee36b6cb845e1e0f59a0073f658e59e6a9f3c.tar.bz2
alpine_aports-fa3ee36b6cb845e1e0f59a0073f658e59e6a9f3c.tar.xz
alpine_aports-fa3ee36b6cb845e1e0f59a0073f658e59e6a9f3c.zip
travis: build repositories in correct order
Diffstat (limited to '.travis')
-rwxr-xr-x.travis/build-pkgs12
1 files changed, 6 insertions, 6 deletions
diff --git a/.travis/build-pkgs b/.travis/build-pkgs
index 8dcf8ba21e..3d20f0754c 100755
--- a/.travis/build-pkgs
+++ b/.travis/build-pkgs
@@ -4,15 +4,15 @@ set -eu
4 4
5. "$(dirname "$0")"/common.sh 5. "$(dirname "$0")"/common.sh
6 6
7# Prints names of top-level directories (i.e. repositories) that has been 7# Prints names of repositories (top-level directories), in defined order,
8# changed/created in the specified revisions. 8# that has been changed/created in the specified revisions.
9changed_repos() { 9changed_repos() {
10 local commit_ish="$1" 10 local commit_ish="$1"
11 local repos="$(find * -type d -maxdepth 0 ! -name '.*' ! -name 'scripts')"
12 11
13 # Print names of dirs in the current directory (it's *not* recursive) 12 local repo; for repo in main community testing non-free unmaintained; do
14 # that contain some changes and consider only dirs listed in $repos. 13 git diff-tree --exit-code "$commit_ish" -- $repo >/dev/null \
15 git diff-tree --name-only "$commit_ish" -- $repos 14 || echo "$repo"
15 done
16} 16}
17 17
18# Prints names of repo's subdirs (i.e. abuilds) that contains APKBUILDs which 18# Prints names of repo's subdirs (i.e. abuilds) that contains APKBUILDs which