aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-04 14:53:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-04 14:58:13 +0000
commitb16084f37f09b6345f84b3d2ee8d350e062a67b4 (patch)
treefdbe782c2b6a3b75ed5296519f644731d01b7000
parent333a0bc64f09e2ff8e575fada7cb440e51ea5d4a (diff)
downloadalpine_aports-1.10.0.tar.bz2
alpine_aports-1.10.0.tar.xz
alpine_aports-1.10.0.zip
main/apk-tools: upgrade to 2.0.1v1.10.0
(cherry picked from commit 83fa369a43f81d3dbab1238262c75507c9724416)
-rw-r--r--main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch27
-rw-r--r--main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch46
-rw-r--r--main/apk-tools/APKBUILD10
3 files changed, 3 insertions, 80 deletions
diff --git a/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch b/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch
deleted file mode 100644
index b025a9b783..0000000000
--- a/main/apk-tools/0001-state-Default-interactive-action-is-Yes.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From d67ee300b6cbd9deaaa8c5e506e836e253f7b77d Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Fri, 25 Dec 2009 07:02:32 +0000
4Subject: [PATCH 1/2] state: Default interactive action is Yes
5
6When pressing only <enter> on the question "..continue [Y/n]?" then
7lets take that as a "yes"
8---
9 src/state.c | 2 +-
10 1 files changed, 1 insertions(+), 1 deletions(-)
11
12diff --git a/src/state.c b/src/state.c
13index 94afe86..1bd29bf 100644
14--- a/src/state.c
15+++ b/src/state.c
16@@ -771,7 +771,7 @@ int apk_state_commit(struct apk_state *state,
17 printf("Do you want to continue [Y/n]? ");
18 fflush(stdout);
19 r = fgetc(stdin);
20- if (r != 'y' && r != 'Y')
21+ if (r != 'y' && r != 'Y' && r != '\n')
22 return -1;
23 }
24 }
25--
261.6.5.7
27
diff --git a/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch b/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch
deleted file mode 100644
index 3061ed5609..0000000000
--- a/main/apk-tools/0002-db-keep-packages-with-no-files-with-installed-status.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 3f9fe4c28be7987bd404f06e27ed03aafd8e8b52 Mon Sep 17 00:00:00 2001
2From: Timo Teras <timo.teras@iki.fi>
3Date: Fri, 25 Dec 2009 14:14:40 +0200
4Subject: [PATCH 2/2] db: keep packages with no files with installed status
5
6got broke few commits ago when apk_pkg_installed() call was
7moved to happen after the package name has been read.
8---
9 src/database.c | 16 ++++++++++------
10 1 files changed, 10 insertions(+), 6 deletions(-)
11
12diff --git a/src/database.c b/src/database.c
13index 5118f5c..2fcb275 100644
14--- a/src/database.c
15+++ b/src/database.c
16@@ -587,17 +587,21 @@ int apk_db_index_read(struct apk_database *db, struct apk_bstream *bs, int repo)
17 }
18
19 /* Standard index line? */
20- if (apk_pkg_add_info(db, pkg, field, l) == 0)
21+ if (apk_pkg_add_info(db, pkg, field, l) == 0) {
22+ if (repo == -1 && field == 'S') {
23+ /* Instert to installed database; this needs to
24+ * happen after package name has been read, but
25+ * before first FDB entry. */
26+ ipkg = apk_pkg_install(db, pkg);
27+ diri_node = hlist_tail_ptr(&ipkg->owned_dirs);
28+ }
29 continue;
30+ }
31
32- if (repo != -1) {
33+ if (repo != -1 || ipkg == NULL) {
34 apk_error("Invalid index entry '%c'", field);
35 return -1;
36 }
37- if (ipkg == NULL) {
38- ipkg = apk_pkg_install(db, pkg);
39- diri_node = hlist_tail_ptr(&ipkg->owned_dirs);
40- }
41
42 /* Check FDB special entries */
43 switch (field) {
44--
451.6.5.7
46
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index 3db72d348d..3e81ac8568 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,14 +1,12 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=apk-tools 2pkgname=apk-tools
3pkgver=2.0 3pkgver=2.0.1
4pkgrel=1 4pkgrel=0
5pkgdesc="Alpine Package Keeper - package manager for alpine" 5pkgdesc="Alpine Package Keeper - package manager for alpine"
6subpackages="$pkgname-static" 6subpackages="$pkgname-static"
7depends= 7depends=
8makedepends="zlib-dev openssl-dev pkgconfig" 8makedepends="zlib-dev openssl-dev pkgconfig"
9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
10 0001-state-Default-interactive-action-is-Yes.patch
11 0002-db-keep-packages-with-no-files-with-installed-status.patch
12 " 10 "
13 11
14 12
@@ -42,6 +40,4 @@ static() {
42 "$subpkgdir"/sbin/apk.static 40 "$subpkgdir"/sbin/apk.static
43} 41}
44 42
45md5sums="dc827e62065c940bbcec1c93099a5718 apk-tools-2.0.tar.bz2 43md5sums="0412a168cdc15066a5ae2015fb9cba01 apk-tools-2.0.1.tar.bz2"
4636e514cbc781759dbb6eb84e35f6072d 0001-state-Default-interactive-action-is-Yes.patch
47180368300d46c5b6de0d5eb43d90547e 0002-db-keep-packages-with-no-files-with-installed-status.patch"