aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-31 12:41:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-31 12:41:05 +0000
commit05eec38aed3ecffa1cbd3fb9d50c62a77ba073d8 (patch)
tree5466140ae3eed7cde223f17951fa542096711737
parent084fbe61fa206586f66dcb25e64a3ed7fe836068 (diff)
downloadalpine_aports-1.9.0_alpha18.tar.bz2
alpine_aports-1.9.0_alpha18.tar.xz
alpine_aports-1.9.0_alpha18.zip
main/alpine-conf: lbu remove packages.list if it existv1.9.0_alpha18
fixes #94
-rw-r--r--main/alpine-conf/0001-lbu-remove-packages.list-if-exist.patch43
-rw-r--r--main/alpine-conf/APKBUILD7
2 files changed, 48 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-lbu-remove-packages.list-if-exist.patch b/main/alpine-conf/0001-lbu-remove-packages.list-if-exist.patch
new file mode 100644
index 0000000000..f7ce644d44
--- /dev/null
+++ b/main/alpine-conf/0001-lbu-remove-packages.list-if-exist.patch
@@ -0,0 +1,43 @@
1From fbe26c92439f4b4f19ee09ec07798a5bbaec0d77 Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Wed, 29 Jul 2009 19:30:36 +0000
4Subject: [PATCH] lbu: remove packages.list if exist
5
6fixes http://redmine.alpinelinux.org/issues/show/94
7---
8 lbu.in | 10 ++++++++--
9 1 files changed, 8 insertions(+), 2 deletions(-)
10
11diff --git a/lbu.in b/lbu.in
12index 48e615e..b84682a 100644
13--- a/lbu.in
14+++ b/lbu.in
15@@ -233,6 +233,12 @@ cmd_package() {
16 tmppkg="$tmpdir/$(basename $pkg)"
17
18 cd "${ROOT:-/}"
19+ # remove old package.list
20+ if [ -f etc/lbu/packages.list ] && [ -f var/lib/apk/world ]; then
21+ echo "Note: Removing /etc/lbu/packages.list."
22+ echo " /var/lib/apk/world will be used."
23+ rm -f etc/lbu/packages.list
24+ fi
25 currentlist=$(apk audit --backup -q)
26 if [ -f var/lib/apk/world ]; then
27 currentlist="$currentlist var/lib/apk/world"
28@@ -391,10 +397,10 @@ cmd_commit() {
29 }' | xargs rm 2>/dev/null
30
31 # remove obsolete file. some older version of alpine needs this
32- # to be ble to upgrade
33+ # to be able to upgrade
34 if [ -z "$DRYRUN" ] && [ -f $mnt/packages.list ]; then
35 echo "Note: Removing packages.list from $(basename $mnt)."
36- echo " $PACKAGES_LIST will be used."
37+ echo " /var/lib/apk/world will be used."
38 rm -f $mnt/packages.list
39 fi
40
41--
421.6.3.3
43
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 08e641d02b..46d5b9824c 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,16 +1,18 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-conf 2pkgname=alpine-conf
3pkgver=2.0_beta3 3pkgver=2.0_beta3
4pkgrel=0 4pkgrel=1
5pkgdesc="Alpine configuration management scripts" 5pkgdesc="Alpine configuration management scripts"
6url=http://git.alpinelinux.org/cgit/$pkgname 6url=http://git.alpinelinux.org/cgit/$pkgname
7depends="openrc" 7depends="openrc"
8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
9 0001-lbu-remove-packages.list-if-exist.patch
9 " 10 "
10license="GPL-2" 11license="GPL-2"
11 12
12build() { 13build() {
13 cd "$srcdir/$pkgname-$pkgver" 14 cd "$srcdir/$pkgname-$pkgver"
15 patch -p1 -i ../0001-lbu-remove-packages.list-if-exist.patch || return 1
14 16
15 make || return 1 17 make || return 1
16 make install PREFIX= DESTDIR="$pkgdir" 18 make install PREFIX= DESTDIR="$pkgdir"
@@ -18,4 +20,5 @@ build() {
18 ln -s lbu "$pkgdir"/sbin/lbu_$i 20 ln -s lbu "$pkgdir"/sbin/lbu_$i
19 done 21 done
20} 22}
21md5sums="7786d6d526e96a3fdf51b9284d063caa alpine-conf-2.0_beta3.tar.bz2" 23md5sums="7786d6d526e96a3fdf51b9284d063caa alpine-conf-2.0_beta3.tar.bz2
24b09f9702fc6599fcb7d9bfbc855c8b5c 0001-lbu-remove-packages.list-if-exist.patch"