aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-09 23:21:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-10-10 05:55:13 +0000
commit0a7f97f20dac33b48ab36f8ff3292ebebc263220 (patch)
treeb3fe808f5e1f19c6e5f6022c2352ef3b9a338fcc
parentdf639a21ecd4bf7cbb18267373be055f9c06dae6 (diff)
downloadalpine_aports-0a7f97f20dac33b48ab36f8ff3292ebebc263220.tar.bz2
alpine_aports-0a7f97f20dac33b48ab36f8ff3292ebebc263220.tar.xz
alpine_aports-0a7f97f20dac33b48ab36f8ff3292ebebc263220.zip
testing/s3fs-fuse: upgrade to 1.87
-rw-r--r--testing/s3fs-fuse/APKBUILD9
-rw-r--r--testing/s3fs-fuse/define-SEEK.patch22
2 files changed, 28 insertions, 3 deletions
diff --git a/testing/s3fs-fuse/APKBUILD b/testing/s3fs-fuse/APKBUILD
index 03138c781f..f268446772 100644
--- a/testing/s3fs-fuse/APKBUILD
+++ b/testing/s3fs-fuse/APKBUILD
@@ -1,7 +1,7 @@
1# Contributor: Steeve Chailloux <steeve.chailloux@orus.io> 1# Contributor: Steeve Chailloux <steeve.chailloux@orus.io>
2# Maintainer: Steeve Chailloux <steeve.chailloux@orus.io> 2# Maintainer: Steeve Chailloux <steeve.chailloux@orus.io>
3pkgname=s3fs-fuse 3pkgname=s3fs-fuse
4pkgver=1.86 4pkgver=1.87
5pkgrel=0 5pkgrel=0
6pkgdesc="FUSE-based file system backed by Amazon S3" 6pkgdesc="FUSE-based file system backed by Amazon S3"
7options="!check" # Fails to connect to localhost 7options="!check" # Fails to connect to localhost
@@ -12,7 +12,9 @@ depends="fuse"
12makedepends="automake autoconf libxml2-dev fuse-dev curl-dev git bash" 12makedepends="automake autoconf libxml2-dev fuse-dev curl-dev git bash"
13checkdepends="coreutils sed" 13checkdepends="coreutils sed"
14subpackages="$pkgname-doc" 14subpackages="$pkgname-doc"
15source="$pkgname-$pkgver.tar.gz::https://github.com/s3fs-fuse/s3fs-fuse/archive/v$pkgver.tar.gz" 15source="$pkgname-$pkgver.tar.gz::https://github.com/s3fs-fuse/s3fs-fuse/archive/v$pkgver.tar.gz
16 define-SEEK.patch
17 "
16 18
17prepare() { 19prepare() {
18 default_prepare 20 default_prepare
@@ -38,4 +40,5 @@ package() {
38 make DESTDIR="$pkgdir" install 40 make DESTDIR="$pkgdir" install
39} 41}
40 42
41sha512sums="a4f79d9ae526427d5d41b5cd1519e4aac605e8bbd97079aec2a67562f0322fa5664d770d565aed4fca83ae254ab3c0454d25f4b86ec4d148a57c7745e07f5e14 s3fs-fuse-1.86.tar.gz" 43sha512sums="654e96f080423b79403f31380157d3410f4f253648e6f024c271e3b48ec814c3373caf375ea6365e47f36b62cf602c9de1ab75b8e24d99dd37b19c158b12e5e1 s3fs-fuse-1.87.tar.gz
4431db7e7f31da53bb56a8cf51e246aef838e520375a39ae4517fe6af5a5a5fc3c092f6df63e9bfa59f3231a51dc1521aa2ae0881f9421da8324c1cd46a519b6f1 define-SEEK.patch"
diff --git a/testing/s3fs-fuse/define-SEEK.patch b/testing/s3fs-fuse/define-SEEK.patch
new file mode 100644
index 0000000000..4cd975ee68
--- /dev/null
+++ b/testing/s3fs-fuse/define-SEEK.patch
@@ -0,0 +1,22 @@
1Upstream: Not applicable
2Reason: Fixes compilation with musl
3
4diff --git a/src/fdcache.cpp b/src/fdcache.cpp
5index 6416b01..30e5a50 100644
6--- a/src/fdcache.cpp
7+++ b/src/fdcache.cpp
8@@ -47,6 +47,14 @@
9 #include "curl.h"
10 #include "fdcache.h"
11
12+// Taken from toybox portability
13+// Introduced in Linux 3.1
14+#ifndef SEEK_DATA
15+#define SEEK_DATA 3
16+#endif
17+#ifndef SEEK_HOLE
18+#define SEEK_HOLE 4
19+#endif
20 using namespace std;
21
22 //------------------------------------------------