aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-05-23 20:10:16 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2020-05-28 15:06:54 +0000
commit11e9491c7c804e82dc45dff606db647a51cc4e0b (patch)
tree1e963c421d153ef672cf940ac5ef8279ac231a63
parent8f7cf916fc0895b6d8061ded0ba65673f06764f4 (diff)
downloadalpine_aports-11e9491c7c804e82dc45dff606db647a51cc4e0b.tar.bz2
alpine_aports-11e9491c7c804e82dc45dff606db647a51cc4e0b.tar.xz
alpine_aports-11e9491c7c804e82dc45dff606db647a51cc4e0b.zip
testing/shfmt: enable tests
-rw-r--r--testing/shfmt/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/testing/shfmt/APKBUILD b/testing/shfmt/APKBUILD
index a7e7eb8543..9da2399464 100644
--- a/testing/shfmt/APKBUILD
+++ b/testing/shfmt/APKBUILD
@@ -7,7 +7,6 @@ pkgdesc="A shell parser, formatter, and interpreter (sh/bash/mksh)"
7url="https://mvdan.cc/sh" 7url="https://mvdan.cc/sh"
8arch="all" 8arch="all"
9license="BSD-3-Clause" 9license="BSD-3-Clause"
10options="!check" # no test suite
11makedepends="go" 10makedepends="go"
12source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz" 11source="$pkgname-$pkgver.tar.gz::https://github.com/mvdan/sh/archive/v$pkgver.tar.gz"
13builddir="$srcdir/sh-$pkgver" 12builddir="$srcdir/sh-$pkgver"
@@ -19,6 +18,10 @@ build() {
19 ./cmd/shfmt 18 ./cmd/shfmt
20} 19}
21 20
21check() {
22 go test ./...
23}
24
22package() { 25package() {
23 install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt 26 install -Dm755 shfmt "$pkgdir"/usr/bin/shfmt
24} 27}