aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-16 13:34:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-16 13:34:48 +0000
commit36b1667c368adbc7cb916e6853fe273ac5212422 (patch)
tree768433875a239b03adf4a38cdeaeae7d2f013326
parentfab2ac478af6b2d39a6dfcff3caa2e346f3f82a4 (diff)
downloadalpine_aports-36b1667c368adbc7cb916e6853fe273ac5212422.tar.bz2
alpine_aports-36b1667c368adbc7cb916e6853fe273ac5212422.tar.xz
alpine_aports-36b1667c368adbc7cb916e6853fe273ac5212422.zip
testing/sshfs: new aport
FUSE client based on the SSH File Transfer Protocol http://fuse.sourceforge.net/sshfs.html ref #210
-rw-r--r--testing/sshfs/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/sshfs/APKBUILD b/testing/sshfs/APKBUILD
new file mode 100644
index 0000000000..f911831236
--- /dev/null
+++ b/testing/sshfs/APKBUILD
@@ -0,0 +1,25 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=sshfs
3pkgver=2.2
4pkgrel=0
5pkgdesc="FUSE client based on the SSH File Transfer Protocol"
6url="http://fuse.sourceforge.net/sshfs.html"
7license="GPL"
8depends="openssh-client"
9makedepends="pkgconfig fuse-dev glib-dev"
10source="http://downloads.sourceforge.net/sourceforge/fuse/sshfs-fuse-$pkgver.tar.gz"
11
12_builddir="$srcdir"/sshfs-fuse-$pkgver
13build ()
14{
15 cd "$_builddir"
16 ./configure --prefix=/usr
17 make || return 1
18}
19
20package() {
21 cd "$_builddir"
22 make DESTDIR="$pkgdir" install || return 1
23}
24
25md5sums="26e9206eb5169e87e6f95f54bc005a4f sshfs-fuse-2.2.tar.gz"