aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2020-10-10 21:09:36 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-11 18:55:29 +0000
commit3c2ea94e1233e388aa92f48655d59eac5adfd1d1 (patch)
tree3bd60a16440037a9fa7acb5459fa236ac01fb6c5
parent0473bf344912e1b0751cfefff4782450d34a5ba1 (diff)
downloadalpine_aports-3c2ea94e1233e388aa92f48655d59eac5adfd1d1.tar.bz2
alpine_aports-3c2ea94e1233e388aa92f48655d59eac5adfd1d1.tar.xz
alpine_aports-3c2ea94e1233e388aa92f48655d59eac5adfd1d1.zip
community/firefox-esr: sort options
-rw-r--r--community/firefox-esr/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index b91d5936d8..3b4cba2144 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -288,53 +288,56 @@ build() {
288 _rust_simd="--disable-rust-simd" 288 _rust_simd="--disable-rust-simd"
289 _low_mem_flags="--disable-debug-symbols --disable-debug" 289 _low_mem_flags="--disable-debug-symbols --disable-debug"
290 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0" 290 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
291 ;; 291 ;;
292 x86) 292 x86)
293 _low_mem_flags="--disable-debug-symbols --disable-debug" 293 _low_mem_flags="--disable-debug-symbols --disable-debug"
294 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0" 294 export RUSTFLAGS="$RUSTFLAGS -C debuginfo=0"
295 ;; 295 ;;
296 *) _rust_simd="--enable-rust-simd" ;; 296 *) _rust_simd="--enable-rust-simd" ;;
297 esac 297 esac
298 298
299 ../configure \ 299 ../configure \
300 --prefix=/usr \ 300 --prefix=/usr \
301 $_arch_config \ 301 $_arch_config \
302 $_low_mem_flags \
303 $_rust_simd \
304 \
302 --disable-crashreporter \ 305 --disable-crashreporter \
303 --disable-gold \ 306 --disable-gold \
304 --disable-install-strip \ 307 --disable-install-strip \
305 --disable-jemalloc \ 308 --disable-jemalloc \
306 --disable-profiling \ 309 --disable-profiling \
307 --disable-pulseaudio \ 310 --disable-pulseaudio \
308 --enable-dbus \
309 --enable-necko-wifi \
310 --disable-strip \ 311 --disable-strip \
311 --disable-tests \ 312 --disable-tests \
312 --disable-updater \ 313 --disable-updater \
314 \
313 --enable-alsa \ 315 --enable-alsa \
316 --enable-cdp \
317 --enable-dbus \
314 --enable-default-toolkit=cairo-gtk3-wayland \ 318 --enable-default-toolkit=cairo-gtk3-wayland \
319 --enable-ffmpeg \
320 --enable-hardening \
321 --enable-necko-wifi \
315 --enable-official-branding \ 322 --enable-official-branding \
316 --enable-optimize="$CFLAGS -O2" \ 323 --enable-optimize="$CFLAGS -O2" \
317 --enable-system-ffi \
318 --enable-ffmpeg \
319 --enable-smoosh \ 324 --enable-smoosh \
320 $_rust_simd \ 325 --enable-system-ffi \
321 $_low_mem_flags \
322 --enable-hardening \
323 --enable-system-pixman \ 326 --enable-system-pixman \
327 \
324 --with-system-ffi \ 328 --with-system-ffi \
325 --with-system-icu \ 329 --with-system-icu \
330 --with-system-jpeg \
326 --with-system-libevent \ 331 --with-system-libevent \
332 --with-system-libvpx \
327 --with-system-nspr \ 333 --with-system-nspr \
328 --with-system-nss \ 334 --with-system-nss \
329 --with-system-pixman \ 335 --with-system-pixman \
330 --with-system-png \ 336 --with-system-png \
331 --with-system-zlib \
332 --with-system-libvpx \
333 --with-system-webp \ 337 --with-system-webp \
334 --with-system-jpeg \ 338 --with-system-zlib \
335 --with-clang-path=/usr/bin/clang \ 339 --with-clang-path=/usr/bin/clang \
336 --with-libclang-path=/usr/lib \ 340 --with-libclang-path=/usr/lib
337 --enable-cdp
338 make 341 make
339} 342}
340 343