aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-07 13:14:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-07 13:17:10 +0000
commit3f32504885104e22136d768852e72173e38158b9 (patch)
tree21bd395fd611f2f97230b230b84043c6c17be0c1
parentfda7515b207dc57226071816cb80ab886d7699a3 (diff)
downloadalpine_aports-3f32504885104e22136d768852e72173e38158b9.tar.bz2
alpine_aports-3f32504885104e22136d768852e72173e38158b9.tar.xz
alpine_aports-3f32504885104e22136d768852e72173e38158b9.zip
main/mkinitfs: make sure patches are applied and add virtio support
- fix / beeing world writeable when tmpfs - include virtio driver support fixes #518
-rw-r--r--main/mkinitfs/0001-included-virtio-kernel-modules.patch25
-rw-r--r--main/mkinitfs/APKBUILD23
2 files changed, 41 insertions, 7 deletions
diff --git a/main/mkinitfs/0001-included-virtio-kernel-modules.patch b/main/mkinitfs/0001-included-virtio-kernel-modules.patch
new file mode 100644
index 0000000000..daf42d41ae
--- /dev/null
+++ b/main/mkinitfs/0001-included-virtio-kernel-modules.patch
@@ -0,0 +1,25 @@
1From a9940ddcba6f77f9a7b2fdaa1c3f921899cb0b1c Mon Sep 17 00:00:00 2001
2From: Natanael Copa <ncopa@alpinelinux.org>
3Date: Mon, 7 Mar 2011 13:06:54 +0000
4Subject: [PATCH] included virtio kernel modules
5
6see http://redmine.alpinelinux.org/issues/518
7---
8 Makefile | 1 +
9 1 files changed, 1 insertions(+), 0 deletions(-)
10
11diff --git a/Makefile b/Makefile
12index 6389d04..31916d9 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -26,6 +26,7 @@ CONF_FILES := mkinitfs.conf \
16 modules.d/scsi \
17 modules.d/ubifs \
18 modules.d/usb \
19+ modules.d/virtio \
20 modules.d/xfs \
21 files.d/bootchart \
22 files.d/base \
23--
241.7.4.1
25
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index 38a2821bf7..840e88aa84 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,25 +1,33 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=mkinitfs 2pkgname=mkinitfs
3pkgver=2.1.2 3pkgver=2.1.2
4pkgrel=1 4pkgrel=2
5pkgdesc="Tool to generate initramfs images for Alpine" 5pkgdesc="Tool to generate initramfs images for Alpine"
6url=http://git.alpinelinux.org/cgit/mkinitfs 6url=http://git.alpinelinux.org/cgit/mkinitfs
7depends="busybox apk-tools>=2.0" 7depends="busybox apk-tools>=2.0"
8triggers="$pkgname.trigger:/usr/share/kernel/*" 8triggers="$pkgname.trigger:/usr/share/kernel/*"
9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2 9source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
10 0001-init-make-readonly-for-world-when-tmpfs.patch 10 0001-init-make-readonly-for-world-when-tmpfs.patch
11 0001-included-virtio-kernel-modules.patch
11 eglibc.patch 12 eglibc.patch
12 " 13 "
13license="GPL-2" 14license="GPL-2"
14 15
15prepare() { 16prepare() {
16 cd "$srcdir"/$pkgname-$pkgver 17 cd "$srcdir"/$pkgname-$pkgver
17 18 for i in $source; do
18 # If we are using eglibc we need to include eglibc libs 19 case $i in
19 # instead of uclibc libs. 20 eglibc.patch)
20 if [ "$ALPINE_LIBC" = "eglibc" ]; then 21 # If we are using eglibc we need to include eglibc libs
21 patch -p1 -i "$srcdir"/eglibc.patch || return 1 22 # instead of uclibc libs.
22 fi 23 if [ "$ALPINE_LIBC" = "eglibc" ]; then
24 patch -p1 -i "$srcdir"/eglibc.patch || return 1
25 fi
26 ;;
27 *.patch)
28 msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
29 esac
30 done
23} 31}
24 32
25build() { 33build() {
@@ -33,4 +41,5 @@ package() {
33} 41}
34md5sums="e35426eb23b379a648500a353031e719 mkinitfs-2.1.2.tar.bz2 42md5sums="e35426eb23b379a648500a353031e719 mkinitfs-2.1.2.tar.bz2
35e38e2f5c2b22b2789b5bc03aacba4d2d 0001-init-make-readonly-for-world-when-tmpfs.patch 43e38e2f5c2b22b2789b5bc03aacba4d2d 0001-init-make-readonly-for-world-when-tmpfs.patch
4415f6a307d607272d61f5a9c86aa0d2e5 0001-included-virtio-kernel-modules.patch
36e59c2f7de496fe430b07e32fd812ebe0 eglibc.patch" 45e59c2f7de496fe430b07e32fd812ebe0 eglibc.patch"