aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-01 14:46:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-01 14:47:08 +0000
commit4729520c135dee23678c115b1db43361534794e3 (patch)
tree01e2f938d7ccba0b90c71c977ad7375501215c8d
parentd36e402fae2b31ca2bf6eafbafa77d716ea99b15 (diff)
downloadalpine_aports-4729520c135dee23678c115b1db43361534794e3.tar.bz2
alpine_aports-4729520c135dee23678c115b1db43361534794e3.tar.xz
alpine_aports-4729520c135dee23678c115b1db43361534794e3.zip
main/vlc: remove dlclose workaround
It appears to have been fixed in uclibc
-rw-r--r--main/vlc/APKBUILD15
-rw-r--r--main/vlc/vlc-1.1.7-disable-cache-gen.patch12
-rw-r--r--main/vlc/vlc-dlclose-workaround.patch20
3 files changed, 1 insertions, 46 deletions
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index 7ba7a19de3..94f4ac34a8 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -3,7 +3,7 @@
3pkgname=vlc 3pkgname=vlc
4pkgver=2.0.4 4pkgver=2.0.4
5_pkgver=${pkgver/_/-} 5_pkgver=${pkgver/_/-}
6pkgrel=0 6pkgrel=1
7pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player" 7pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
8pkgusers="vlc" 8pkgusers="vlc"
9pkggroups="vlc" 9pkggroups="vlc"
@@ -13,9 +13,6 @@ license="GPL-2"
13triggers="$pkgname.trigger=/usr/lib/vlc/plugins" 13triggers="$pkgname.trigger=/usr/lib/vlc/plugins"
14subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-xorg 14subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-xorg
15 $pkgname-daemon" 15 $pkgname-daemon"
16#depends="fluidsynth zvbi lirc-utils libdca
17# libproxy libcddb smbclient
18# libmpcdec libmodplug"
19depends="ttf-dejavu" 16depends="ttf-dejavu"
20makedepends=" 17makedepends="
21 a52dec-dev 18 a52dec-dev
@@ -74,11 +71,8 @@ source="http://download.videolan.org/pub/videolan/$pkgname/$_pkgver/$pkgname-$_p
74 uclibc-inhibit-spawn.patch 71 uclibc-inhibit-spawn.patch
75 uclibc-no-xscreensaver.patch 72 uclibc-no-xscreensaver.patch
76 uclibc3.patch 73 uclibc3.patch
77 vlc-dlclose-workaround.patch
78 vlc.trigger 74 vlc.trigger
79 " 75 "
80# uclibc-libcompat.patch
81# vlc-1.1.7-disable-cache-gen.patch
82 76
83_builddir="$srcdir"/$pkgname-$_pkgver 77_builddir="$srcdir"/$pkgname-$_pkgver
84prepare() { 78prepare() {
@@ -145,12 +139,6 @@ build ()
145 --enable-xvideo \ 139 --enable-xvideo \
146 || return 1 140 || return 1
147 141
148# --enable-dvb \
149# --enable-snapshot \
150# --enable-hal \
151# --enable-lirc \
152# --enable-pvr \
153
154 make || return 1 142 make || return 1
155} 143}
156 144
@@ -235,5 +223,4 @@ md5sums="f36dab8f126922c56b372388b7fade47 vlc-2.0.4.tar.xz
23528349b8239fdd6987fbe0ca2c758517f uclibc-inhibit-spawn.patch 22328349b8239fdd6987fbe0ca2c758517f uclibc-inhibit-spawn.patch
236b84c5a9121440b6a1dcf28792d783eb8 uclibc-no-xscreensaver.patch 224b84c5a9121440b6a1dcf28792d783eb8 uclibc-no-xscreensaver.patch
23794f11ec8394775018222781a0c875444 uclibc3.patch 22594f11ec8394775018222781a0c875444 uclibc3.patch
2385aa45c7966b915801a0e449f56b6c454 vlc-dlclose-workaround.patch
239350b30698eb784def7d19446eb1d6c81 vlc.trigger" 226350b30698eb784def7d19446eb1d6c81 vlc.trigger"
diff --git a/main/vlc/vlc-1.1.7-disable-cache-gen.patch b/main/vlc/vlc-1.1.7-disable-cache-gen.patch
deleted file mode 100644
index b8a3dd9551..0000000000
--- a/main/vlc/vlc-1.1.7-disable-cache-gen.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1--- a/modules/Makefile.am
2+++ b/modules/Makefile.am
3@@ -63,7 +63,8 @@
4
5 stamp-cache:
6 $(AM_V_GEN)if test "$(build)" = "$(host)"; then \
7- ../bin/vlc-cache-gen$(EXEEXT) . ; \
8+ # ../bin/vlc-cache-gen$(EXEEXT) . ; \
9+ echo "FIXME: vlc-cache-gen" ; \
10 else \
11 echo "Cross-compilation: cache generation skipped!" ; \
12 fi
diff --git a/main/vlc/vlc-dlclose-workaround.patch b/main/vlc/vlc-dlclose-workaround.patch
deleted file mode 100644
index 44001c8c84..0000000000
--- a/main/vlc/vlc-dlclose-workaround.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1We have an issue with dlclose on uclibc on x86_64.
2For now we work around it by simply not dlcose our plugins.
3
4
5--- ./src/modules/bank.c.orig
6+++ ./src/modules/bank.c
7@@ -484,11 +484,13 @@
8 assert (module->next == NULL);
9
10 /* Unload plugin until we really need it */
11+#if 0
12 if (module->b_loaded && module->b_unloadable)
13 {
14 module_Unload (module->handle);
15 module->b_loaded = false;
16 }
17+#endif
18
19 /* For now we force loading if the module's config contains
20 * callbacks or actions.