aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-17 06:52:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-23 08:17:43 +0000
commit516e3e24f6463a9674c3e6948996f517d396d083 (patch)
treed9b4a8f661b0ee387ee9ac8ae7da1b0ead0cd360
parent5ca3bbde6d1460508455d1b0fe293c29262cb155 (diff)
downloadalpine_aports-516e3e24f6463a9674c3e6948996f517d396d083.tar.bz2
alpine_aports-516e3e24f6463a9674c3e6948996f517d396d083.tar.xz
alpine_aports-516e3e24f6463a9674c3e6948996f517d396d083.zip
main/libc0.9.32: disable debugging symbols
(cherry picked from commit 863d7fd7cd6a72171014520a04ab41774b9eb055)
-rw-r--r--main/libc0.9.32/APKBUILD10
-rw-r--r--main/libc0.9.32/uclibcconfig.x864
2 files changed, 6 insertions, 8 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 83d89a5b7f..12a01fa134 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
3pkgname=libc$_abiver 3pkgname=libc$_abiver
4_gitver=1009151331 4_gitver=1009151331
5pkgver=${_abiver}_alpha0_git$_gitver 5pkgver=${_abiver}_alpha0_git$_gitver
6pkgrel=0 6pkgrel=1
7pkgdesc="C library for developing embedded Linux systems" 7pkgdesc="C library for developing embedded Linux systems"
8url=http://uclibc.org 8url=http://uclibc.org
9license="LGPL-2" 9license="LGPL-2"
@@ -12,12 +12,10 @@ subpackages="uclibc-dev:dev uclibc-utils:utils"
12depends_dev="linux-headers=>2.6.32" 12depends_dev="linux-headers=>2.6.32"
13replaces=uclibc 13replaces=uclibc
14 14
15DEBUG=y
16if [ -n "$DEBUG" ]; then 15if [ -n "$DEBUG" ]; then
17 options="!strip" 16 options="!strip"
18fi 17fi
19 18
20
21_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2" 19_snapurl="http://git.uclibc.org/uClibc/snapshot/master.tar.bz2"
22_snapfile="$pkgname-$pkgver.tar.bz2" 20_snapfile="$pkgname-$pkgver.tar.bz2"
23source="http://build.alpinelinux.org:8010/distfiles/$_snapfile 21source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
@@ -82,7 +80,7 @@ build() {
82 fi 80 fi
83 cp "$_config" .config 81 cp "$_config" .config
84 if [ -n "$DEBUG" ]; then 82 if [ -n "$DEBUG" ]; then
85 sed -i -e 's/# DODEBUG is not set/DODEBUG=y' \ 83 sed -i -e 's/# DODEBUG is not set/DODEBUG=y/' \
86 -e 's/DOSTRIP=y/# DOSTRIP is not set/' \ 84 -e 's/DOSTRIP=y/# DOSTRIP is not set/' \
87 .config 85 .config
88 fi 86 fi
@@ -124,5 +122,5 @@ md5sums="966c830f294a8ab5069cc03a61e1b2ed libc0.9.32-0.9.32_alpha0_git100915133
124ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch 122ba6e0370d1fc19e5903696de412507ef 0001-config-parser-do-not-assume-that-realloc-return-same.patch
12519d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch 12319d923997f9625ce6f16d8128bbcba65 0002-getservice-getservent_r-must-return-ERANGE-when-buff.patch
12699b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch 12499b817778f4ef3a1b194740ea08990b4 0003-config-parser-always-initialize-line-pointer.patch
1272ca97ab4b49f920247f335184bb02c1c uclibcconfig.x86 125cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.x86
1282ca97ab4b49f920247f335184bb02c1c uclibcconfig.i486" 126cffecb42bdec2da7cac718fa66cacbbe uclibcconfig.i486"
diff --git a/main/libc0.9.32/uclibcconfig.x86 b/main/libc0.9.32/uclibcconfig.x86
index 3baabc7718..977f023b42 100644
--- a/main/libc0.9.32/uclibcconfig.x86
+++ b/main/libc0.9.32/uclibcconfig.x86
@@ -250,8 +250,8 @@ UCLIBC_BUILD_NOEXECSTACK=y
250# 250#
251CROSS_COMPILER_PREFIX="" 251CROSS_COMPILER_PREFIX=""
252UCLIBC_EXTRA_CFLAGS="" 252UCLIBC_EXTRA_CFLAGS=""
253DODEBUG=y 253# DODEBUG is not set
254# DOSTRIP is not set 254DOSTRIP=y
255# DOASSERTS is not set 255# DOASSERTS is not set
256# SUPPORT_LD_DEBUG is not set 256# SUPPORT_LD_DEBUG is not set
257# SUPPORT_LD_DEBUG_EARLY is not set 257# SUPPORT_LD_DEBUG_EARLY is not set