aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-10-09 12:36:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-10-12 07:53:30 +0000
commit574be7070a489a2c5268baa0191d8f2d6bac0618 (patch)
treef0500e80e62ec23d658f620f5703cfade77074b4
parent94ccade6ac3fc834d916212bbe9bda53058ad72d (diff)
downloadalpine_aports-574be7070a489a2c5268baa0191d8f2d6bac0618.tar.bz2
alpine_aports-574be7070a489a2c5268baa0191d8f2d6bac0618.tar.xz
alpine_aports-574be7070a489a2c5268baa0191d8f2d6bac0618.zip
main/linux-firmware: upgrade to 20200918
use source from upstream tarballs instead of 'git clone' and build tarball locally and upload it to dev.alpinelinux.org upstream started to make (about) monthly releases in tarballs from 2019-03-12 remove snapshot(), not needed now remove not needed variables clean-up little
-rw-r--r--main/linux-firmware/APKBUILD30
1 files changed, 5 insertions, 25 deletions
diff --git a/main/linux-firmware/APKBUILD b/main/linux-firmware/APKBUILD
index 963734834d..4485ec7ff7 100644
--- a/main/linux-firmware/APKBUILD
+++ b/main/linux-firmware/APKBUILD
@@ -1,15 +1,14 @@
1# Contributor: Oliver Smith <ollieparanoid@postmarketos.org> 1# Contributor: Oliver Smith <ollieparanoid@postmarketos.org>
2# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 2# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
3pkgname=linux-firmware 3pkgname=linux-firmware
4pkgver=20200519 4pkgver=20200918
5pkgrel=2 5pkgrel=0
6pkgdesc="firmware files for linux" 6pkgdesc="firmware files for linux"
7#url="https://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=summary" 7#url="https://git.kernel.org/?p=linux/kernel/git/dwmw2/linux-firmware.git;a=summary"
8url="http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary" 8url="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=summary"
9arch="all" 9arch="all"
10license="custom:multiple" 10license="custom:multiple"
11makedepends="libarchive-tools" 11makedepends="libarchive-tools"
12install=""
13provides="linux-firmware-any" 12provides="linux-firmware-any"
14provider_priority=1 13provider_priority=1
15options="!strip !check !archcheck !tracedeps !spdx" 14options="!strip !check !archcheck !tracedeps !spdx"
@@ -17,15 +16,12 @@ options="!strip !check !archcheck !tracedeps !spdx"
17_rpi_bt=fff76cb15527c435ce99a9787848eacd6288282c 16_rpi_bt=fff76cb15527c435ce99a9787848eacd6288282c
18 17
19# cypress fmac: https://community.cypress.com/docs/DOC-19375 18# cypress fmac: https://community.cypress.com/docs/DOC-19375
20source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-${pkgver}.tar.gz 19source="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-$pkgver.tar.gz
21 https://community.cypress.com/servlet/JiveServlet/download/19375-1-53475/cypress-fmac-v5.4.18-2020_0402.zip 20 https://community.cypress.com/servlet/JiveServlet/download/19375-1-53475/cypress-fmac-v5.4.18-2020_0402.zip
22 BCM43430A1.hcd.${_rpi_bt::8}::https://github.com/RPi-Distro/bluez-firmware/raw/$_rpi_bt/broadcom/BCM43430A1.hcd 21 BCM43430A1.hcd.${_rpi_bt::8}::https://github.com/RPi-Distro/bluez-firmware/raw/$_rpi_bt/broadcom/BCM43430A1.hcd
23 BCM4345C0.hcd.${_rpi_bt::8}::https://github.com/RPi-Distro/bluez-firmware/raw/$_rpi_bt/broadcom/BCM4345C0.hcd 22 BCM4345C0.hcd.${_rpi_bt::8}::https://github.com/RPi-Distro/bluez-firmware/raw/$_rpi_bt/broadcom/BCM4345C0.hcd
24 " 23 "
25 24
26_giturl="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git"
27_upload=dev.alpinelinux.org:/archive/$pkgname/
28
29_builddir="$srcdir"/$pkgname-$pkgver 25_builddir="$srcdir"/$pkgname-$pkgver
30 26
31# Put /lib/firmware/* folders in subpackages 27# Put /lib/firmware/* folders in subpackages
@@ -46,22 +42,6 @@ for i in $_folders; do
46done 42done
47subpackages="amd-ucode::noarch $subpackages" 43subpackages="amd-ucode::noarch $subpackages"
48 44
49snapshot() {
50 local _date=$(date +%Y%m%d)
51 local _pkg=$pkgname-$_date.tar.gz
52 mkdir -p "$srcdir"
53 cd "$srcdir"
54 rm -rf "$pkgname"
55 git clone --depth=1 --bare $_giturl
56 git --git-dir ${_giturl##*/} archive -o $_pkg \
57 --prefix=$pkgname-$_date/ HEAD
58 msg "New snapshot: $_pkg"
59 if [ -n "$_upload" ]; then
60 msg "Uploading to $_upload"
61 scp $_pkg $_upload && abump $pkgname-$_date
62 fi
63}
64
65package() { 45package() {
66 cd "${_builddir}" 46 cd "${_builddir}"
67 make DESTDIR="${pkgdir}" FIRMWAREDIR="/lib/firmware" install 47 make DESTDIR="${pkgdir}" FIRMWAREDIR="/lib/firmware" install
@@ -160,7 +140,7 @@ ucode() {
160 bsdtar --null -cf - --format=newc @- > "$subpkgdir"/boot/amd-ucode.img 140 bsdtar --null -cf - --format=newc @- > "$subpkgdir"/boot/amd-ucode.img
161} 141}
162 142
163sha512sums="9724cf3d1aea73f264d53564ef160a62e90bb35766f3300bbbeaf7c7c6a356ef50c7d17bfa01197e8e991ff72b1aeef002bb78f5dc78243b2792cafbf1139dff linux-firmware-20200519.tar.gz 143sha512sums="1e2972eaa9d6a116de08d0aa41f4660ef2cc0d1499ce413fd0f41290391519e677519c27113103a5844a862fbab1e9e39f817f9336d2fb228ebad2d5cd1ce0ed linux-firmware-20200918.tar.gz
164d3d976799f43b3b344305959b10d220709f6881cec102dfe391347869748f76d517d1b0d31076e2baa9759cb6a622eb5fc6f4fe45d6d3151974725e254255afa cypress-fmac-v5.4.18-2020_0402.zip 144d3d976799f43b3b344305959b10d220709f6881cec102dfe391347869748f76d517d1b0d31076e2baa9759cb6a622eb5fc6f4fe45d6d3151974725e254255afa cypress-fmac-v5.4.18-2020_0402.zip
165a7b37bce092367125e390017bb0329c3b7f8fa891cf30d422ee73ce53d0592d4ff0fc2e2a94a87eefb641d5dd8631fae1cc46664224dea987ca04b68a8af8519 BCM43430A1.hcd.fff76cb1 145a7b37bce092367125e390017bb0329c3b7f8fa891cf30d422ee73ce53d0592d4ff0fc2e2a94a87eefb641d5dd8631fae1cc46664224dea987ca04b68a8af8519 BCM43430A1.hcd.fff76cb1
166a52fdb876131affa85b39434d619580c0e1605094992ffa3bb321af387dd79739736842dea9ffa759e6658aecde40eda6b06d93dbb58234a4b126b756c28521e BCM4345C0.hcd.fff76cb1" 146a52fdb876131affa85b39434d619580c0e1605094992ffa3bb321af387dd79739736842dea9ffa759e6658aecde40eda6b06d93dbb58234a4b126b756c28521e BCM4345C0.hcd.fff76cb1"