aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-20 09:05:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-20 09:05:09 +0000
commit580b429561e3371e429e75c0d5aaea187c907ce4 (patch)
tree59e39125c6672361658c5faeb7a3dff029de6996
parentcbeb37ad9bde2f4f54c990a8f446db0517079c7f (diff)
downloadalpine_aports-580b429561e3371e429e75c0d5aaea187c907ce4.tar.bz2
alpine_aports-580b429561e3371e429e75c0d5aaea187c907ce4.tar.xz
alpine_aports-580b429561e3371e429e75c0d5aaea187c907ce4.zip
main/alpine-conf: add fix for setup-acf
fixes #386
-rw-r--r--main/alpine-conf/APKBUILD16
-rw-r--r--main/alpine-conf/setup-acf.patch21
2 files changed, 34 insertions, 3 deletions
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 64333a38c4..bab4a16c64 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,16 +1,25 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=alpine-conf 2pkgname=alpine-conf
3pkgver=2.4 3pkgver=2.4
4pkgrel=0 4pkgrel=1
5pkgdesc="Alpine configuration management scripts" 5pkgdesc="Alpine configuration management scripts"
6url=http://git.alpinelinux.org/cgit/$pkgname 6url=http://git.alpinelinux.org/cgit/$pkgname
7depends="openrc" 7depends="openrc"
8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2" 8source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
9 setup-acf.patch"
9license="GPL-2" 10license="GPL-2"
10 11
11_builddir="$srcdir"/$pkgname-$pkgver 12_builddir="$srcdir"/$pkgname-$pkgver
12prepare() { 13prepare() {
13 cd "$_builddir" 14 cd "$_builddir"
15 for i in $source; do
16 case $i in
17 *.patch)
18 msg "Applying $i"
19 patch -p1 -i "$srcdir"/$i || return 1
20 ;;
21 esac
22 done
14} 23}
15 24
16build() { 25build() {
@@ -25,4 +34,5 @@ package() {
25 ln -s lbu "$pkgdir"/sbin/lbu_$i 34 ln -s lbu "$pkgdir"/sbin/lbu_$i
26 done 35 done
27} 36}
28md5sums="4c8db8948a21b0435f577d1e0f8d7c8e alpine-conf-2.4.tar.bz2" 37md5sums="4c8db8948a21b0435f577d1e0f8d7c8e alpine-conf-2.4.tar.bz2
38882e555ab6f319846930f933d7fe0dd0 setup-acf.patch"
diff --git a/main/alpine-conf/setup-acf.patch b/main/alpine-conf/setup-acf.patch
new file mode 100644
index 0000000000..d317adb383
--- /dev/null
+++ b/main/alpine-conf/setup-acf.patch
@@ -0,0 +1,21 @@
1commit cd1dc75d09e5ac8f5e55100e5b9099c85a91db7f
2Author: Natanael Copa <ncopa@alpinelinux.org>
3Date: Tue Jul 20 09:02:05 2010 +0000
4
5 setup-acf: install openssl
6
7 so we can generate the certificate
8
9diff --git a/setup-acf.in b/setup-acf.in
10index 5144a21..4f2afec 100644
11--- a/setup-acf.in
12+++ b/setup-acf.in
13@@ -11,7 +11,7 @@ usage() {
14 exit 0;
15 }
16
17-pkgs="acf-core acf-alpine-baselayout acf-apk-tools"
18+pkgs="acf-core acf-alpine-baselayout acf-apk-tools openssl"
19
20 while getopts "ae:hl:n" opt ; do
21 case $opt in