aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 09:54:22 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 13:17:59 +0000
commit6a2548ebf9f70fdf4c367477f3308b3f26a99e38 (patch)
treebc8539f0098c26c7920ffa4c437d87d7a627854c
parent17a04e76bd61d4185c71f3f31227786a17caec74 (diff)
downloadalpine_aports-6a2548ebf9f70fdf4c367477f3308b3f26a99e38.tar.bz2
alpine_aports-6a2548ebf9f70fdf4c367477f3308b3f26a99e38.tar.xz
alpine_aports-6a2548ebf9f70fdf4c367477f3308b3f26a99e38.zip
testing/zbar: upgrade to 0.22
-rw-r--r--testing/zbar/APKBUILD68
-rw-r--r--testing/zbar/imagemagick7.patch23
-rw-r--r--testing/zbar/magickwand.patch147
3 files changed, 74 insertions, 164 deletions
diff --git a/testing/zbar/APKBUILD b/testing/zbar/APKBUILD
index 4bfb2ea26f..d4e725d36c 100644
--- a/testing/zbar/APKBUILD
+++ b/testing/zbar/APKBUILD
@@ -1,37 +1,71 @@
1# Contributor: Leo <thinkabit.ukim@gmail.com>
1# Contributor: Diego Queiroz <diego.queiroz@gmail.com> 2# Contributor: Diego Queiroz <diego.queiroz@gmail.com>
2# Maintainer: Diego Queiroz <diego.queiroz@gmail.com> 3# Maintainer: Diego Queiroz <diego.queiroz@gmail.com>
3pkgname=zbar 4pkgname=zbar
4pkgver=0.10 5pkgver=0.22
5pkgrel=3 6pkgrel=0
6pkgdesc="Port of ZBAR BAR CODE READER" 7pkgdesc="Port of ZBAR BAR CODE READER"
7url="http://zbar.sourceforge.net/" 8url="http://zbar.sourceforge.net/"
8arch="all !aarch64" 9arch="all"
9license="LGPL-2.0-or-later" 10license="LGPL-2.0-or-later"
10depends="py-gobject" 11depends="py-gobject"
11makedepends="imagemagick-dev gtk+-dev py-gtk-dev qt-dev libtool lcms2-dev autoconf python2-dev" 12makedepends="imagemagick-dev gtk+-dev py-gtk-dev qt5-qtx11extras-dev
12install="" 13 lcms2-dev python2-dev automake autoconf libtool xmlto docbook-xsl
13subpackages="$pkgname-dev $pkgname-doc" 14 libxv-dev"
14source="https://sourceforge.net/projects/zbar/files/zbar/$pkgver/zbar-$pkgver.tar.bz2 15subpackages="
15 magickwand.patch 16 $pkgname-dev
17 $pkgname-doc
18 lib$pkgname:zbarlibs
19 lib${pkgname}qt:qtlibs
20 lib${pkgname}gtk:gtklibs
21 py2-${pkgname}:py"
22source="
23 $pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz
24 imagemagick7.patch
16 " 25 "
17 26
18builddir="$srcdir"/zbar-$pkgver
19prepare() { 27prepare() {
20 default_prepare 28 default_prepare
21 update_config_guess 29 autoreconf -fi
22 autoconf
23} 30}
24 31
25build() { 32build() {
26 cd "$builddir" 33 ./configure --prefix=/usr --disable-video
27 ./configure --prefix=/usr --disable-video || return 1 34 make
28 make || return 1
29} 35}
30 36
31package() { 37package() {
32 cd "$builddir"
33 make DESTDIR="$pkgdir" install 38 make DESTDIR="$pkgdir" install
39 rm -rf "$pkgdir"/usr/lib/*.a
34} 40}
35 41
36sha512sums="76cb8a469e3ac9ea7932a95c500cf933501249cdb8dce4df558bf5681bd44c62111327b494e6e887079a5fd30b32154887dcc12962e6d27b1453f55457483db4 zbar-0.10.tar.bz2 42zbarlibs() {
37d134c4d44364638250e31d8acf45dc87624bf84005ede95859712e97fa14f7f43347ad488357e48c27c1dd69dacbb454c8dab6a3cd28e4c4c8952f4b950e72f7 magickwand.patch" 43 depends=""
44 pkgdesc="$pkgdesc (library)"
45 mkdir -p "$subpkgdir"/usr/lib
46 mv "$pkgdir"/usr/lib/libzbar.so.* "$subpkgdir"/usr/lib
47}
48
49qtlibs() {
50 depends=""
51 pkgdesc="$pkgdesc (Qt5 library)"
52 mkdir -p "$subpkgdir"/usr/lib
53 mv "$pkgdir"/usr/lib/libzbarqt.so.* "$subpkgdir"/usr/lib
54}
55
56gtklibs() {
57 depends=""
58 pkgdesc="$pkgdesc (Gtk+2 library)"
59 mkdir -p "$subpkgdir"/usr/lib
60 mv "$pkgdir"/usr/lib/libzbargtk.so.* "$subpkgdir"/usr/lib
61}
62
63py() {
64 depends=""
65 pkgdesc="python2 bindings for ZBar"
66 mkdir -p "$subpkgdir"/usr/lib
67 mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib
68}
69
70sha512sums="bef1078f7fe0c943e2ca7348f45e3bb5744e807c5135051fccf2c4499d52515558e98f61620e2ef2c993f35b8104d886d0639b7f0e6f8979caa5dcc49df7c931 zbar-0.22.tar.gz
7164d97d3c7e3aa0227dea7e152ad70ebb1612b5944cfbbb18c4c77ea5498b0a995d70a9e8953eb6bf93357e38af573b64f8e5020e4f586f6bbdb3f527fc5a6bc5 imagemagick7.patch"
diff --git a/testing/zbar/imagemagick7.patch b/testing/zbar/imagemagick7.patch
new file mode 100644
index 0000000000..b3cbf1e5c4
--- /dev/null
+++ b/testing/zbar/imagemagick7.patch
@@ -0,0 +1,23 @@
1--- zbar-0.10/configure.ac~ 2016-12-20 09:17:33.000000000 +0100
2+++ zbar-0.10/configure.ac 2016-12-20 09:21:38.906665127 +0100
3@@ -333,7 +333,7 @@
4 dnl double check ImageMagick install (bug #2582232)
5 CPPFLAGS_save="$CPPFLAGS"
6 CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
7- AC_CHECK_HEADER([wand/MagickWand.h],
8+ AC_CHECK_HEADER([MagickWand/MagickWand.h],
9 [have_IM="yes"],
10 [have_IM="broken"])
11 CPPFLAGS="$CPPFLAGS_save"])])
12--- zbar-0.10/zbarimg/zbarimg.c.orig 2016-12-20 09:18:15.924187996 +0100
13+++ zbar-0.10/zbarimg/zbarimg.c 2016-12-20 09:20:27.679129140 +0100
14@@ -44,7 +44,7 @@
15 #endif
16
17 #ifdef HAVE_IMAGEMAGICK
18-# include <wand/MagickWand.h>
19+# include <MagickWand/MagickWand.h>
20
21 /* ImageMagick frequently changes API names - just use the original
22 * (more stable?) names to match GraphicsMagick
23
diff --git a/testing/zbar/magickwand.patch b/testing/zbar/magickwand.patch
deleted file mode 100644
index 26c7f8815f..0000000000
--- a/testing/zbar/magickwand.patch
+++ /dev/null
@@ -1,147 +0,0 @@
1diff --git a/configure.ac b/configure.ac
2index 56d3dd0..026dbcd 100644
3--- a/configure.ac
4+++ b/configure.ac
5@@ -285,8 +285,8 @@ $saved_error
6 dnl double check ImageMagick install (bug #2582232)
7 CPPFLAGS_save="$CPPFLAGS"
8 CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
9- AC_CHECK_HEADER([wand/MagickWand.h], [],
10- [AC_MSG_FAILURE([ImageMagick package found but wand/MagickWand.h not installed?!
11+ AC_CHECK_HEADER([MagickWand/MagickWand.h], [],
12+ [AC_MSG_FAILURE([ImageMagick package found but MagicWand/MagickWand.h not installed?!
13 this is a problem with your ImageMagick install,
14 please resolve the inconsistency and try again...])])
15 CPPFLAGS="$CPPFLAGS_save"])
16diff --git a/zbarimg/zbarimg.c b/zbarimg/zbarimg.c
17index 5d2db34..a6bc2d1 100644
18--- a/zbarimg/zbarimg.c
19+++ b/zbarimg/zbarimg.c
20@@ -38,7 +38,7 @@
21 #include <assert.h>
22
23 #include <zbar.h>
24-#include <wand/MagickWand.h>
25+#include <MagickWand/MagickWand.h>
26
27 /* in 6.4.5.4 MagickGetImagePixels changed to MagickExportImagePixels.
28 * (still not sure this check is quite right...
29--- ./configure.orig
30+++ ./configure
31@@ -21741,8 +21741,8 @@
32 CPPFLAGS_save="$CPPFLAGS"
33 CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
34 if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
35- { $as_echo "$as_me:$LINENO: checking for wand/MagickWand.h" >&5
36-$as_echo_n "checking for wand/MagickWand.h... " >&6; }
37+ { $as_echo "$as_me:$LINENO: checking for MagickWand/MagickWand.h" >&5
38+$as_echo_n "checking for MagickWand/MagickWand.h... " >&6; }
39 if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
40 $as_echo_n "(cached) " >&6
41 fi
42@@ -21750,8 +21750,8 @@
43 $as_echo "$ac_cv_header_wand_MagickWand_h" >&6; }
44 else
45 # Is the header compilable?
46-{ $as_echo "$as_me:$LINENO: checking wand/MagickWand.h usability" >&5
47-$as_echo_n "checking wand/MagickWand.h usability... " >&6; }
48+{ $as_echo "$as_me:$LINENO: checking MagickWand/MagickWand.h usability" >&5
49+$as_echo_n "checking MagickWand/MagickWand.h usability... " >&6; }
50 cat >conftest.$ac_ext <<_ACEOF
51 /* confdefs.h. */
52 _ACEOF
53@@ -21759,7 +21759,7 @@
54 cat >>conftest.$ac_ext <<_ACEOF
55 /* end confdefs.h. */
56 $ac_includes_default
57-#include <wand/MagickWand.h>
58+#include <MagickWand/MagickWand.h>
59 _ACEOF
60 rm -f conftest.$ac_objext
61 if { (ac_try="$ac_compile"
62@@ -21792,15 +21792,15 @@
63 $as_echo "$ac_header_compiler" >&6; }
64
65 # Is the header present?
66-{ $as_echo "$as_me:$LINENO: checking wand/MagickWand.h presence" >&5
67-$as_echo_n "checking wand/MagickWand.h presence... " >&6; }
68+{ $as_echo "$as_me:$LINENO: checking MagickWand/MagickWand.h presence" >&5
69+$as_echo_n "checking MagickWand/MagickWand.h presence... " >&6; }
70 cat >conftest.$ac_ext <<_ACEOF
71 /* confdefs.h. */
72 _ACEOF
73 cat confdefs.h >>conftest.$ac_ext
74 cat >>conftest.$ac_ext <<_ACEOF
75 /* end confdefs.h. */
76-#include <wand/MagickWand.h>
77+#include <MagickWand/MagickWand.h>
78 _ACEOF
79 if { (ac_try="$ac_cpp conftest.$ac_ext"
80 case "(($ac_try" in
81@@ -21834,25 +21834,25 @@
82 # So? What about this header?
83 case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
84 yes:no: )
85- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&5
86-$as_echo "$as_me: WARNING: wand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
87- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: proceeding with the compiler's result" >&5
88-$as_echo "$as_me: WARNING: wand/MagickWand.h: proceeding with the compiler's result" >&2;}
89+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&5
90+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
91+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: proceeding with the compiler's result" >&5
92+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: proceeding with the compiler's result" >&2;}
93 ac_header_preproc=yes
94 ;;
95 no:yes:* )
96- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: present but cannot be compiled" >&5
97-$as_echo "$as_me: WARNING: wand/MagickWand.h: present but cannot be compiled" >&2;}
98- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: check for missing prerequisite headers?" >&5
99-$as_echo "$as_me: WARNING: wand/MagickWand.h: check for missing prerequisite headers?" >&2;}
100- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: see the Autoconf documentation" >&5
101-$as_echo "$as_me: WARNING: wand/MagickWand.h: see the Autoconf documentation" >&2;}
102- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&5
103-$as_echo "$as_me: WARNING: wand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&2;}
104- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: proceeding with the preprocessor's result" >&5
105-$as_echo "$as_me: WARNING: wand/MagickWand.h: proceeding with the preprocessor's result" >&2;}
106- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: in the future, the compiler will take precedence" >&5
107-$as_echo "$as_me: WARNING: wand/MagickWand.h: in the future, the compiler will take precedence" >&2;}
108+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: present but cannot be compiled" >&5
109+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: present but cannot be compiled" >&2;}
110+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: check for missing prerequisite headers?" >&5
111+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: check for missing prerequisite headers?" >&2;}
112+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: see the Autoconf documentation" >&5
113+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: see the Autoconf documentation" >&2;}
114+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&5
115+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&2;}
116+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: proceeding with the preprocessor's result" >&5
117+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: proceeding with the preprocessor's result" >&2;}
118+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: in the future, the compiler will take precedence" >&5
119+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: in the future, the compiler will take precedence" >&2;}
120 ( cat <<\_ASBOX
121 ## ------------------------------------------- ##
122 ## Report this to spadix@users.sourceforge.net ##
123@@ -21861,8 +21861,8 @@
124 ) | sed "s/^/$as_me: WARNING: /" >&2
125 ;;
126 esac
127-{ $as_echo "$as_me:$LINENO: checking for wand/MagickWand.h" >&5
128-$as_echo_n "checking for wand/MagickWand.h... " >&6; }
129+{ $as_echo "$as_me:$LINENO: checking for MagickWand/MagickWand.h" >&5
130+$as_echo_n "checking for MagickWand/MagickWand.h... " >&6; }
131 if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
132 $as_echo_n "(cached) " >&6
133 else
134@@ -21877,11 +21877,11 @@
135 else
136 { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
137 $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
138-{ { $as_echo "$as_me:$LINENO: error: ImageMagick package found but wand/MagickWand.h not installed?!
139+{ { $as_echo "$as_me:$LINENO: error: ImageMagick package found but MagickWand/MagickWand.h not installed?!
140 this is a problem with your ImageMagick install,
141 please resolve the inconsistency and try again...
142 See \`config.log' for more details." >&5
143-$as_echo "$as_me: error: ImageMagick package found but wand/MagickWand.h not installed?!
144+$as_echo "$as_me: error: ImageMagick package found but MagickWand/MagickWand.h not installed?!
145 this is a problem with your ImageMagick install,
146 please resolve the inconsistency and try again...
147 See \`config.log' for more details." >&2;}