aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-09 15:23:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-09 15:23:43 +0000
commit709ce9b8faa6c4e2c32ecb99d9fe005b4ca92f42 (patch)
tree973f49410260e8aafd7a910efef5dcab519fd8ad
parent9752dac0cd60fb83864076111dd1fa210af4cc32 (diff)
downloadalpine_aports-709ce9b8faa6c4e2c32ecb99d9fe005b4ca92f42.tar.bz2
alpine_aports-709ce9b8faa6c4e2c32ecb99d9fe005b4ca92f42.tar.xz
alpine_aports-709ce9b8faa6c4e2c32ecb99d9fe005b4ca92f42.zip
main/libvpx: fix permissions
-rw-r--r--main/libvpx/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/main/libvpx/APKBUILD b/main/libvpx/APKBUILD
index 80d1e539e6..5b4e5d66df 100644
--- a/main/libvpx/APKBUILD
+++ b/main/libvpx/APKBUILD
@@ -2,7 +2,7 @@
2pkgname=libvpx 2pkgname=libvpx
3pkgver=1.3.0 3pkgver=1.3.0
4_ver=${pkgver/_/-} 4_ver=${pkgver/_/-}
5pkgrel=0 5pkgrel=1
6pkgdesc="Library for the vp8 codec" 6pkgdesc="Library for the vp8 codec"
7url="http://www.webmproject.org/" 7url="http://www.webmproject.org/"
8arch="all" 8arch="all"
@@ -42,7 +42,9 @@ build() {
42package() { 42package() {
43 cd "$_builddir" 43 cd "$_builddir"
44 make DIST_DIR="$pkgdir"/usr install 44 make DIST_DIR="$pkgdir"/usr install
45 chmod 644 "$pkgdir"/usr/include/vpx/*.h 45 chmod 644 "$pkgdir"/usr/include/vpx/*.h || return 1
46 chown root:root -R "$pkgdir" || return 1
47 chmod 755 "$pkgdir"/usr/lib/* || return 1
46} 48}
47 49
48utils() { 50utils() {