aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-01 09:33:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-01 09:33:03 +0000
commit75ef48f5f750a8ee02bd3105c75ecbe3e8611b39 (patch)
tree85d734873931b1f6782a6e11f5e77e39815b9e7e
parente7718143a8be28ea09de03a661fa44c63529fd3c (diff)
downloadalpine_aports-75ef48f5f750a8ee02bd3105c75ecbe3e8611b39.tar.bz2
alpine_aports-75ef48f5f750a8ee02bd3105c75ecbe3e8611b39.tar.xz
alpine_aports-75ef48f5f750a8ee02bd3105c75ecbe3e8611b39.zip
main/strace: upgrade to 4.9
-rw-r--r--main/strace/APKBUILD22
-rw-r--r--main/strace/strace-musl.patch190
-rw-r--r--main/strace/sysinfo.patch12
-rw-r--r--main/strace/uclibc-fix.patch12
4 files changed, 21 insertions, 215 deletions
diff --git a/main/strace/APKBUILD b/main/strace/APKBUILD
index 1000b12be2..d8b1200c0f 100644
--- a/main/strace/APKBUILD
+++ b/main/strace/APKBUILD
@@ -1,7 +1,7 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=strace 2pkgname=strace
3pkgver=4.8 3pkgver=4.9
4pkgrel=4 4pkgrel=0
5pkgdesc="A useful diagnositic, instructional, and debugging tool" 5pkgdesc="A useful diagnositic, instructional, and debugging tool"
6url="http://sourceforge.net/projects/strace/" 6url="http://sourceforge.net/projects/strace/"
7arch="all" 7arch="all"
@@ -10,8 +10,7 @@ depends=
10makedepends= 10makedepends=
11subpackages="$pkgname-doc" 11subpackages="$pkgname-doc"
12source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.xz 12source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.xz
13 strace-musl.patch 13 sysinfo.patch
14 uclibc-fix.patch
15 " 14 "
16 15
17_builddir="$srcdir/$pkgname-$pkgver" 16_builddir="$srcdir/$pkgname-$pkgver"
@@ -44,12 +43,9 @@ package() {
44 cd "$srcdir/$pkgname-$pkgver" 43 cd "$srcdir/$pkgname-$pkgver"
45 make -j1 DESTDIR="$pkgdir" install 44 make -j1 DESTDIR="$pkgdir" install
46} 45}
47md5sums="c575ef43829586801f514fd91bfe7575 strace-4.8.tar.xz 46md5sums="885eafadb10f6c60464a266d3929a2a4 strace-4.9.tar.xz
484dca5e173da85798ad4d628774db6053 strace-musl.patch 47ed853f7bc7b87cc598f1a2c65ca09165 sysinfo.patch"
494906d85aaf996831cca1dcbd13f3f5b5 uclibc-fix.patch" 48sha256sums="095bfea5c540b91d297ccac73b21b92fd54a24599fd70395db87ff9eb7fd6f65 strace-4.9.tar.xz
50sha256sums="f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8 strace-4.8.tar.xz 49727b2d56ebf4941726c21ea77bbde5b841581f4a5bde8c2954937032ee05b93b sysinfo.patch"
5147875682d64258806b76202c9d05f9b0547a93dca52bfb4d1fb62cd3993771cd strace-musl.patch 50sha512sums="70d03b74067ad03940cda72dc057a44a8a33fc55790a8a3bfffb1c4d7442c2de7f3e975a01dc7c7b0430342e492579b2f3a007242d13c8a0feba1a1989f42b7b strace-4.9.tar.xz
52b089fc949aab33d791acb5939ef64cc74726fa0e599300be4fcb41ca005be78f uclibc-fix.patch" 51d0da5ed3eb1cee04d07297253445725c86abb55f0f4b80e3e1b7587c581a8c252e895dd7d8a32f410e457c5382194d1b27682215d0304e1dd7ebc8d69cb8e4e7 sysinfo.patch"
53sha512sums="c3316382f60cd4d02eec1eef46a0ef2d000afbccf2c176a6fec652e1b3391685f0e33f184497cb3ccf54d72d460471a4945d3a864fb5bce1f45f32fdf132cfe3 strace-4.8.tar.xz
5479cf73c292afe8ed6a78792f32a763bb39ba643f3696f0931867a6e93fb0f32ee1833e872c54bf5509c50dc382999202de677f37242356952df5dee367b0cc50 strace-musl.patch
55672b5b240bd79ca0b7145cda33e29d9aea4067ff78eae993062381010868a5e31d2d58fc3329dfa5dbe76f029a057710489d50ba6a104adc727f287704622125 uclibc-fix.patch"
diff --git a/main/strace/strace-musl.patch b/main/strace/strace-musl.patch
deleted file mode 100644
index b0fb3f9cbd..0000000000
--- a/main/strace/strace-musl.patch
+++ /dev/null
@@ -1,190 +0,0 @@
1--- strace-4.8.orig/defs.h
2+++ strace-4.8/defs.h
3@@ -155,7 +155,7 @@
4 || defined(METAG) \
5 || defined(TILE) \
6 || defined(XTENSA) \
7- ) && defined(__GLIBC__)
8+ ) && defined(__linux__)
9 # include <sys/ptrace.h>
10 #else
11 /* Work around awkward prototype in ptrace.h. */
12@@ -222,7 +222,7 @@
13 # define PTRACE_EVENT_EXIT 6
14 #endif
15
16-#if !defined(__GLIBC__)
17+#if !defined(__GLIBC__) && !defined(PTRACE_PEEKUSER)
18 # define PTRACE_PEEKUSER PTRACE_PEEKUSR
19 # define PTRACE_POKEUSER PTRACE_POKEUSR
20 #endif
21--- strace-4.8.orig/desc.c
22+++ strace-4.8/desc.c
23@@ -299,7 +299,7 @@
24 #ifdef X32
25 tprintf(", start=%lld, len=%lld", fl.l_start, fl.l_len);
26 #else
27- tprintf(", start=%ld, len=%ld", fl.l_start, fl.l_len);
28+ tprintf(", start=%ld, len=%ld", (long) fl.l_start, (long) fl.l_len);
29 #endif
30 if (getlk)
31 tprintf(", pid=%lu}", (unsigned long) fl.l_pid);
32--- strace-4.8.orig/file.c
33+++ strace-4.8/file.c
34@@ -632,7 +632,7 @@
35 return 0;
36 }
37
38-#if _LFS64_LARGEFILE
39+#if defined _LFS64_LARGEFILE || defined HAVE_LONG_LONG_OFF_T
40 int
41 sys_truncate64(struct tcb *tcp)
42 {
43@@ -654,7 +654,7 @@
44 return 0;
45 }
46
47-#if _LFS64_LARGEFILE
48+#if defined _LFS64_LARGEFILE || defined HAVE_LONG_LONG_OFF_T
49 int
50 sys_ftruncate64(struct tcb *tcp)
51 {
52@@ -2322,7 +2322,7 @@
53 return 0;
54 }
55
56-#if _LFS64_LARGEFILE
57+#if defined _LFS64_LARGEFILE || defined HAVE_LONG_LONG_OFF_T
58 int
59 sys_getdents64(struct tcb *tcp)
60 {
61--- strace-4.8.orig/net.c
62+++ strace-4.8/net.c
63@@ -95,12 +95,14 @@
64 #endif
65
66 /* Under Linux these are enums so we can't test for them with ifdef. */
67+#if !defined(IPPROTO_MAX)
68 #define IPPROTO_EGP IPPROTO_EGP
69 #define IPPROTO_PUP IPPROTO_PUP
70 #define IPPROTO_IDP IPPROTO_IDP
71 #define IPPROTO_IGMP IPPROTO_IGMP
72 #define IPPROTO_RAW IPPROTO_RAW
73 #define IPPROTO_MAX IPPROTO_MAX
74+#endif
75
76 static const struct xlat domains[] = {
77 #ifdef PF_UNSPEC
78--- strace-4.8.orig/process.c
79+++ strace-4.8/process.c
80@@ -55,7 +55,7 @@
81 # endif
82 #endif
83
84-#ifdef HAVE_LINUX_PTRACE_H
85+#if defined HAVE_LINUX_PTRACE_H && defined __GLIBC__
86 # undef PTRACE_SYSCALL
87 # ifdef HAVE_STRUCT_IA64_FPREG
88 # define ia64_fpreg XXX_ia64_fpreg
89@@ -2857,7 +2857,7 @@
90 if (umove(tcp, tcp->u_arg[2], &p) < 0)
91 tprintf(", %#lx", tcp->u_arg[2]);
92 else
93- tprintf(", { %d }", p.__sched_priority);
94+ tprintf(", { %d }", p.sched_priority);
95 }
96 return 0;
97 }
98@@ -2872,7 +2872,7 @@
99 if (umove(tcp, tcp->u_arg[1], &p) < 0)
100 tprintf("%#lx", tcp->u_arg[1]);
101 else
102- tprintf("{ %d }", p.__sched_priority);
103+ tprintf("{ %d }", p.sched_priority);
104 }
105 return 0;
106 }
107@@ -2885,7 +2885,7 @@
108 if (umove(tcp, tcp->u_arg[1], &p) < 0)
109 tprintf("%d, %#lx", (int) tcp->u_arg[0], tcp->u_arg[1]);
110 else
111- tprintf("%d, { %d }", (int) tcp->u_arg[0], p.__sched_priority);
112+ tprintf("%d, { %d }", (int) tcp->u_arg[0], p.sched_priority);
113 }
114 return 0;
115 }
116--- strace-4.8.orig/signal.c
117+++ strace-4.8/signal.c
118@@ -59,6 +59,7 @@
119 #ifdef IA64
120 # include <asm/ptrace_offsets.h>
121 #endif
122+#include <asm/ptrace.h>
123
124 #if defined(SPARC) || defined(SPARC64) || defined(MIPS)
125 typedef struct {
126--- strace-4.8.orig/strace.c
127+++ strace-4.8/strace.c
128@@ -506,7 +506,7 @@
129 perror_msg_and_die("dup2");
130 close(fds[0]);
131 }
132- execl(_PATH_BSHELL, "sh", "-c", command, NULL);
133+ execl(_PATH_BSHELL, "sh", "-c", command, (void*) 0);
134 perror_msg_and_die("Can't execute '%s'", _PATH_BSHELL);
135 }
136
137--- strace-4.8.orig/syscall.c
138+++ strace-4.8/syscall.c
139@@ -72,13 +72,7 @@
140 # include <elf.h>
141 #endif
142
143-#if defined(AARCH64)
144-# include <asm/ptrace.h>
145-#endif
146-
147-#if defined(XTENSA)
148-# include <asm/ptrace.h>
149-#endif
150+#include <asm/ptrace.h>
151
152 #ifndef ERESTARTSYS
153 # define ERESTARTSYS 512
154--- strace-4.8.orig/time.c
155+++ strace-4.8/time.c
156@@ -774,7 +774,11 @@
157 /* _pad[0] is the _tid field which might not be
158 present in the userlevel definition of the
159 struct. */
160+#if defined(__GLIBC__)
161 tprintf("{%d}", sev._sigev_un._pad[0]);
162+#else
163+ tprintf("{%d}", (int) sev.__pad[0]);
164+#endif
165 else if (sev.sigev_notify == SIGEV_THREAD)
166 tprintf("{%p, %p}", sev.sigev_notify_function,
167 sev.sigev_notify_attributes);
168--- ./resource.c.orig
169+++ ./resource.c
170@@ -31,6 +31,7 @@
171 #include "defs.h"
172 #include <sys/resource.h>
173 #include <sys/times.h>
174+#include <sys/sysinfo.h>
175 #include <linux/kernel.h>
176
177 static const struct xlat resources[] = {
178--- strace-4.8.org/process.c
179+++ strace-4.8/process.c
180@@ -91,6 +91,10 @@
181 # include <asm/rse.h>
182 #endif
183
184+#ifdef __arm__
185+#include <asm/ptrace.h>
186+#endif
187+
188 #ifdef HAVE_PRCTL
189 # include <sys/prctl.h>
190
diff --git a/main/strace/sysinfo.patch b/main/strace/sysinfo.patch
new file mode 100644
index 0000000000..1a655d629c
--- /dev/null
+++ b/main/strace/sysinfo.patch
@@ -0,0 +1,12 @@
1diff --git a/resource.c b/resource.c
2index 12e218f..2b72ee2 100644
3--- a/resource.c
4+++ b/resource.c
5@@ -31,6 +31,7 @@
6 #include "defs.h"
7 #include <sys/resource.h>
8 #include <sys/times.h>
9+#include <sys/sysinfo.h>
10 #include <linux/kernel.h>
11
12 #include "xlat/resources.h"
diff --git a/main/strace/uclibc-fix.patch b/main/strace/uclibc-fix.patch
deleted file mode 100644
index 1265df76ce..0000000000
--- a/main/strace/uclibc-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1--- ./resource.c.orig 2014-03-26 10:51:41.868389136 +0000
2+++ ./resource.c 2014-03-26 10:52:15.395449771 +0000
3@@ -31,7 +31,9 @@
4 #include "defs.h"
5 #include <sys/resource.h>
6 #include <sys/times.h>
7+#ifndef __GLIBC__
8 #include <sys/sysinfo.h>
9+#endif
10 #include <linux/kernel.h>
11
12 static const struct xlat resources[] = {