aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-29 12:50:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-29 12:50:08 +0000
commit87d28613b8a0b2e8f3ccaa7ed5ad689a25d1a852 (patch)
tree29ca799b34d4596c54f55e071360e4ad9a74ffda
parent96b8a98c97a7ab84bb6f59e3eb4da0a65c434f99 (diff)
downloadalpine_aports-87d28613b8a0b2e8f3ccaa7ed5ad689a25d1a852.tar.bz2
alpine_aports-87d28613b8a0b2e8f3ccaa7ed5ad689a25d1a852.tar.xz
alpine_aports-87d28613b8a0b2e8f3ccaa7ed5ad689a25d1a852.zip
main/bluez: upgrade to 5.9 and remove bluez5
-rw-r--r--main/bluez/APKBUILD79
-rw-r--r--main/bluez/bluetooth.initd17
-rw-r--r--main/bluez5/APKBUILD75
-rw-r--r--main/bluez5/bluetooth.initd25
-rw-r--r--main/bluez5/rfcomm.confd5
-rw-r--r--main/bluez5/rfcomm.initd27
6 files changed, 35 insertions, 193 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 82ba644649..5b42547488 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,56 +1,33 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org> 1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=bluez 2pkgname=bluez
3pkgver=4.101 3pkgver=5.9
4pkgrel=3 4pkgrel=0
5pkgdesc="Tools for the Bluetooth protocol stack" 5pkgdesc="Tools for the Bluetooth protocol stack"
6url="http://www.bluez.org/" 6url="http://www.bluez.org/"
7arch="all" 7arch="all"
8license="GPL2" 8license="GPL2"
9depends="consolekit dbus" 9depends="consolekit dbus"
10replaces="udev" 10replaces="udev"
11makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev 11makedepends="dbus-dev libusb-compat-dev udev-dev
12 consolekit-dev udev-dev" 12 libical-dev readline-dev glib-dev"
13subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-alsa 13subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
14 $pkgname-cups $pkgname-gstreamer $pkgname-hid2hci" 14 $pkgname-hid2hci"
15source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2 15source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.bz2
16 fix-includes.patch
17 bluetooth.initd 16 bluetooth.initd
18 rfcomm.initd 17 rfcomm.initd
19 rfcomm.confd 18 rfcomm.confd
20 " 19 "
21 20
22_builddir="$srcdir"/$pkgname-$pkgver 21_builddir="$srcdir"/bluez-$pkgver
23
24prepare() {
25 cd "$_builddir"
26 update_config_sub || return 1
27 for i in $source; do
28 case $i in
29 *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
30 esac
31 done
32}
33
34build() { 22build() {
35 cd "$_builddir" 23 cd "$_builddir"
36 ./configure \ 24 ./configure --prefix=/usr \
37 --build=$CBUILD \
38 --host=$CHOST \
39 --prefix=/usr \
40 --sysconfdir=/etc \ 25 --sysconfdir=/etc \
41 --localstatedir=/var \ 26 --localstatedir=/var \
27 --libexecdir=/usr/lib \
42 --mandir=/usr/share/man \ 28 --mandir=/usr/share/man \
43 --enable-gstreamer \ 29 --disable-systemd \
44 --enable-alsa \ 30 --enable-library \
45 --enable-usb \
46 --enable-tools \
47 --enable-bccmd \
48 --enable-hid2hci \
49 --enable-dfutool \
50 --enable-hidd \
51 --enable-pand \
52 --enable-dund \
53 --enable-cups \
54 || return 1 31 || return 1
55 make || return 1 32 make || return 1
56} 33}
@@ -58,8 +35,7 @@ build() {
58package() { 35package() {
59 cd "$_builddir" 36 cd "$_builddir"
60 make install DESTDIR="$pkgdir" || return 1 37 make install DESTDIR="$pkgdir" || return 1
61 rm "$pkgdir"/usr/lib/*/*.la \ 38 rm "$pkgdir"/usr/lib/*.la || return 1
62 "$pkgdir"/usr/lib/*.la || return 1
63 install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth 39 install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
64 install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm 40 install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
65 install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm 41 install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
@@ -72,26 +48,12 @@ libs() {
72 mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/ 48 mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
73} 49}
74 50
75alsa() {
76 pkgdesc="Bluez plugin for ALSA"
77 mkdir -p "$subpkgdir"/usr/share "$subpkgdir"/usr/lib
78 mv "$pkgdir"/usr/share/alsa* "$subpkgdir"/usr/share/ || return 1
79 mv "$pkgdir"/usr/lib/alsa* "$subpkgdir"/usr/lib/
80}
81
82cups() { 51cups() {
83 pkgdesc="Bluez backend for CUPS" 52 pkgdesc="Bluez backend for CUPS"
84 mkdir -p "$subpkgdir"/usr/lib/ 53 mkdir -p "$subpkgdir"/usr/lib/
85 mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/ 54 mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
86} 55}
87 56
88gstreamer() {
89 pkgdesc="Bluez plugin for gstreamer"
90 mkdir -p "$subpkgdir"/usr/lib
91 mv "$pkgdir"/usr/lib/gstreamer* \
92 "$subpkgdir"/usr/lib/
93}
94
95hid2hci() { 57hid2hci() {
96 pkgdesc="Put HID proxying bluetooth HCI's into HCI mode" 58 pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
97 replaces="bluez" 59 replaces="bluez"
@@ -99,18 +61,15 @@ hid2hci() {
99 mv "$pkgdir"/lib "$subpkgdir"/ 61 mv "$pkgdir"/lib "$subpkgdir"/
100} 62}
101 63
102md5sums="902b390af95c6c5d6d1a17d94c8344ab bluez-4.101.tar.bz2 64md5sums="6edaf60d09ee32942a739f80ea847db1 bluez-5.9.tar.bz2
103664785224a0f8d678f527c2a4940fc9d fix-includes.patch 657a5611fa2cf42da2e844f96b2efa9f3b bluetooth.initd
104701636b72c4fb72b1d81a050471b130c bluetooth.initd
1057672edb8e33c4495ee9febb9864feb10 rfcomm.initd 667672edb8e33c4495ee9febb9864feb10 rfcomm.initd
1067f4bb093adb0f519c621f2ea68712f35 rfcomm.confd" 677f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
107sha256sums="88f170b52119d576281a20ee98d65319b52cf4fb71aa7a7af1c9e928779baaa0 bluez-4.101.tar.bz2 68sha256sums="40a408bc535c19ac544895cfa24984659d8e338e58c729fb3ed8c4634e7c23ac bluez-5.9.tar.bz2
1086aba767ec14dae7e7f8d9ac5ab6b6600f4c0559d7bf368b6bbfaa5374ed6ee54 fix-includes.patch 69d4aef203e184bef4284b3719268c91e07a1e3f84cbdea2ac8ab40a2617ac9186 bluetooth.initd
109547ad2659d508fb6f4080aed078cb4811b3feda84f677afff64bf92f7fc9bea8 bluetooth.initd
1104430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd 704430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
111672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd" 71672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
112sha512sums="a47c3e0943ae50adbcc78b00b4f170f0de8ff12672468e5e09897a669df061b97d99a13b3871f8ec9a85785c3e2839ea2c64e304cb9dd632e33244c222684e1a bluez-4.101.tar.bz2 72sha512sums="025d7b8c688c16d13e33f803c339f0c64b1247df43ed483dba31a62fe3521c5bec24a4516a7c13304492c632ed413638c0d308333ceedeaed31a92f8cdb3204b bluez-5.9.tar.bz2
113be356e156e96f440f6506235b103efb8d835acf7a5a8f061553619b8bac8549288444e2ca86199a81cba87df12297e1d589403e1afef15c4b93fe0ee229a1bc7 fix-includes.patch 732c13cde6561c5aa8b2f27306851458966c67853f6ac2358d09019fda14d3d8e3ff6d9f1c90512c67063d1e1954ec05bf117c5fafc7716446cc5786e9cc12c49f bluetooth.initd
114f648437b9fbc9789fc3d83b544458759236be7f99d5d6029dc38e81660b1c129b2055b62fad86e4e833cb43a040bf59e5fc1ddf95e0d832e13df23775961cf06 bluetooth.initd
1158f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd 748f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
116a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd" 75a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"
diff --git a/main/bluez/bluetooth.initd b/main/bluez/bluetooth.initd
index d9d5d9c917..a3eab5628d 100644
--- a/main/bluez/bluetooth.initd
+++ b/main/bluez/bluetooth.initd
@@ -1,10 +1,25 @@
1#!/sbin/runscript 1#!/sbin/runscript
2 2
3name="Bluetooth" 3name="Bluetooth"
4command="/usr/sbin/bluetoothd" 4command="/usr/lib/bluetooth/bluetoothd"
5pidfile="/var/run/bluetoothd.pid"
6start_stop_daemon_args="--background --make-pidfile"
7
5 8
6depend() { 9depend() {
7 after coldplug 10 after coldplug
8 need dbus localmount 11 need dbus localmount
9} 12}
10 13
14start_post() {
15 local adapter
16 eindent
17 for adapter in $AUTO_ENABLE; do
18 ebegin "Enabling $adapter"
19 hciconfig $adapter up
20 eend
21 done
22 eoutdent
23 return 0
24}
25
diff --git a/main/bluez5/APKBUILD b/main/bluez5/APKBUILD
deleted file mode 100644
index f59c31a995..0000000000
--- a/main/bluez5/APKBUILD
+++ /dev/null
@@ -1,75 +0,0 @@
1# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
2pkgname=bluez5
3pkgver=5.9
4pkgrel=0
5pkgdesc="Tools for the Bluetooth protocol stack"
6url="http://www.bluez.org/"
7arch="all"
8license="GPL2"
9depends="consolekit dbus"
10replaces="udev"
11makedepends="dbus-dev libusb-compat-dev udev-dev
12 libical-dev readline-dev glib-dev"
13subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
14 $pkgname-hid2hci"
15source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.bz2
16 bluetooth.initd
17 rfcomm.initd
18 rfcomm.confd
19 "
20
21_builddir="$srcdir"/bluez-$pkgver
22build() {
23 cd "$_builddir"
24 ./configure --prefix=/usr \
25 --sysconfdir=/etc \
26 --localstatedir=/var \
27 --libexecdir=/usr/lib \
28 --mandir=/usr/share/man \
29 --disable-systemd \
30 --enable-library \
31 || return 1
32 make || return 1
33}
34
35package() {
36 cd "$_builddir"
37 make install DESTDIR="$pkgdir" || return 1
38 rm "$pkgdir"/usr/lib/*.la || return 1
39 install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
40 install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
41 install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
42 install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
43}
44
45libs() {
46 pkgdesc="Libraries for Bluetooth protocol stack"
47 mkdir -p "$subpkgdir"/usr/lib
48 mv "$pkgdir"/usr/lib/libbluetooth.so.* "$subpkgdir"/usr/lib/
49}
50
51cups() {
52 pkgdesc="Bluez backend for CUPS"
53 mkdir -p "$subpkgdir"/usr/lib/
54 mv "$pkgdir"/usr/lib/cups "$subpkgdir"/usr/lib/
55}
56
57hid2hci() {
58 pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
59 replaces="bluez"
60 mkdir -p "$subpkgdir"
61 mv "$pkgdir"/lib "$subpkgdir"/
62}
63
64md5sums="6edaf60d09ee32942a739f80ea847db1 bluez-5.9.tar.bz2
657a5611fa2cf42da2e844f96b2efa9f3b bluetooth.initd
667672edb8e33c4495ee9febb9864feb10 rfcomm.initd
677f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
68sha256sums="40a408bc535c19ac544895cfa24984659d8e338e58c729fb3ed8c4634e7c23ac bluez-5.9.tar.bz2
69d4aef203e184bef4284b3719268c91e07a1e3f84cbdea2ac8ab40a2617ac9186 bluetooth.initd
704430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
71672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
72sha512sums="025d7b8c688c16d13e33f803c339f0c64b1247df43ed483dba31a62fe3521c5bec24a4516a7c13304492c632ed413638c0d308333ceedeaed31a92f8cdb3204b bluez-5.9.tar.bz2
732c13cde6561c5aa8b2f27306851458966c67853f6ac2358d09019fda14d3d8e3ff6d9f1c90512c67063d1e1954ec05bf117c5fafc7716446cc5786e9cc12c49f bluetooth.initd
748f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
75a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"
diff --git a/main/bluez5/bluetooth.initd b/main/bluez5/bluetooth.initd
deleted file mode 100644
index a3eab5628d..0000000000
--- a/main/bluez5/bluetooth.initd
+++ /dev/null
@@ -1,25 +0,0 @@
1#!/sbin/runscript
2
3name="Bluetooth"
4command="/usr/lib/bluetooth/bluetoothd"
5pidfile="/var/run/bluetoothd.pid"
6start_stop_daemon_args="--background --make-pidfile"
7
8
9depend() {
10 after coldplug
11 need dbus localmount
12}
13
14start_post() {
15 local adapter
16 eindent
17 for adapter in $AUTO_ENABLE; do
18 ebegin "Enabling $adapter"
19 hciconfig $adapter up
20 eend
21 done
22 eoutdent
23 return 0
24}
25
diff --git a/main/bluez5/rfcomm.confd b/main/bluez5/rfcomm.confd
deleted file mode 100644
index d87acdb282..0000000000
--- a/main/bluez5/rfcomm.confd
+++ /dev/null
@@ -1,5 +0,0 @@
1# Bind rfcomm devices (allowed values are "true" and "false")
2RFCOMM_ENABLE=true
3
4# Config file for rfcomm
5RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/main/bluez5/rfcomm.initd b/main/bluez5/rfcomm.initd
deleted file mode 100644
index d3b819e1ab..0000000000
--- a/main/bluez5/rfcomm.initd
+++ /dev/null
@@ -1,27 +0,0 @@
1#!/sbin/runscript
2# Copyright 1999-2011 Gentoo Foundation
3# Distributed under the terms of the GNU General Public License v2
4# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/rfcomm-init.d,v 1.1 2011/12/31 21:09:18 pacho Exp $
5
6depend() {
7 after coldplug
8 need dbus localmount hostname
9}
10
11start() {
12 if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
13 if [ -f "${RFCOMM_CONFIG}" ]; then
14 ebegin "Starting rfcomm"
15 /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
16 eend $?
17 else
18 ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
19 fi
20 fi
21}
22
23stop() {
24 ebegin "Shutting down rfcomm"
25 /usr/bin/rfcomm release all
26 eend $?
27}