aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-10-10 16:58:00 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-10-11 18:59:29 +0000
commit88959ae83e0f2f52b3f292fb985d74a5d86479be (patch)
tree47c2fbc3cdcc2714d314778b6a2485b411106a5f
parentfec90030dcb1fbb305d725215b027d4b3e6973cb (diff)
downloadalpine_aports-88959ae83e0f2f52b3f292fb985d74a5d86479be.tar.bz2
alpine_aports-88959ae83e0f2f52b3f292fb985d74a5d86479be.tar.xz
alpine_aports-88959ae83e0f2f52b3f292fb985d74a5d86479be.zip
community/py3-joblib: stop shipping tests and vendoring loki and cloudpickle
Resolves #12000
-rw-r--r--community/py3-joblib/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/py3-joblib/APKBUILD b/community/py3-joblib/APKBUILD
index c1f19a04f5..80f0553f9f 100644
--- a/community/py3-joblib/APKBUILD
+++ b/community/py3-joblib/APKBUILD
@@ -2,12 +2,12 @@
2# Maintainer: Bart Ribbers <bribbers@disroot.org> 2# Maintainer: Bart Ribbers <bribbers@disroot.org>
3pkgname=py3-joblib 3pkgname=py3-joblib
4pkgver=0.16.0 4pkgver=0.16.0
5pkgrel=0 5pkgrel=1
6pkgdesc="Computing with Python functions" 6pkgdesc="Computing with Python functions"
7url="http://joblib.readthedocs.org/" 7url="http://joblib.readthedocs.org/"
8arch="noarch !mips !mips64 !s390x" # Blocked by py3-distributed 8arch="noarch !mips !mips64 !s390x" # Blocked by py3-distributed
9license="BSD-3-Clause" 9license="BSD-3-Clause"
10depends="python3 py3-distributed" 10depends="python3 py3-distributed py3-loki py3-cloudpickle"
11makedepends="py3-setuptools cython" 11makedepends="py3-setuptools cython"
12checkdepends="py3-pytest py3-threadpoolctl" 12checkdepends="py3-pytest py3-threadpoolctl"
13source="https://pypi.python.org/packages/source/j/joblib/joblib-$pkgver.tar.gz" 13source="https://pypi.python.org/packages/source/j/joblib/joblib-$pkgver.tar.gz"
@@ -27,6 +27,11 @@ check() {
27 27
28package() { 28package() {
29 python3 setup.py install --prefix=/usr --root="$pkgdir" 29 python3 setup.py install --prefix=/usr --root="$pkgdir"
30
31 # Remove tests and vendored dependencies
32 local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
33 rm -r "$pkgdir"/usr/lib/python$_py3ver/site-packages/joblib/test
34 rm -r "$pkgdir"/usr/lib/python$_py3ver/site-packages/joblib/externals
30} 35}
31 36
32sha512sums="d3784dc831bf9d658a38f84883a58773627f124cbc5b80ea94fc2e5fa4fe1a6950efc1be88711602d7394ef9ba66918b788fd1ae0f4254f2d61a2f9503a2d56e joblib-0.16.0.tar.gz" 37sha512sums="d3784dc831bf9d658a38f84883a58773627f124cbc5b80ea94fc2e5fa4fe1a6950efc1be88711602d7394ef9ba66918b788fd1ae0f4254f2d61a2f9503a2d56e joblib-0.16.0.tar.gz"