aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-31 14:05:44 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-10 15:18:25 +0000
commit8bc47171a0ad2579776504332fb29a3e7e54a515 (patch)
tree3af44c0fe4ca9eff1049b267c023fa163deeafde
parentcb52dc0d47d8328fb1199da109565550e84795d9 (diff)
downloadalpine_aports-8bc47171a0ad2579776504332fb29a3e7e54a515.tar.bz2
alpine_aports-8bc47171a0ad2579776504332fb29a3e7e54a515.tar.xz
alpine_aports-8bc47171a0ad2579776504332fb29a3e7e54a515.zip
community/exfat-utils: modernize
Closes GH-6608
-rw-r--r--community/exfat-utils/APKBUILD30
1 files changed, 7 insertions, 23 deletions
diff --git a/community/exfat-utils/APKBUILD b/community/exfat-utils/APKBUILD
index 6d764cc051..7169d4d430 100644
--- a/community/exfat-utils/APKBUILD
+++ b/community/exfat-utils/APKBUILD
@@ -1,40 +1,24 @@
1# Maintainer: 1# Maintainer: TBK <alpine@jjtc.eu>
2pkgname=exfat-utils 2pkgname=exfat-utils
3pkgver=1.3.0 3pkgver=1.3.0
4pkgrel=0 4pkgrel=1
5pkgdesc="Utilities for exFAT file system" 5pkgdesc="Utilities for exFAT file system"
6url="https://github.com/relan/exfat" 6url="https://github.com/relan/exfat"
7arch="all" 7arch="all"
8license="GPL-2.0+" 8license="GPL-2.0-or-later"
9depends="" 9options="!check" # no test suite
10makedepends=""
11install=""
12subpackages="$pkgname-doc" 10subpackages="$pkgname-doc"
13source="https://github.com/relan/exfat/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz" 11source="https://github.com/relan/exfat/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
14 12
15build() { 13build() {
16 cd "$builddir"
17
18 ./configure \ 14 ./configure \
19 --prefix=/usr \ 15 --prefix=/usr \
20 --sbindir=/usr/bin 16 --sbindir=/usr/sbin
21 make CCFLAGS="${CFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}" 17 make
22}
23
24check() {
25 cd "$builddir"
26 make check
27} 18}
28 19
29package() { 20package() {
30 cd "$builddir"
31 make DESTDIR="$pkgdir" install 21 make DESTDIR="$pkgdir" install
32
33 # Install man pages
34 install -Dm444 dump/dumpexfat.8 "${pkgdir}/usr/share/man/man8/dumpexfat.8"
35 install -m444 fsck/exfatfsck.8 "${pkgdir}/usr/share/man/man8"
36 install -m444 mkfs/mkexfatfs.8 "${pkgdir}/usr/share/man/man8"
37 install -m444 label/exfatlabel.8 "${pkgdir}/usr/share/man/man8"
38} 22}
39 23
40sha512sums="e1c5b708f22e878d7521e3299866bba127145757e3620696ff11b18c8c7d4830522974e8ee4771234b70aa9718295d3433779cf34ca990e28ccc06cbf9325f7e exfat-utils-1.3.0.tar.gz" 24sha512sums="e1c5b708f22e878d7521e3299866bba127145757e3620696ff11b18c8c7d4830522974e8ee4771234b70aa9718295d3433779cf34ca990e28ccc06cbf9325f7e exfat-utils-1.3.0.tar.gz"